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1 Chapter One
xRes S.E . Basics

Overvie w

This chapter covers the basic concepts you need to use xRes S.E. 
effectively. Topics include:

• Essential Terms

• Creating a Swap Disk

• Resolution

• Resizing Documents

• Work Modes

• Working with Multiple Undos

• Local vs. Global Operations



Essential Terms

Document

A document is simply an open file. The relation
between the terms “document” and “file” in 
xRes S.E. is similar to that found in word pro-
cessing; you can open, create, or close a docu-
ment which in turn is saved to a file. 

A document in xRes S.E. consists of one or more
objects (see “Object” below).

Image

An image is a graphic or illustration that you
view using xRes S.E.. An image is viewed within
a document, which can consist of a single object
or multiple objects.

Object

An object is an individual item in a document
and can be moved, altered, and even saved sepa-
rately from the document. 

Editing an object might consist of applying 
a filter to it, painting over it, or any other 
operation that changes the object’s pixel data. 

In xRes S.E., objects in the document are dis-
played in the Objects Window. When an object
is selected, it is called an active object. More
than one object can be active at a time.

A document can contain multiple objects.
Documents with multiple objects are often
reduced to having only one (background) object
when they are exported to other file formats. 

For more information about manipulating
objects, see Chapter Three: Objects. 

Creating a Swap Disk
A swap disk is simply the amount of hard disk
space xRes S.E. can use to edit your document. 

The amount of swap disk space needed depends
on the size of your image, the number of objects
in your image, and the number of undo levels
you plan to use. 

The chart below represents the approximate
amount of swap disk needed for a one-object doc-
ument. For example, if you are using five levels of
undo, you should have swap disk space equaling
approximately twelve times the image size.
xRes S.E. supports up to twenty levels of undo. 
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Reducing the undo levels is the simplest way to
free up swap disk space. This is discussed in “To
Free Swap Disk Space” in this chapter. xRes S.E.
can utilize space up to two swap disks. 

To Create a  Swap Disk

1 Launch xRes S.E..

2 Use the menu command File > Preferences >
Memory.

3 Choose a primary swap disk from the
Primary Swap Disk drop down menu. 
The default setting is Startup. Startup 
uses available disk space on the disk where
the xRes S.E. application is stored.

4 Choose a secondary swap disk from the
Secondary Swap Disk drop down menu.
Startup can be both the primary and 
secondary swap disk.

5 Click OK.

6 Quit and relaunch xRes S.E. for the change
to take effect. 

To Keep Track of S wap Disk Spac e

The size of the image and the amount of disk
space reserved for that image on the swap disk(s)
are always displayed at the bottom left corner 
of the image. In the example below, the image 
is 1.5 MB and the reserved swap disk space is
5.6 MB.

To View the Amount of S wap Disk A vailable

Use the menu command Window > Inspectors >
Info to display the Info Inspector. The number
next to “Free Disk” is the currently available
swap disk space. 

To Free Swap Disk Spac e

If the “Free Disk” amount becomes low, access
the menu command File > Preferences >
Memory and reduce the number of undo levels.
You must always have at least one undo level. 

To free swap disk space without reducing undo
levels, try saving the current file, closing it, then
re-opening the saved file.
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Resolution

Bitmap Images v s. Vector Images

xRes S.E. creates bitmap images (also called
raster images) composed of pixels on a
prearranged grid. xRes S.E. can edit at the pixel
level, either one pixel or multiple pixels at a
time. 

xRes S.E. is ideal for working with continuous-
tone images that is, images that have several dif-
ferent tones, or shades of color. xRes S.E. is also
ideal for creating an image from scratch using
naturally textured brushes. When you edit a pic-
ture in xRes S.E., you alter one or more pixels to
change the appearance of the image. By editing
several pixels at a time, you are changing the
appearance of that section of the image. 

xRes S.E. does not create vector images. A vector
image is different from a bitmap image. A vector
image is an image composed of shapes which are
saved as mathematical relations to each other.
An example of a vector-based image editing
program is Macromedia FreeHand, which can
create and edit straight lines, curves and text.
When these shapes are changed, their relation-
ship to one another is changed; the image is not
saved as a set number of pixels on a prearranged 
grid, but as a series of mathematical relation-
ships, or formulae. 

Vector editing programs are ideal for logos, 
technical illustrations, or images composed 
primarily of distinct lines and shapes. 

Bitmap Image Vector Image

What is Resolution ?

When an image is scanned, the image is broken
into thousands of pixels. Each pixel is typically
encoded as three numbers, corresponding to the
red, green, and blue components of its color in
the RGB color space. Resolution is typically
described as the pixels per square inch (ppi) of
the image, as it is displayed on the monitor.

If two images are the same height and width and
are stored in the same Color Mode (RGB,
CMYK, or Grayscale), the image with the higher
resolution will have the larger file size. 

The following chart shows the size (in
megabytes) of letter, legal, and poster-sized
images of 150 ppi and 300 ppi. Notice that as
the pixels per inch doubles, the file size
quadruples.
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150 ppi 300 ppi

How xRes S.E . Handles Resolution

In xRes S.E., each image document stores its
own resolution. For example, you cannot open 
a 300 ppi (pixels per inch) document at 150 ppi:
it can only be opened at 300 ppi and then
changed to 150 ppi by the menu command
Resize document. This resolution is set when
you create a new document with the menu 
command File > New. The resolution can be
confirmed and changed in an existing document
by the menu command Modify > Resize >
Document. If you copy and paste an image into
an existing xRes S.E. document, the ppi of the
pasted image is converted to the ppi of the 
document. 

Document resolution does not affect how the
image is displayed on screen. For example, a 
600 ppi image is indistinguishable from a 72 ppi
image on screen. It is only when the images 
are printed that you can see the difference 
in resolution. 

Resizing D ocuments
In xRes S.E. you can resize the entire document
or just the image area. You can also choose either
to resize the file proportionately or nonpropor-
tionately.

1 Use the menu command Modify > Resize >
Document.

2 In the upper drop down menu, choose Pixels,
Inches, Centimeters, Picas, Points, or Percent
as the unit of measurement. Percent allows
resizing based on a percentage of the original
document. For example, a value of 50% 
produces a document that is half as big as 
the original; a value of 200% produces a 
document that is twice as big as the original.

As you enter the measurement, the file size
(indicated in the bottom right corner of 
the dialog) is adjusted to match the new
dimensions of the document. 
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To keep the image dimensions proportional,
check the “Fixed Aspect Ratio” preference.
The width will adjust automatically as you
resize the height, and vice versa.

To resize the entire document, check the
“Resize Objects” preference. If this preference
is unchecked, the image is resized but the
individual objects are not. You may want to
leave “Resize Objects” unchecked to access
the maximum amount of image space with-
out resizing the objects.

If you do not check “Resize Objects,” you
may want to create a new background object
that covers the entire image area. See
“Creating New Objects” in Chapter Three:
Objects for more information. If you do not
create a new background object, the new
image space will not be editable.

4 Enter the new resolution of the document in
pixels per inch or pixels per centimeter, as
per your selection in the lower drop-down
menu.

Checking the “Maintain Size” preference will
maintain the current file size of the docu-
ment as you enter a new resolution. For
example, if you check this preference and
change the resolution, the document size (in
pixels) will be adjusted to maintain the same
file size (in megabytes).

5 Click OK. The new file size of the document 
is listed in the bottom left corner of the 
document window.

Work M odes
xRes S.E. supports two document-specific work
modes: Direct Mode and xRes Mode. Direct
Mode is designed for images that are less than 
10 to 20 MB in size and contain less than ten
objects. xRes Mode is designed for images that
are greater than 10 to 20 MB in size or contain
ten or more objects.

The top of the image window indicates the work
mode. If you are in xRes Mode, the word “xRes”
appears at the top of the image window. If you
are in Direct Mode, the word “xRes” does not
appear.

Most of the xRes S.E. User Guide is written 
for work in Direct Mode. See Chapter Nine:
Working in xRes Mode to learn how to convert
images from one mode to another, how to work
in xRes Mode, how operations are different in 
xRes Mode, and how to optimize productivity 
in xRes Mode.

Direct M ode xRes M ode

Use for images Use for images 
under 10-20MB over 10-20 MB

or 10+ objects 

Acts on pixel data Acts on tiles 
of data

Does not require Requires post-
post-processing processing

Supports multiple Supports multiple
undos undos
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Supports plug-in Supports 
filters plug-in filters

Magic Wand Magic Wand
functional non-functional

Bucket functional Bucket non-
functional

Dropping Objects Dropping Objects
functional non-functional

Dropping selections Dropping selec-
functional tions non-

functional

Indexed 256 Color Indexed 256 Color
functional non-functional

Working with Multiple Undos

xRes S.E. offers multiple levels of undo on a per-
object basis. Applying the menu command Edit
> Undo undoes the last operation performed on
the active object. 

As previously noted, an object is a separate com-
ponent of a document and may be moved,
resized, rotated, duplicated, deleted, and edited
independent of the document. See Chapter
T h ree: Objects to learn more about objects.

The number of undo levels can be set from 1 to
20 with the menu command File > Preferences >
Memory. The number of undo levels supported
depends on the size of the image and the avail-
able swap disk space. In general, a large swap
disk and a small file will allow more undo levels
than a small swap disk and a large file. See

“Creating a Swap Disk” in this chapter 
for more information.

The menu command Edit > Undo reverses the
last operation. An operation is any 
command or tool that is applied to pixel data.
For example, applying a filter, creating a selec-
tion, deleting an object, and applying a gradient
are all operations because they affect to the 
pixel data. 

Changing the name of a brush within the
Brushes Palette is not an operation because it
does not affect the pixel data. Deleting a texture
within the Textures Palette is not an operation
because it does not affect the pixel data. These
steps can be undone, but not with the Edit >
Undo command. To change the name of a
brush, re-enter the brush name: to undo a
change to a texture, you must quit xRes S.E. and
relaunch the application so that the last saved
textures are reloaded.

To Undo an O peration

The menu command Edit > Undo reverses the
last operation. To undo the undo, use the menu
command Edit > Redo.

In Direct Mode, applying an object transforma-
tion command (such as skewing an object) pro-
hibits undos before that object transformation
was performed. Object transformation opera-
tions involve changing the size or shape of an
object. Resizing an object, rotating an object,
skewing an object, and flipping an object are all
object transformation commands.

For example, if you apply three filters to an object
and re s i ze it, you will be able to undo the re s i z i n g ,
but you will not be able to undo the filters.
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Local vs. Global Operations
Local operations support multiple levels of undo.
Global operations support only one level of
undo.

Local Operations

Local operations are performed at the object
level and do not change the position, size, or
shape of the object. Local operations support
multiple levels of undo. 

Global Operations

Global operations are operations performed at
the document level that change the position,
size, or shape of an object. Global operations
support only one level of undo.

Understanding the differences between local and
global operations is key to understanding the
undo sequence of xRes S.E.. For example:

• If you apply the following operations: paint
(local), move an object (global), apply a filter
(local), and apply Edit > Undo two times,
you will undo the commands in this order:
filter, paint. Moving the object cannot be
undone because it is a global operation.

• If you move a path point (global) and apply
a filter (local) you can undo the filter but not
the path point because moving a path point
is a global operation, which supports only
one level of undo.

• If you paint (local), apply a filter (local),
create a selection (local), and apply Undo
three times, all three operations are undone
because they are all local operations which
support multiple levels of undo.
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Chapter Two
Opening, Saving, and Exporting Images

Overvie w

This chapter addresses how to open, save, export and import both docu-
ments and individual objects. Topics include:
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• Essential Terms

• Opening Images

• Saving Images

• Exporting Images

• Importing Images

• Acquiring Images

• File Formats



Essential Terms

Channel

A channel stores the color information for an
image; for instance, the R, G, and B channels store
the red, green, and blue information for an image.

Primary Channels

The primary channels of a color mode store the
color information of the image. The primary
channels of the RGB color space are red, green,
and blue.

Alpha Channels

Alpha channels are non-primary channels used
to store intermediate channel operations and spe-
cial effects. Certain file formats retain alpha
channels; others delete the alpha channels.

To learn more about alpha channels, see Chapter
Se ve n: Masks and Channels.

Color M ode

This is the means by which color is repre-
sented in the document: RGB, Grayscale, or
Indexed 256.

To learn more about Color Modes, see 
Chapter Fi ve: Colors.

Selections

Selections mask out an area of an object and are
displayed on screen as a flashing black and white
line or “marquee.”

To learn more about selections, see Chapter
Seven: Masks and Channels..

Opening Images
xRes S.E. can read the following file formats:

• BMP

• GIF

• JPEG

• LRG

• MMI

• PhotoCD

• Photoshop 3.0

• PICT

• PNG

• TGA

• TIFF
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Open

To open a document use the menu command
File > Open. A dialog prompts you to select the
document you wish to open.

Open as LR G

The menu command File > Open as LRG is
used in xRes Mode to open a file while concur-
rently saving it to the LRG file format. 

See Chapter Nine: Working in xRes Mode for
more information.

Saving Images
To save an image use the menu command File >
Sa ve or the menu command File > Sa ve As.

Save

The menu command File > Save saves changes 
to the file that have been made since it was last
saved. The Save Command does not change the
name or format of the document. 

Save As

Use the menu command File > Save As to save
an open document under a different name
and/or a different file format if the document
has only one object. 

To learn how to merge all document objects into
a single object, see Chapter Three: Objects.

If the document has only one object, its file 
format can be changed to BMP, EPS, GIF, JPE G ,
MMI, LRG, Photoshop 3.0, PI C T, PNG, Scitex
C T, TGA, or TIFF with the Sa ve As command.

The Save As command will save the alpha chan-
nels of the document if the file format you are
saving to supports alpha channels.

If the document has more than one object, the
Save As command can only be used to save the
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document to the MMI file format. To save a
multi-object document in a file format besides
MMI, you must use the Export command.

Exporting Images
The menu command File > Export saves a 
copy of a file to a different file format including
file formats of third-party vendors. When you
use the menu command File > Export you are
prompted with a dialog for specifying the docu-
ment format, name, and location. Remember
that using the File > Export command does not
affect the original document. 

An exported document will have all objects
merged and all alpha channels deleted. See
Chapter Nine: Working in xRes Mode to learn
about using the Export command in xRes Mode.

When using the Export command, you can
export the file at a zoom level from 1:1 to 1:64.
For example, exporting a file at a zoom level of
1:2 creates an image that is half the width and
half the height of the original document. 

The Export command is typically used to export
multiple-object MMI files to different file for-

mats. You must use the “Export a multiple-
object document” command to output to any
file format except MMI. The Export command
deletes all alpha channels; to save the alpha 
channels for a particular object, activate that
object and use the “Save Object” command
located in the Objects Window submenu. 
See “Save Object” in Chapter Three: Objects for
more information.

Importing Images
The menu command File > Import imports an
image into the active document as an object.
xRes S.E. can import an image of any file format 
that it can open except MMI.

Acquiring Images

The Acquire command is used to open 
documents that have been acquired using a scan-
ner device. The Acquire command can also use
third-party acquire modcules (also called Import
modules) as described below.

To Use an Import M odule

Use the menu command File > Acquire and
select the import module from the submenu. 
A dialog prompts you to select options based 
on the chosen import module. To use these
modules, follow the instructions that shipped
with the third-party software.
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Scanning Images

When scanning images, you will be prompted 
to enter a resolution for scanning the image. 
If you plan to output the image at a service 
bureau, ask the service bureau for the best 
scanning resolution.

Scanning can produce documents that have
distinct color casts or are too heavy in the 
highlight or shadow areas. Use the Levels or
Curves color correction commands to adjust
color casts. You can save Levels or Curves 
settings for each scanner.

See Chapter Ten: Color Correction to obtain
more information on the Levels and Curves
commands. 

File Formats

BMP

BMP has an advantage over all other file 
formats: it is the official file format for 
Microsoft Windows® images.

BMP is an RGB-only format. It supports
Indexed 256 color documents, as well as
Grayscale and 24-bit RGB documents.

EPS

EPS stands for Encapsulated PostScript.
PostScript is a page layout language that Adobe
Systems developed about fifteen years ago.

PostScript output devices, including all Apple
printers and other desktop laser printers (as well
as document setters), read PostScript files.

EPS documents can contain a preview that is
used by applications such as Quark XPress® to
give a sample representation of the document in
the page layout. For example, if the EPS file has
a preview, Quark XPress does not have to read
the entire document to give you a preview.
This saves considerable processing time. 

When you save to EPS in xRes S.E., you can
choose from two preview types, “None” or
“TIFF.” None means there will be no preview of
the document available; TIFF means a TIFF for-
mat preview of the document will be available. 

In the above example, Quark XPress first gener-
ates its own EPS description of the page then
inserts the EPS document that you saved in 
xRes S.E. as part of the complete EPS document.

xRes S.E. cannot import or open an EPS file; 
it can only export to EPS.

GIF

The GIF format is an 8-bit color format fre-
quently used in on-line services. GIF files are
typically very small, which makes them conve-
nient for uploading and downloading via
modem.

Unisys Corporation (which holds the patent on
the LZW compression used in GIFs) and
CompuServe enforce a licensing fee for GIF files
that are uploaded or downloaded to on-line 
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services. Macromedia advises that you check the
status of this licensing fee before uploading or
downloading GIF files.

xRes S.E. can open and save GIF files. When
saving a GIF file, you may have to convert to the
Indexed 256 color mode (menu command
Modify > Color Mode > Indexed 256).

xRes S.E. also supports the GIF 89 format,
which supports the matte color and void color
used in the Color Index Table. See “Color 
Index Ta b l e” in Chapter Fi ve: Colors for more
i n f o r m a t i o n .

JPEG

JPEG stands for Joint Photographic Experts
Group; it is one of the most efficient compres-
sion file formats. JPEG compression can vary
from high quality (saving a document at low
compression, such as 2:1) to low quality (saving
a document at high compression, such as 100:1).
With high levels of compression, image quality
can suffer. xRes S.E.’s JPEG reader is based on
code provided by the JPEG consortium.
xRes S.E. can read in JPEG documents in all
color modes.

When you Save As a JPEG document, the 
dialog prompts you to specify the quality of 
the compression on a scale of 1 to 100.

A value of 100 maintains the current image qual-
ity. A value of 1 compresses the document as
much as possible and has the greatest loss of
image quality. In-between values have propor-
tional degrees of compression and image quality.

If you are compressing a document for serious
production work, Macromedia recommends that
you set the JPEG quality between 50 and 100. 
If the file will be displayed only on a monitor
and not used in print, you can use higher 
compression and still get satisfactory results.

LRG

The LRG document format was designed by
Fauve Software (now part of Macromedia) to
specifically address the issue of saving a large
document (10 to 20 MB or larger). An LRG
document is stored in a series of tiles, making 
it easy to rapidly access the image data. LRG
documents are automatically opened in xRes
Mode by xRes S.E.. For more information on
the LRG file forms, see Chapter Nine: Working
in xRes Mode.

LRG documents can be saved as RGB (with 
29 channels) or Grayscale (with 32 channels).

You might want to export a document to the
LRG format if you plan on opening it later in
xRes Mode. When you export the document to
an LRG format all objects will be merged.

MMI

This MMI file format is used to save documents
with multiple objects which you want to keep
independent. An MMI file describes a document
by keeping a command set for all objects in the
document. Generally, you will not want to
export the MMI file to another file format until
you have finished editing the image. 
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If you save to any format other than MMI, all
objects will be merged into the background. 

To change a document from MMI format to
another format, you must export it to the 
appropriate format; you cannot use the Save As
command. See Exporting Images in this chapter
for more information.

In xRes Mode, the MMI file serves as a 
pointer to all objects in the document. See
Chapter Nine: Working in xRes Mode for more
information.

PhotoCD

Kodak’s PhotoCD® file format is designed for 
reading files from specially encoded CD’s.
PhotoCD uses a multiple resolution document
representation. This is similar in concept to the
LRG file format used in xRes S.E.. However,
xRes S.E.’s LRG file format is more efficient than
PhotoCD. 

PhotoCD documents are stored in a special YCC
color space developed by Kodak, the details of
which have not been made public. The YCC
color space is optimal for storing a wide gamut
of colors. xRes S.E. uses the tool kit provided by
Kodak to translate YCC data into RGB as it
reads the document.

PhotoCD works with documents at seven fixed
sizes, which range from 64 x 96 pixels to 4096 x
6144 pixels. When you scan a PhotoCD file, you
can pick the size that fits your needs. 

Photoshop 3.0

The Photoshop 3.0 format was designed by
Adobe Systems to store and edit multiple-
object documents. 

When opening or importing a Photoshop 3.0
document in xRes S.E., all the Photoshop
objects are merged into one object. If you want
to retain separate Adobe Photoshop objects,
save each object as a TIFF file from within
Adobe Photoshop and then import the TIFF
files into xRes S.E.. See “Importing Objects” in
Chapter Three: Objects for more information.

When opening a Photoshop 3.0 document in
xRes S.E., the alpha channels of the document 
are maintained in the Channels Window
(Window > Channels). 

You can export any document to the Photoshop
3.0 format. This command merges all of the
objects into one object and saves this image 
as a Photoshop 3.0 file. 

To maintain separate objects use the “Save
Object” command located in the Objects
Window submenu on each object, open these
objects in Adobe Photoshop and click and drag
them into a single document. See the Ad o b e
Photoshop User Guide for more information. 

PI C T

PICT is the standard image format for Ma c i n t o s h .
It was designed as both a vector and raster image
format. PICT raster format is not efficient for
storing large documents (10 to 20 MB and larger)
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and cannot store documents with alpha channels
or store documents in CMYK Color Mode. 

x Res S.E. can read PICT documents in the RG B
Color Mode but it will not maintain alpha chan-
nels. PICT is essentially a useful format for trans-
ferring small files from one Macintosh to another.

P N G

Despite being less than a year old, the PNG 
( p ronounced “p i n g”) file format is gaining popular-
ity due to its lossless compression ability, true color
s u p p o rt, free re f e rence implementation, and full
alpha blending. Unlike the GIF format, PNG 
is roy a l t y - f re e .

x Res S.E. can save and load PNG files. The PNG
file format supports alpha channels.

TGA

Targa (TGA) is the file format of True Vision
Corporation which is best known for its video
boards for IBM PCs. Since the early 1980’s, 
applications such as AT&T’s Rio® have made
TGA the standard for video applications on IBM-
compatible PCs. Applications such as Caligari
True Space®, In-Sync Razor®, and Adobe
Premiere® have the ability to export individual
frames of animation to TGA files. 

TGA is an RGB-only format, and can contain
only one alpha channel. This format is referred to
as 32-bit color; 3 x 8 bits for the document, plus 8
bits for the alpha channel. xRes S.E. will display
the alpha channel as it exists in the document.

TGA is a simple file format. It does not 
support compression, and it can only be saved 
to either RGB or Grayscale Color Modes.

TIFF

The TIFF format was developed over ten years ago
by Aldus Corporation (now part of Adobe) as a
general purpose format for raster documents. T I F F
stands for Tagged Image File Format; the format
consists of tagged fields which are general enough
to handle any type of document. 

The latest version of TIFF is called TIFF 6.0; it
includes full support for RGB, CMYK, In d e xe d
256, Grayscale, and Lab Color documents. A T I F F
document can also save the monitor white point,
gamma settings, and other settings. TIFF is widely
used on both Wi n d ows and Macintosh platforms.

When you export or save a document in
xRes S.E. as a TIFF, you will be prompted with
these options:

• Byte Order: Choose IBM PC or 
Macintosh depending on the platform 
you intend to work in.

• Alpha Channels: xRes S.E. supports 
alpha channels in TIFFs. If you want to 
retain the alpha channels for a particu-
lar object, use the “Save Object” com-
mand located on the Objects Window
submenu. 
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Chapter Three
Objects

Overvie w
This chapter discusses how to manipulate the objects in a document.
Topics include:
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• Dropping Objects

• Changing the Order of
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• Aligning Objects
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• Setting Object Options

• Objects Window
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Essential Terms

Document

As noted in Chapter One, a document is simply 
an open file. The relation between the terms
“document” and “file” in xRes S.E. is similar to
that found in word processing; you can open, 
create, or close a document which in turn is
saved to a file. 

A document in xRes S.E. is made of one or more
objects.

Object

As noted in Chapter One, an object is an individ-
ual item in a document and can be move d ,
a l t e red, and even saved separately from the docu-
m e n t.

Activating and M oving Objects
Selected objects are called active objects. Many
operations, including painting, cloning, erasing,
filling, masking, and applying filters affect only
the active objects in a document. One or more
objects may be active at a time; one object is
always active.

There are two means of activating an object: 
the Arrow Tool and the Objects Window.
See “Using the Arrow Tool” and “Objects
Window” in this chapter for more information.

There are two ways to move objects:

1 Active objects may be moved within the doc-
ument using the Arrow Tool on the Tools

Palette. See “Using the Arrow Tool” below
for more information.

2 Active objects may be moved with the arrow
keys on the keyboard. Pressing an arrow key
once moves the active object(s) up, down, or
sideways one pixel. Pressing Shift while using
the arrow key moves the active object(s) up,
down, or sideways ten pixels. Arrow key con-
trol is useful for precise object positioning.

Using the A rrow To ol

The Arrow Tool is used to activate
and move objects. The Arrow
Tool is located in the top left cor-
ner of the Tools Palette.

To activate an object with the Arrow
Tool, use one of these methods:

• Click the object’s name in the
Objects Window.

• Click the object in the document.

Note: The second method only works if “Activates
Objects” is checked in the Arrow Tool Options. The
default setting has “Activates Objects” checked.

To move an object, click and drag it. The 
rectangular boundary of the object will move
with the cursor to indicate that you are
moving the object. When you release the 
cursor the object is moved to its new location 
in the document.
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If “Real Time Dragging” is checked in the Arrow
Tool Options, then the entire object, not just 
the boundary of the object, will move when you
initially reposition the object.

Grouping Objects

There are two ways to group objects. One
method involves using the Objects Window. The
other method involves using the Arrow Tool and
assumes that “Activates Objects” is checked in
the Arrow Tool Options.

To activate more than one object, click an object in
the document, hold down the Shift key, and click
additional objects; this process groups the objects.

Grouped objects are edited and moved as one
object. For example, if you apply a filter (such as
Invert) the filter is applied to all objects in the
group. If you move one object in a group all
objects in the group are moved.

Groups are temporary associations. To ungroup
objects, simply click an object that is not in the
group with the Arrow Tool or deactivate the
objects on the Objects Window.

Setting A rrow To ol Options

The Arrow Tool Options allow you to set prefer-
ences for how the Arrow Tool functions. There
are two ways to access the Arrow Tool Options:

• Double-click the Arrow Tool.

• Click the Arrow Tool on the Tools Palette
and use the menu command 
Window > Inspectors > Tool Options.

The first Arrow Tool Option is “Activates
Objects.” If this option is checked, the Arrow
Tool can be used to activate and move objects. 
If this option is unchecked, the Arrow Tool
moves objects but does not activate them. 
You may want the “Activates Objects” option
unchecked if objects are packed very closely
together and you are trying to move only one
object. You may also want this option unchecked
if the object you are trying to move is behind
several other objects. 

When “Activates Objects” is unchecked objects
may only be activated with the Objects Window.
By default “Activates Objects” is checked.

The second Arrow Tool Option is “Real-Time
Dragging.” Normally, when you click an object
and drag it, you move only the rectangular 
border of the object until you let go of the
mouse, at which time the entire object moves 
to the specified location. However, if “Real-Time
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Dr a g g i n g” is checked, clicking and dragging with
the Arrow Tool moves the entire object, not just the
b o rder of the object. Although slowe r, this method
a l l ows more immediate feedback on scre e n.

By default “Real-Time Dragging” is unchecked
and the Arrow Tool moves only the border of 
the object.

Creating Objects
There are four ways to add objects to a 
document in xRes S.E.:

• Creating an empty rectangular object.

• Floating a selection.

• Importing an object.

• Option-cropping an object.

Creating an Empty Objec t

You can create a new, empty rectangular object
by clicking the New Object Icon in the 
Objects Window.

Floating a Selection

You can create an object by floating a selection
within the document. A selection may be cre a t e d
with any of the masking tools (such as the El l i p s e
Tool or Rectangle Tool) or the Mask Wi n d ow.

Once your selection is made, use the menu 
command Select > Float. The pixel data within
the selection is now a freely floating object. 
This new object may be resized, rotated, 
positioned, and edited as any other object. 

Importing an Objec t

See “Importing an Image” in this chapter.

Option-C ropping 
an Objec t

The Crop Tool normally deletes 
the image data outside the crop
marks. However, pressing the
Option (Alt in Windows) key while
using the Crop Tool creates a new
object based on the image data 
within the crop marks.

The difference between creating 
an object by floating a selection 
and creating an object by option-
cropping is that floating a selection
creates an object based on one
(active) object, while Option- (Alt
in Windows) cropping creates an
object based on all objects within
the crop marks, whether they are active or not.
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To Create an Object by Option-C ropping

1 Click the Crop Tool on the Tools Palette. 

2 Select the area on the document you wish to
Option (Alt in Wi n d ow s ) - c rop by dragging
the Crop Tool. You can release the crop mark s
and readjust them by moving the corners.
Dragging while holding down the Shift key
changes the size of the rectangle while keeping
the pro p o rtions of the original crop mark s.

3 To accept the image within your crop marks
as a new object, hold down only the Option
key (Alt in Windows), and click inside of the
crop marks. The cursor changes to a pair of
scissors when the Option key (Alt in
Windows) is selected. After you click within
the crop marks, a new object is created based
on the selected image data. 

4 To decline the rectangular area as an object,
click outside of the rectangular area. 
This deletes the rectangle created with the 
Crop Tool and allows you to start the 
process again.

Saving and Importing Objects
Objects are components of a document, and can
be saved and imported as separate documents.

Saving Objects

When you save an object in xRes S.E., you create
a separate document consisting of that object.
Saving an object as a new document does not
affect the current document or object. 

To Save an Objec t

1 Use the menu command Window > Objects
to display the Objects Window.

2 Click the object that you wish to save in the
Objects Window to make it active. Active
objects are displayed in gray in the Objects
Window, while inactive objects are displayed
in white. The object that you wish to save
should be the topmost active (gray) object in
the window. To deactivate an object, click it. 

3 From the Objects Window submenu, choose
“Save Object.”

Note: If more than one object is active, xRes S.E. will
save  the topmost active object.

4 Specify a location for the object to be saved.

5 Enter a name for the object. This name 
does not have to match the original name 
of the object.
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6 Choose a file format for the object. You can
choose any document format except MMI,
which is for multiple-object documents. 

7 Click Save in the Save Object dialog. 
You have now saved your object as a 
separate document.

Importing Objects

Any image on disk can be added to the docu-
ment as an object. The process of bringing one
image into the document by loading it from disk
is called importing the image. xRes S.E. can
import any file format it can open except MMI. 

To import an image into an open document, 
use the menu command File > Import and select
the image that you wish to open. Click Open.
The image will be opened as an object within
the current document. 

An alternative to the File > Import command is
to open the image as an additional document
and click and drag the image from the source
document to the target document. The Import
command is simply a convenient shortcut.

Importing Images in to Documents of
Different Resolution

When you are importing an image into a 
document the image retains its original pixel 
size but changes to match the resolution of the
target document. This can change the displayed
size of the image. 

For example, imagine that the image cat.tif is
200 pixels high by 200 pixels wide and has a 
resolution of 100 ppi. Cat.tif is therefore 2” x 2”
wide (200/100 = 2). 

Imagine that cat.tif is imported into a document
called sky.tif, which has a resolution of 200 ppi.
The cat.tif image will be only 1” x 1” in the
sky.tif document (200/200 = 1).

Importing Images in to Documents of
Different Siz e

You may import an image of any size into a 
document. If the image is larger than the target
document you can resize it using the menu com-
mand Modify > Resize > Active Object.

Importing Images in to Documents
with Different Color M odes

When you import an image into a 
document, the Color Mode of the image will
convert to the Color Mode of the target
document. For example, if you import a RGB
object into a Grayscale document, the Color
Mode of the object will change to Grayscale to
match the target document.
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Importing Images in to Documents
with Differen t Work M odes

If you are importing an image of one workmode
into a document of another work mode, the
work mode of the image converts to the work
mode of the document. See Chapter Nine:
Working in xRes Mode for more information.

Dragging Objects bet ween
Documents

Objects can be dragged across documents.
Dragging an object from one document to
another copies that object from the source 
document to the target document. Holding the
Option key (Alt in Windows) while dragging an
object from one document to another moves
that object from the source document to the tar-
get document.

Dragging Objects in to Documents 
with Different Color M odes

If you drag an object from a source document 
in one color mode to a target document in
another color mode, the color mode of the
object converts to the color mode of the 
target document. 

For example, if you drag an RGB object into a
Grayscale document, that object is converted to
the Grayscale mode. See Chapter Five: Colors
for more information on color modes.

Dragging Objects in to Documents
with Different Resolution

When you drag an object across documents, the
resolution of the object changes to reflect the 
target document. For example, if you drag an
object of 300 ppi into a target document of 75
ppi, the resolution of that object is converted to
75 ppi. However, the number of pixels in the
object does not change; the size of the object
changes to reflect the new resolution. In this
example, the object changes from a resolution of
300 ppi to 75 ppi, making it four times as wide
and four times as high. (300/75 = 4). 

Dragging Objects in to Documents
with Differen t Work M odes

When you drag an object into a document of a
different work mode, the work mode of that
object changes to reflect the work mode of the
document (xRes or Direct). 

See Chapter Nine: Wo rking in xRes Mode for
m o re information on using different work modes.
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Dragging Objects in to
Smaller D ocuments

You can move an object into a target document
even if the object is larger than the document.
After dragging an object across documents, you
may want to resize the object using the menu
command Modify > Resize > Active Object. 

Cutting and Pasting Objects
xRes S.E. can cut, copy, paste, and duplicate
objects. These commands affect the entire object,
even if a selection is present inside the object.

To Cut an Objec t

If an object is active, use the menu command
Edit > Cut (or click the Cut Icon) to remove the
object from the document window and place it
in the clipboard. 

To Copy an Objec t

If an object is active, use the menu command
Edit > Copy (or click on the Copy Icon) to copy
the object to the clipboard. The original object
will remain in the document window.

To Paste an Objec t

When you apply the menu command Edit >
Paste to a document, the object in the 
clipboard is pasted into the current document.
Alternatively, you may click the Paste Icon on
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the Toolbar. The pasted object appears in the top
left corner of the document, and it may be
dragged to the appropriate location with the
Arrow Tool.

To Duplicate an Objec t

A shortcut to using the menu commands Edit >
Copy and Edit > Paste is the menu command
Edit > Duplicate. This command duplicates the
active object and places it in the top left corner
of the current document.

Dropping Objects
An object can be “dropped” onto the object
below it. Dropping an object means to merge an
object onto the object below it while clipping to
the borders of the underlying object.

Source Objec t

When dropping (or copying and pasting) an
object, the source object is the object that is
being dropped. The target object is the object
the source object is being dropped onto. View
the Objects Window to determine the target
object. The target object is the topmost 
overlapping object below the source object.

To Drop an Objec t

1 Activate the source object by clicking it in 
the Objects Window.

2 Move the source object on top of the target
object in the Objects Window with the
Arrow Tool. See “Objects Window” in this
chapter  for more information about manip-
ulating objects with the Objects Window.

3 If the source object is on top of more than
one object, it will drop onto the first object
below it. You may have to deactivate other
objects to make the correct object the target
object. 

4 Use the menu command Select > Drop
Objects. The source object merges into 
the target object, and the source object is
deleted. The source object is clipped to the
boundaries of the target object. 

Note: Instead of using the menu command Select > Drop
Object, you can click the Drop Object Icon on the
Toolbar.
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Changing the O rder of Objects

Objects have a distinct order, which is shown in
the Objects Window. The order of the objects is
used to determine which object is in front if the
objects overlap.

To determine the object order, examine 
the Objects Window. Objects at the top of 
the Objects Window are at the front of 
the document.  

You can change the order of an object at any
time with the menu commands under Modify >
Arrange. The “Bring to Front” command brings
the active object to the front of the document. 
The “Move Forward” command moves the active
object up one level. The “Move Backward” com-
mand moves the active object down one level.
The “Send to Back” command sends the active
object to the back of the document..

Aligning Objects
Objects may be aligned to existing objects or 
to the center of the document. The menu 
commands used to align objects are located
under the menu command Modify > Align. 
To use the Left, Right, Top, Bottom, and Center

commands, you must first make two or more
objects active. 

Applying one of these commands will align the
objects to each other in the method indicated.
The Align Left command aligns active objects 
to the object with the leftmost edge. The Align
Right command aligns the objects to the object
with the rightmost edge. The Align Top and
Align Bottom commands align objects to the
object with the top-most or bottom-most edge, 
respectively. The Align Center command places
the objects on top of each other in such a 
manner that all their centers line up.

The Modify > Align > Center to Page 
command aligns all active objects to the center
of the document. 

Using Object Channels
Each object can contain up to 32 channels. 
To view the channels of an object, use the menu
command Window > Channels. The channels
for one object will be different from the channels
of another object unless the objects are dupli-
cates. See Chapter Seven: Masks and Channels
for more information.

The Channels Window displays all the 
channels in the object, including primary
channels, alpha channels, and mask channels.

Using the Mask Channel

The Mask column in the Channels Window
is used to mask out certain areas of the object.
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Clicking the Mask checkbox for a channel makes
that channel the transparency mask for the
object.  The white areas of the channel represent
opaque sections of the object, black areas of the
channel represent transparent areas of the object,
and gray areas of the channel represent translu-
cent sections of the object.

Painting in the Transparency Mask 

of an Objec t

Using the mask channel you can easily paint in
or paint out the transparency of an object; that
is, you can make an object transparent in one
area and opaque in another.

1 Create a mask channel for an object. 
Use the Channels Window (Window >
Channels), click the New Channel Icon, 
and check the Mask checkbox for that 
channel. See Chapter Seven: Masks and
Channels for more information on creating
mask channels.

(Checking the Mask checkbox for more than
one channel creates a mask for the object
based on the intersection of the channels;
that is, only areas that are opaque in both
channels are opaque in the object.)

2 In the Channels Window, click the mask 
channel to make it uniquely editable (that is, 
the only channel displayed in gray), and 
click the view checkbox of the composite
channel to make all primary channels visible.

3 Click the default swatches on the Tools
Palette. Clicking the default swatches

makes the foreground color black and 
the background color white.

4 Double-click the Brushes Tool on the Tools
Palette to access the Brush Tool Options.
Select Hard or Soft.

5 Paint on the object to remove the opacity of
the object. Because you are painting in black,
you are removing the opacity of the object.
To restore the opacity, click the Eraser Tool
on the Tools Palette and erase the object. As
you erase (paint in white), you will restore
the opacity.

Painting in shades of gray will make the
object semi-transparent. If you paint with a
50% gray, the object will be 50% opaque. If
you paint with a gray value of 192, the
object will be 75% opaque in the area you
paint in. If you paint with a gray value of 64,
the object will be 25% opaque in the area
you paint in.

See Chapter Seven: Masks and Channels to learn
more about using mask channels.

Setting Object Options
The Object Options dialog contains text entry
boxes for the name of the object, as well as the
precise position of the object in pixels, inches,
centimeters, picas, or points (as determined by
the setting under the menu command File >
Preferences > General > Ruler Units).

To access the Object Options for a particular
object, double-click the object. (You can also
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double-click the object’s name in the Objects
Window.) The Object Options dialog appears.

To Change the Name of an Objec t

To change the name of an object, enter a new
name in the Object Options dialog and click
OK. The new name may be up to 128 charac-
ters; however, only 22 characters will show up in
the Objects Window.

To Change the Position of an Objec t

To change the position of an object, enter a new
position in the Object Options dialog. A drop
down menu allows you to choose from Pixels,
Inches, Centimeters, Picas, or Points. Text entry
dialogs allow you to enter positive or negative x
and y coordinates for the object. This position
refers to the position of the top left corner of the

object with x=0, y=0 being the origin (center) of
the document window.

Objects Window
The Objects Window, accessed by the menu
command Window > Objects, serves as a 
shortcut for many common object operations. 
It is used to change the opacity and the Blending
Mode of an object, to change the visibility
of an object, to lock objects in place, and to
delete objects.

The Objects Window displays a thumbnail of
each object in the document with information
about that object, such as its:

• Visibility 

• Opacity 

• Blending Mode 

• File Size

• Status (active = gray, inactive = white)

• Rank (in object order)

When working with multiple objects in a 
document, it is recommended that you keep 
the Objects Window open to keep track of the
objects within that document.
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Note: The remaining directions in this chapter assume
you are working in the Objects Window. Clicking an
object’s name means to click the object’s name within the
Objects Window.

To Make an Object A ctive

Clicking an object’s name makes it active. Active
objects are indicated in gray. Inactive objects are
indicated in white.

To Make Multiple Objects A ctive

To activate multiple objects, hold the Shift key
and click two or more objects. Objects between
these two objects will also be activated.

To Activate/Deactiv ate a Particular Objec t

To activate or deactivate a particular object,
Option-click (Alt-click in Windows) that object
in the Objects Window. Option-clicking an
inactive object makes it active. One object is
active at all times. Using the Option-click
method you can activate non-consecutive objects
in the Objects Window.

To Change the O rder of an Objec t

To move an object forw a rd (up) or backward
( d own), click the object in the Objects Wi n d ow
and drag it either up or down. Dragging an
object up in the Objects Wi n d ow moves it for-
w a rd in the document. Moving an object dow n
in the Objects Wi n d ow moves the object back-
w a rd in the document.

To Use the Scroll Bars

If there are more objects in the document than
can be displayed in the Objects Window, a scroll
bar appears on the right side of the Objects
Window. This scroll bar allows you to scroll
down to the different objects. 

To Access Object Options

To access the Object Options dialog for any
given object, double-click the object in the
Objects Window. See “Setting Object Options”
for more information.

To Rename an Objec t

To rename an object, double-click the object 
in the Objects Window. In the Object Options
dialog, enter a new name and click OK.

To Change the Position of an Objec t

To change the position of an object, move it
with the Arrow Tool (if it is the topmost active
object) or double-click the object in the Objects
Window, enter a new position in the Object
Options dialog, and click OK.
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Using Objects Window I cons

To Create a New Objec t

To create a new object, click the New Object
Icon in the Objects Window. A dialog will
appear, allowing you to enter the new size of the
object in Pixels, Inches, Centimeters, Picas, or
Points. Objects may be larger than the current
document; the default object size is the same as
the document size. In addition, you can specify
whether the object is transparent or opaque by
checking or unchecking the object’s Transparency
checkbox.

A transparent object will be clear, while a 
non-transparent object is filled with the 
background color. Transparent objects act 
like sheets of acetate. You may want to use a 
transparent object to have a layer of paint 
that floats above the rest of the document.

When you create a transparency, xRes S.E. allo-
cates an extra channel to that object, in addition
to the primary channels of the color space (either
RGB, Grayscale, or Indexed 256). This extra
channel acts as the transparency mask. 

When you fill or apply a gradient to a transpar-
ent object, the fill or gradient also edits the mask
channel which controls the opacity of the object.

For this reason, filling or applying a gradient to 
a transparent object usually produces a translu-
cent effect.

For example, if you fill a transparent object with
blue, the brightness value of the blue determines
the opacity at which the blue is displayed. A 
brightness value of 50% produces a blue color
that is a half opaque/half transparent. (To display
the object at full opacity, uncheck the Mask
checkbox in the Channels Window.)

To Duplic ate an Existing Objec t

To duplicate an existing object, click an object
and drag it to the New Object Icon. A duplicate
of the object will be placed at the top of the doc-
ument. To change the name of the new object,
double-click the new object’s name, enter a new
name, and click OK.

To Delete an Objec t

To delete an object, click that object and drag it
to the trash in the Objects Window. If you acci-
dentally delete an object, access the menu com-
mand Edit > Undo to retrieve it.

Using the Objects Window
Check boxes

To Change the Visibility of an Objec t

To change the visibility of an object, select/
deselect the “View” checkbox located under the
View column in the Objects Window. An object
is either visible or invisible. You may want to
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make an object invisible to experiment with dif-
ferent compositing effects. The visibility of an
object is reflected both on screen and when the
document is printed or exported. 

Any object can be made invisible except 
active object(s), which are always visible.

To Lock an Object in Plac e

To lock an object in place, check the “Lock”
checkbox for the object located in the Lock 
column of the Objects Window. Locked objects
cannot be moved. To unlock a locked object,
uncheck the Lock checkbox for the object. You
may want to lock an object in place to prevent
accidentally moving it.

The General Preferences (menu command File >
Preferences > General) control whether or not
the background (bottommost) object is initially
locked. Check or uncheck the “Objects Initially
Locked” preference to set it as desired. 

Changing the Opacity and Blending
Mode of an Objec t

The top of the Objects Window contains an
Opacity Slider and Blending Mode menu.

To Change the Opacity of an Objec t

To change the opacity of an object, activate the
object and adjust the Opacity Slider at the top of
the Objects Window. Adjusting the opacity after
grouping objects changes the opacity for the
entire group.

To Change the Blending M ode of an Objec t

To change the Blending Mode of an object, acti-
vate the object and select a Blending Mode in
the Blending Mode menu at the top of the
Objects Window. Adjusting the Blending Mode
of grouped objects changes the Blending Mode
of the entire group.

See “Blending Modes” (next) to learn more
about how Blending Modes affect objects.
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Blending M odes

The Blending Mode of an object can be used to
create a multitude of special effects. It is easy to
change the Blending Mode of the object several
times and experiment with different settings. 

Blend

The Normal Blend Mode combines objects
using an opacity blend. This mode takes the
opacity of the objects into account when com-
bining them. For example, if Object A with 75%
opacity is composited onto Object B, the result
will be an image that takes 75% of the pixel val-
ues from A and 25% of the pixel values from B.

Additive

In the Additive Blending Mode, the composite is
built up by adding the pixel values on a per-
channel basis. In RGB, Additive blending light-
ens the image. For example, if an RGB object
has an opacity of 50% and an Additive Blending
Mode, it will be composited by first changing
the opacity to 50%, then adding this value to the
object underneath it.

Subtractiv e

The Subtractive Blending Mode is the opposite
of the Additive Blending Mode. The gray levels
of the top object are subtracted from those
beneath it on a per-channel basis. This mode
has the impact of darkening RGB images.
Subtractive blending is used to remove light
from RGB images.
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Multipl y

The Multiply Blending Mode works by multi-
plying each channel’s gray level with the corre-
sponding channel value of the underlying object
and dividing the result by 255. The multiply fil-
ter tends to darken as it composites, particularly
if the image and its composite are very different. 

Differenc e

The Di f f e rence Blending Mode mode computes
the value of each pixel by taking the absolute
value of the difference in pixel values on a per-
channel basis. In difference blending, two identi-
cal objects that are composited will produce a
p u re black result. If the two objects are negative s

of each other, the result will be pure white.
Generally speaking, blending two objects with
the Di f f e rence Blending Mode will create a wildly
c o l o red image that can be used as a special effect.

Maximum

The Maximum Blending Mode computes the
maximum value (on a scale from 0 to 255 for
RGB) for every pixel on a per channel basis. 
In other words, if pixel “A” (128, 75, 200) were
composited in RGB mode onto pixel “B” 
(65, 90, 150), the result will be pixel “C” (128,
90, 200), representing the maximum values for
each individual channel of red, green, and blue.
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Minimum

The Minimum Blending Mode is similar to
Maximum Blending Mode, but instead of com-
puting the maximum values for each color chan-
nel, it computes the minimum values. 

In RGB, Minimum generally darkens the picture
and Maximum generally lightens it.

Using the Objects 
Window Submenu
There are three commands located in the
Objects Window submenu: Save Object As,
Render Objects, and Drop Objects.

To Save an Objec t

To save an object, choose “Save Object As” from
the Objects Window submenu. The Save Object
As command affects the topmost active object. A
dialog prompts you to enter a name, file format,
and disk location for the object. You can save the
object in any file format that xRes S.E. supports
for saving files except MMI. 

Using the Save Object As command does not
affect the name, file format, or disk location of
the object. Instead, it saves a copy of the object.
You may want to save a particular object to make
the current version of the object accessible to a
different application. For example, saving an
object as a TIFF file makes it accessible to most
page layout programs. See “Saving and
Importing Objects” in this chapter for more
information.

To Render an Objec t

To render an object, choose “Render Objects”
from the Objects Window submenu. The
Render Object command renders active objects
in the document. 

See Chapter Nine: Working in xRes Mode for
more information about rendering objects.

To Drop an Objec t

To Drop an Object, choose “Drop Objects”
from the Objects Window submenu. See
“Dropping Objects” in this chapter for more
information.

Object Transformations
Object transformations refer to all operations that
i n vo l ve changing the size or shape of an object. 

Object transformation commands in xRes S.E.
include Re s i ze Object, Rotate Object, Sk ew
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Object, and Flip Object. Ac t i vate the object
b e f o re applying an object transformation com-
mand. If more than one object is active, the
transformation will be applied to the topmost
a c t i ve object.

Interpolation M odes

The Interpolation Mode refers to the method
x Res S.E. uses to ensure that object transforma-
tion commands do not cause image degradation. 
The Interpolation Mode is set in the Ge n e r a l
Pre f e rences accessed by the menu command Fi l e
> Pre f e rences > General and is re p resented by a
c h e c k b ox called “Bilinear In t e r p o l a t i o n . ”

If the Bilinear Interpolation pre f e rence is
checked, then the Bilinear Interpolation Mode is
used. If the Bilinear Interpolation pre f e rence is
unchecked, then “Ne a rest Ne i g h b o r
In t e r p o l a t i o n” is used. The default setting is
Bilinear In t e r p o l a t i o n .

Ne a rest Neighbor Interpolation examines the pix-
els immediately surrounding a pixel when re s i z i n g
or reshaping an object. This mode is faster, but it
may not generate the same quality as the Bi l i n e a r
Mode, which uses more surrounding pixels when
resizing or reshaping an object.

To Resize an Objec t

In xRes S.E., you can resize an
object in two ways:

(1) Freehand resizing
When you click the Resize Tool on
the Tools Palette, four handles appear
at the corners of the topmost active
object. Drag any one of these corners
to resize the object.

(2) Numerical resizing
The most precise way to re s i ze an
object is to use the re s i ze dialog to
enter a new size in inches, centime-
ters, pixels, picas, points or perc e n t-
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age of object size. To access this dialog, double-
click the object with the Re s i ze Tool, or use the
menu command Modify > Re s i ze > Ac t i ve
Object. 

If the “Fi xed Aspect Ratio” pre f e rence is
checked, resizing will be pro p o rtional. Fo r
example, if you check this pre f e rence and enter
a new height in the Re s i ze Object dialog,
x Res S.E. will automatically compute the
n ew width according to the original object’s
p ro p o rt i o n s.

To Rota te an Objec t

You can rotate an 
object in three ways:

(1) Freehand Rotation
The first way to rotate an object 
is to use the Rotate Tool on the
Tools Palette. 

When you click the Rotate To o l
four handles appear at the corners of
the active object. Any of these han-
dles can be used to rotate the object.

To see the percentage that you are
rotating, access the Info Inspector
with the menu command Window
> Inspector > Info. The bottom-
most section of the Info Inspector displays the
rotation in degrees, from 1 to 360.

(2) Numerical Rotation
The Rotate Object dialog allows you to enter an
angle in degrees between –359.99 and 359.99.

You may also specify whether you want to rotate
clockwise (CW) or counter-clockwise (CCW).
To access this dialog, use the menu command
Modify > Rotate > Arbitrary, or double-click the
object with the Rotate Tool.

(3) Rotation by 90 Degrees
Often it is necessary to rotate an object exactly
90 degrees. For example, you might scan an
image horizontally but wish to see it vertically.
The menu commands Modify > Resize > CCW
90 and Modify > Resize > CW 90 are used for
this purpose. 

To Skew an Objec t

When you use the Skew Tool, four
handles will appear at the corners
of the topmost active object. You
can drag these handles to create a
horizontal skew of the object. An
object can be skewed back and forth
and still retain the original pixel
information.

To Flip an Objec t

The menu commands Modify >
Flip > Horizontal and Modify >
Flip > Vertical can be used to flip
the topmost active object either
horizontally or vertically.

These commands might be useful, for example,
if the original scan is upside down or backwards.
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Using Text Objects
Because text is an object in xRes S.E. it can
be easily resized, reshaped, or repositioned at
any time. This allows you to move text
objects around the document to achieve the
best position.

To Create a Text Objec t

1 Click the Text Tool on the Tools Palette.

2 Click in the current document. A text dialog
appears.

3 Choose the desired font. Yo u
may choose any Tru e Type or

ATM font that is on your system.

4 Select a unit of measure in the
Size drop-down menu, then enter the size of
the font.

5 Enter the border width of the text object (in
pixels) in the Border entry box. The border
indicates the amount of transparent space
around the text in the text object. You may
want to use a large border if you plan to use

a drop shadow with the object. See “Creating
Text Dropshadows” in this chapter for more
information.

6 Select a style for the text by checking the
checkboxes next to the styles you wish to use.
You may choose any of the following styles:
Bold, Italic, Underline, Outline, Shadow, and
Anti-aliased. Anti-aliased smooths out the
text and prevents jagged lines around the
edges, especially with large font sizes.

7 Select an alignment for the text by clicking in
the Left, Center, or Right radio buttons.

8 Enter the text in the text entry box at the
bottom of the Text Tool dialog.

9 Click OK. A new text object appears in the
document based on the font, size, border,
style(s), and alignment chosen in the Text 
Tool dialog.

Mask Channel

A text object contains the primary channels 
plus one additional channel used to mask out 
the text.
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See Chapter Seven: Masks and Channels to learn
more about using masks in objects. You can 
view this mask channel by accessing the menu
command Window > Channels and clicking 
the mask channel (in RGB Color Mode this
channel is “#4”). 

Resizing Text

When you re s i ze a text object the text automatical-
ly re s i zes pro p o rtionately to the nearest point size .
This ensures that there is no degradation in the
text quality as it is re s i zed. To re s i ze text dispro p o r-
tionately use the Modify > Re s i ze > Ac t i ve Ob j e c t.

Creating Text Dropshado ws

A common procedure in the digital arts 
community is to create text with dropshadows.
With xRes S.E. you can easily create text drop-
shadows, reposition or reorder the dropshadow
in relation to the original text, and group the
text dropshadow objects.

To Create a Text Dropshadow

1 Create a text object in an RGB document.

2 Duplicate the text object (menu command
Edit > Duplicate).

3 Click the duplicate object. Click the default
color swatches on the Tools Palette. Use the
menu command Edit > Fill, set the fore-
ground color to 100% opacity, and click OK.

4 Open the Channels Window (menu com-
mand Windows > Channels) and click #4.

5 Apply the Gaussian Blur filter (menu com-
mand Effects > Blur > Gaussian). Aim for soft
edges while keeping the text distinguishable.

6 Click the RGB composite channel. You now
have a text dropshadow.

7 Use the menu command Modify > Arrange >
Move Backward to move the text drop-
shadow object behind the text object.

8 Reposition the dro p s h a d ow text object so that
it is almost directly beneath the text object.

To group the objects, Shift-click the text
object. The text and dro p s h a d ow will move
together in the document, allowing you to
experiment freely with different locations.
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Chapter Four 
Painting , Erasing, and Cloning

Overvie w

This chapter discusses the concepts and the practical applications of 
painting, erasing, and cloning operations. Topics include:
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• Essential Terms

• Brushes Palette

• Editing the Brush Set

• Shape Inspector

• Brush Tool Options

• Brush Tool Options Submenu

• Textures Palette

• Erasing

• Creating Straight Lines

• Cloning



Essential Terms

Digital Painting

Painting on the computer is a fairly new con-
cept. The program that started the painting craze
was MacPaint by Bill Atkinson. It was a strictly
black and white program. Believe it or not, that
was the state of the art in 1984. Digital painting
has come a long way since then.

The second step in the evolution of digital paint-
ing came when natural, textured brushes were
available on the computer. Charcoals, inks, pen-
cils, and even air brushes could be reproduced
on the computer screen. One program which
emerged as a leading contender in the digital
painting category was Matisse™ by Fauve. 

xRes S.E. marks the third step in the evolu-
tion of digital painting by allowing natural,
textured brushes to be used on images of any
size. xRes S.E. fully integrates the brush technol-
ogy of Matisse, providing artists a customizable
digital art studio. You can control the size, shape,
and soft edge of the brush. You can even control
the behavior of the brush, such as how much the
ink or paint bleeds into the canvas and how
much texture it picks up. xRes S.E. also allows
you to create your own textures by scanning
them or creating them from scratch.

Brush M odel

There are four floating panels that are used when
painting in xRes S.E.:

Brushes Palett e

(Wi n d ow > Palettes > Brushes): The Bru s h e s
Palette selects which brush is used. Brushes i n c l u d e
traditional photographic retouch brushes as well as
a rtistic brushes such as charcoal and waterc o l o r. 

Shape Inspec tor

(Window > Inspectors > Shape): The Shape
Inspector controls the size, shape, and soft edge
of the brush. It also controls whether or not the
brush is anti-aliased.

Brush Tool Options Inspec tor

(Window > Inspectors > Tool Options): The
Brush Inspector controls the characteristics and
behavior of the brush including its opacity and
pressure-sensitivity.

Note: You must have the Brush Tool selected on the Tools
Palette to access this Inspector.

Textures Palett e

(Window > Palettes > Textures): The Textures
Palette selects which texture is used with the
brush.
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Painting

Painting in xRes S.E. involves selecting a brush
in the Brushes Palette and then clicking and
dragging on the document. 

• To learn more about the Brushes Palette, 
see “Brushes Palette” in this chapter.

• To learn about changing the size and shape
of your brush as you paint, see “Shape
Inspector” in this chapter.

• To learn about changing the characteristics
or behavior of the brush, see “Changing
Brush Properties” in this chapter.

• To learn about making a brush pressure-sen-
sitive, see “Pressure and Speed Relationships”
in this chapter.

• To learn about selecting a texture, see
“Textures Palette” in this chapter.

To Paint in xRes S.E .

1 Click the Brush Tool on the Tools Palette.

2 Access the Brushes Palette by one of these
two methods:

• Double-click the Brush Tool on the 
Tools Palette.

• Use the menu command Window > Palettes
> Brushes.

3 Click a brush on the Brushes Palette to select
it. Choices include Hard, Soft, Air Brush,
Charcoal, Crayon, Quill, Calligraphy,
Japanese, and Tint.

4 Select a brush variant from the Variant menu
at the top of the Brushes Palette.

5 Click the document and drag on the docu-
ment to paint. Painting only affects active
objects. Release the mouse to terminate the
stroke. 

6 Continue clicking and dragging the mouse
to place more strokes on the document. 
Shift-clicking will constrain the strokes to
straight lines.

Brushes Palett e
The available brushes are displayed in the
Brushes Palette. A drop-down menu lists the
available brush variants. 

By clicking on a brush and selecting a variant,
you can create dozens of brushes. In addition,
the Brushes Palette allows you to save new
brushes and edited brushes, to delete brushes,
and to duplicate existing brushes.

The Brushes Palette contains:

• Brush Icons: These are the icons that allow
you to choose a brush. Brushes range from
photographic retouching tools to artistic
styles, such as oil and watercolor.
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• Variant Menu: Clicking on a brush loads the
variants available for that brush in the
Variant Menu. For example, variants for the
Crayon brush include “Wax” and “Wet.”

• New/Duplicate Icon: With this icon you can
create new brush Variants and duplicate
existing brushes.

• Trash: You can delete brushes or variants by
dragging them to the trash.

• Scroll Bars: With the scroll bars you can
scroll horizontally or vertically through the
brush set.

Editing the B rush Set
You can edit the appearance of the Brushes
Palette as well as the brush properties associated
with each brush. You can also change the name
of brushes or brush variants; add or delete brush-
es in the Brushes Palette; and load and save
brush sets.

Changing the Appearance of the
Brushes Palett e

You can change the location of brushes and the
corresponding Brush Icons used in the Brushes
Palette. The following section explains how to
change the location of brushes within the Palette
and how to personalize the Brush Icons.

To Change the L ocation of B rushes

To change the location of a brush, click that
brush’s icon, move the brush to a new location
within the Brushes Palette, and release the
mouse button. The brush is placed in its new
location and all other brushes are moved over
one position. 

A brush cannot be moved to the top left corner
of the Brushes Palette. However, you can move
the top left brush to a different location in the
Brushes Palette.

To Change a B rush Icon

You can create your own Brush Icons to person-
alize your brush set.

1 Create a new document that is 64 x 64 pix-
els. Other sizes can be used, but the dimen-
sions should be even, symmetrical, and no
smaller than 32 x 32 pixels.

2 Use the painting and drawing tools to create
an image that you wish to use on the new
Brush Icon. You can use any of the brushes
or any of the filters of xRes S.E.. Do not cre-
ate any new objects.

3 Access the Objects Window (Window >
Objects) and the Brushes Palette (Window >
Palettes > Brushes).

4 Make sure that the object displayed in the
Objects Window matches the document. If
the Objects Window has not been updated,
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click in the top right corner to compact the 
window, then click the top right corner again
to re-open the Objects Window. The Objects
Window should display an updated view
of the document.

5 Click the Brush Icon that you wish to
change in the Brushes Palette.

6 Click the object in the Objects Window and
drag it on top of the Brushes Palette. The
Brush Icon is replaced by the object you
dragged on top of the Palette. If the object is
not square or the dimensions are not propor-
tional, it is scaled accordingly to the size of
the Brush Icon. 

Creating , Duplicating, Deleting , and
Changing Names

The following explains how to create new va r i-
ants for a brush, how to duplicate an existing
b rush as a starting point for creating a new
b rush, and how to delete brushes or brush va r i-
ants to better organize the brush set. This section
also explains how to change the name of the
b rushes and brush va r i a n t s .

To Duplic ate a Brush

Drag the brush to the New Brush Icon. A dialog
prompts you for a name for the new brush. The
default name is the current brush with the word
“copy,” as in “Oil copy.” The brush is copied,
including its variants.

To Duplic ate a Brush Varian t

You can duplicate a brush variant in order to
edit it or to create a new brush variant.

1 Click the brush that contains the variant you
wish to duplicate.

2 Select the variant.

3 Click the New Brush Icon. A dialog prompts
you for a name for the new variant. The
default name is the current variant with the
word “copy” such as “Wax copy.”

To Delete a B rush

To delete a brush, press Option (Alt in
Windows) and drag the brush to the trash. 

If you accidentally delete a brush, choose
“Default Brush Set” from the Brushes submenu
to restore the default brush set. Alternatively,
uncheck “Save Brushes on Exit” from the
General Preferences dialog, and relaunch the
application. 
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To Delete a B rush Varian t

To delete a brush variant, click the brush con-
taining that variant and select the variant in the
Variant Menu. Then drag the brush to the trash.
The variant selected in the Variant Menu is
deleted. 

Note: If you accidentally delete a brush variant, choose
“Default Brush Set” from the Brushes submenu to restore
the default brush set. Alternatively, uncheck “Save
Brushes on Exit” from the General Preferences, and
relaunch the application. Note that you cannot use the
Edit > Undo command to undo the deletion of a brush
variant.

To Change the Name of a B rush

To change the name of a brush, press Option
(Alt in Windows) and double-click the Brush
Icon. A dialog prompts you for a new name.

To Change the Name of a B rush Variant

To change the name of a brush variant, select
that variant in the Variant Menu and double-
click the brush containing that variant. A dialog
prompts you for a new name.

Changing B rush Properties

The Brushes Palette stores all the brushes as well
as the properties associated with each brush. The
brush properties refer to the size, shape, and
behavior of a brush. The properties of a brush
are controlled by the Shape Inspector (Window

> Inspector > Shape)  and Brush Tool Options
(accessed by double-clicking the Brush Tool).

If you change the properties of a brush, those
changes are automatically saved, but only for the
current session. Any settings that are changed by
the Shape Inspector or Brush Tool Options are
properties of the brush.

For example, if you increase the size of the oil
brush, that new size is saved automatically. If
you select another brush and then reselect the 
oil brush, the new, larger size is still present. 

To save brush properties permanently to disk,
display the General Preferences dialog accessed
by the menu command File > Preferences >
General and check the “Save Brushes on Exit”
preference. If this preference is checked, then any
changes made to the brush properties are saved
permanently to disk. If this preference is
unchecked, changes made to the brush proper-
ties are saved for the current session only.

Note: If you change the properties of a brush and are dis-
satisfied with the results, use the menu command File >
Preferences > General, uncheck the “Save Brushes on
Exit” preference, quit xRes S.E. and relaunch xRes S.E..
This resets the brushes to the last saved version.

Saving B rushes

You can save changes made to the brushes within
the Brushes Palette for the current session, or
permanently. You can also load and save different
brush sets to use in the Brushes Palette or load
the default brush set that ships with xRes S.E..
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Saving Changes to the B rush Palett e

Changes made to the Brushes Palette are saved
automatically for the current session. These
changes include changing the appearance of the
Palette; saving, duplicating, and deleting brushes;
and changing brush properties. 

To save the changes permanently, display the
General Preferences by accessing the menu com-
mand File > Preferences > General, and check
the “Save Brushes on Exit” preference. When
this preference is checked, all changes to the
brush set are saved permanently to disk. When
this preference is unchecked, brush changes are
saved only for the current session.

Saving and Loading Different B rush Sets

You can save and load brush sets if you have cus-
tomized the brush set for a particular project.
You can also create a specialized brush set—for
example, a brush set that contains only inks (to
customize the application).

When xRes S.E. is launched, it loads the
brushes.brs file located in xRes S.E.
Resources/Brushes.

If “Save Brushes on Exit” is checked in the
General Preferences when you quit the applica-
tion, the current brush set is automatically saved
as brushes.brs and loaded the next time you
launch xRes S.E..

Note: If the “Save Brushes on Exit” preference is
unchecked in the General Preferences and you wish to
load the current brush set the next time you use
xRes S.E., use the Save Brush Set command, name the
brush set brushes.brs, and store the brush set in xRes S.E.
Resources/Brushes.

To Save a B rush Set

To save a brush set, select “Save Brush Set As”
from the Brushes Palette submenu. A dialog
prompts you to indicate a location of the brush
set on disk. Enter a name for the brush set and
click “Save.”

Note: When you choose “Default Brush Set” from the
Brushes submenu, xRes S.E. searches for the default brush
set located in the xRes S.E. Resources/Brushes folder.

If you save a brush set as default.brs, that brush
set will load when you access the Default Brush
Set command instead of the default brush set
that shipped with xRes S.E..

To Load a B rush Set

To load a brush set, select “Load Brush Se t” fro m
the Brushes Palette submenu. A dialog pro m p t s
you to locate the brush set on disk. After locating
the brush set, click “Op e n” to load it.

Changing Back to the Default B rush Set

To change back to the brushes of the default
brush set that shipped with xRes S.E., select
“Default Brush Set” from the Brushes Palette
submenu. “Default Brush Set” in the Brushes
Palette submenu restores the default brush set to
the Brushes Palette.

Note: If you have re s a ved a brush set as default.brs, and
s t o red it in the xRes S.E. Re s o u rc e s / Brushes, then that
b rush set is loaded when you use the Default Brush Se t
c o mmand.
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Appending B rushes

Appending Brushes refers to the process of
adding brushes from one brush set to another
brush set. To append (add to) a brush set, choose
“Append Brush Set” from the Brushes Palette
submenu. A dialog prompts you for the name
and location of the brush set you wish to add to
the current brush set; click Open in the dialog to
append the brush set to the current brush set.

Macromedia will provide several additional brush
sets through on-line services as they are devel-
oped. By using the “Append Brush Set” com-
mand, you can add these brush sets to your
current brush set.

xRes S.E . Default B rushes

xRes S.E. ships with dozens of brushes with uses 
from photographic retouching to artistic effects.
These brushes include:

Hard

Hard brushes are useful for retouching work.
Variants for the Hard brushes include “Square”
and “Anti-Aliased.”

Soft

Soft brushes are useful for retouching work, 
particularly with the Eraser and Clone Tools
because the edges of the brushes are not as 
distinct as the Hard brushes.

Tint

The Tint brushes are used to tint
images with the current foreground color.
Applying the Tint brush at a low strength 
applies a special, subtle effect.

Airbrush

Airbrushes apply paint in a fine, smooth mist.
They are ideal for hand-coloring old pho-
tographs or creating backgrounds for digital
paintings. It is often useful to adjust the opacity
of the airbrush to a low setting when painting
over existing images in order to achieve a subtle
effect. Flow value controls the amount of paint a
mouse click places. 

• Basic: A standard airbrush.

• Light: Useful for painting in areas where you
need only a tinge of color.

• Textured or Grainy: Variants which apply a
light mist that reflects the current texture.

Calligraph y

Calligraphy brushes create angled calligraphy
strokes. For best results, move the mouse or 
stylus with a steady hand. Notice how smooth
the calligraphy stroke is in xRes S.E.. This effect
is achieved by the Smoothing value. You can
even change the angle and size of the calligraphy
brushes.

Note: The calligraphy brush is spelled “Caligraphy” in
the xRes S.E. brush set due to size limitations.
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Charcoal

Charcoal brushes are the penultimate
example of natural textured brushes in xRes S.E..
Charcoal brushes use the texture in effect and
have a noticeably fringed edge. Charcoal brushes
also have a high degree of blackness to simulate
the darkness of charcoals. 

Crayon

Crayon brushes look like crayons children might
use. Experiment with the following:

• Wax: Simulates the look of a crayon straight
out of the box. 

• Wet: Looks like a crayon smeared with water.

• Monkey: A two-tipped crayon which is just
for fun.

Quill

Imagine dipping a feather quill in an ink well,
and you have the basic idea of how the Quill
brushes work. Flow value determines the amount
of ink that runs from the quill at a time. 

Japanese

The Japanese brushes imitate the ancient art of
painting with off-black inks to produce scenes of
nature. For a really neat effect, try cloning with
one of the Japanese brushes. See “Cloning” in
this chapter.

Notice that the longer you hold down the mouse
in one place, the more ink flows from the brush
into that area. Using this method you can create
images that realistically mimic an actual Japanese
brush. Bamboo, Sumi, and Rising Sun are all
variants of the Japanese brush that produce the
look of Japanese washes. Experiment with the
different variants to find out which one works
best for you.

Shape Inspec tor

xRes S.E. uses a Shape Inspector, to control the
shape and size of the active brush. Any changes
you make that affect the size or shape of the
brush with the Shape Inspector are saved for the
current session. To save the changes permanently,
see “Saving Changes” in this chapter.

As you change the settings in the Shape
Inspector, the Shape preview updates automati-
cally to reflect any changes to the size, aspect,
angle, soft edge, or squareness of the brush.

To view the Inspector use the menu command
Window > Inspectors > Shape. The Inspector
contains the following: 
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Size

This slider controls the size of the brush in pixe l s. 

Aspect

This slider sets the ratio of brush height to
brush width, as a percentage.

Angle

This slider sets the brush angle in degrees.

Soft Edge

This slider sets the degree of softness of the
brush as a value from 0 to 100. In addition,
there are two checkboxes at the bottom of the
palette:

• Square: This checkbox makes the brush 
rectangular or square in shape.

• Anti-aliasing: This checkbox makes the
stroke smooth by applying anti-aliasing. 

Preset Size I cons

These icons serve as a quick means of accessing
the most commonly-used brush sizes.

Preview Window

This window allows you to pre v i ew the size and
shape of a brush. The Pre v i ew Wi n d ow is located
in the top left corner of the Shape In s p e c t o r.

The size slider in the Shape Inspector controls
the size of the brush in pixels. Moving the size

slider automatically updates the Shape preview
to the new size. If the size is too large to display
in the preview box, it is displayed in a zoomed
out view.

The bottom of the Shape Inspector contains six
preset size icons. Clicking on one of these icons
automatically updates the size slider. The preset
size icons are good shortcuts for creating a brush
of a certain size. For example, you can click on
the leftmost preset to create a 1 pixel brush.

The preset size icons affect only the size of the
brush; they do not affect the soft edge, angle,
aspect, or any other brush property.

To Change the P reset Sizes

You can change the preset size icons to reflect
different sizes.

1 Move the Size Slider to set the size of the
brush.

2 Option-click one of the presets. The preset
size changes to reflect the newly set size. 

Aspect R atio

The term “Aspect Ratio” refers to the ratio of
brush height to brush width.

• An Aspect Ratio of 100 indicates a perfectly
round (or perfectly square) brush.

• An Aspect Ratio of 50 indicates that the
brush is twice as wide as it is high.
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• An Aspect Ratio of 5 indicates that the brush
is very thin.

As you move the Aspect Slider, the Preview
Window in the Shape Inspector updates auto-
matically. Using the Aspect Ratio in combina-
tion with the Brush Angle allows you to create
Calligraphy or other angled brushes.

Angle

The Brush Angle is used to create angled brush-
es. As you change the angle of the brush, the
Preview Window in the Shape Inspector updates
automatically. xRes S.E. allows you to vary the
angle of the brush between 0 and 180 degrees. If
the brush is perfectly round or square (for exam-
ple, if the aspect ratio slider is set to 100) this
will not change the preview in the Shape
Inspector. If you are changing the angle of a
brush with an aspect ratio less than 100, you will
see a difference in the preview box. 

Macromedia recommends that you set the angle
to 45 degrees, or a multiple thereof, because the
cleanest brushes have angles of exactly 45
degrees. This is because the rotation transforma-
tion tends to produce small artifacts at other
angles. In addition, angled brushes look better
when the underlying shape is rectangular, rather
than elliptical. 

Soft Edge

Soft Edge is one of the most important settings
in the Shape Inspector. The Soft Edge slider

determines the opacity of the Shape Inspector
from the center of the brush to the edge of the
brush. 

• Setting of 100: This brush has maximum
softness. It is totally transparent at the edges
and totally opaque at the center. In-between
there is a smooth transition in transparency
values. Soft-edged brushes are useful for gen-
eral photo-retouching and airbrushing.

• Setting of 50 (or any other intermediate
value): This provides a semi-hard brush.

• Setting of 0: This brush is completely hard.
There is no difference in opacity between the
edge of the brush mask and the center of the
brush mask. 

As you move the Soft Edge slider, the preview
box in the Shape Inspector updates automatically
to reflect the new soft edge. 

Square

You can make the brush rectangular or square
by checking the Square preferences on the 
bottom of the Shape Inspector. Rectangular and
square brushes are mainly used for small single
pixel brushes, calligraphy pens, and other angled
brushes, as well as for custom special effects.
When you check or uncheck this box, the pre-
view box in the Shape Inspector updates to
reflect the new shape. 
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Anti-Aliasing

Anti-aliasing is often a misunderstood concept 
in computer graphics. It is often referred to as a
smoothing technique or a blurring of the edges,
but the effect is more complex.

Anti-aliasing gives the impression of a sharp,
consistent edge on a screen with a limited 
number of pixels per inch. Without anti-alias-
ing, an opaque paint stroke will produce jaggies,
or 
a pixilated staircase-like effect. Although this
phenomenon is most noticeable on the screen at
72 ppi, it is even apparent on printed output at 
resolutions as high as 300 dpi. 

Anti-aliasing subtly darkness the pixels around
every edge of the brush stroke to make the edges
appear more sharp. In other words, anti-aliasing
is all about sharpening edges, not blurring or
smoothing them. 

To make a brush anti-aliased in xRes S.E., check
the Anti-Alias Preferences at the bottom of the
Shape Inspector.

Brush Tool Options
The Brush Tool Options control the behavior 
of the brush. This inspector includes frequently-
used controls such as:

• Brush opacity.

• Brush texture.

• Amount of fringe.

• Ink Level.

• Bleed.

• Smoothness.

• Pressure-sensitivity.

The Brush Tool Options is the main control center
for the brush model in xRes S.E.. You can specify a
style for the brush and configure a brush exactly as
you want it. Brushes from calligraphy pens to char-
coals can be made by changing brush pro p e rt i e s .

All of the brushes in xRes S.E. were designed
by changing the brush properties in the Shape
Inspector and Brush Tool Options.

To Access the B rush Tool Options

1 Click the Brush Tool on the Tools Palette.

2 Use the menu command Window >
Inspectors > Tool Options after choosing the



Brush Tool on the Tools Palette, or simply
double-click the Brush Tool.

Clicking on the triangle at the bottom left cor-
ner of the Inspector lists more brush tool
options. Clicking this triangle again compacts
the Inspector.

Brush Styles

The Brush Tool Options has a style menu,
which contains a library of styles. When creating
or editing a brush, the first step is to determine
its new style. Different brush properties will be
available depending on the chosen style. For
example, Artistic brushes contain a texture prop-
erty and Fast brushes do not. 

Understanding the behavior of different styles
and the different properties associated with each
style is key to successful brush creation. Brush
styles include Artistic, Fast, Tint, Contrast,
Noise, Shading, and Sponge.

Fast

Fast brushes are up to eight times faster than
other brush styles. They are used for general
photographic retouching and airbrushing effects.
The Opacity value determines the opacity of
each stroke, and the Flow value controls whether
the paint is delivered in a smooth flow or with a
build-up effect. Other brush properties include
Concentration, Spacing, and Smoothing. You
can also make fast brushes pressure- or speed-
sensitive. 

Artistic

A rtistic brushes are used to create natural, 
t e x t u red brushes, or other media that simulate
real-life artistic tools. Artistic brushes are the only
b rushes that are affected by the paper texture. 

Artistic brushes are useful if you are creating 
an image from scratch using only brushes. 
They can also be used on existing pictures to add
interesting effects and realism.

Artistic brushes contain a plethora of brush con-
trols for creating brushes from rich felt tips to
Japanese Sumi brushes to multi-strand oil bru s h e s .
Brush pro p e rties include:

• Concentration value: Controls the thickness
of each dab of paint.

• Flow value: Controls the ink build-up that
can occur in one location.

• Texture and Fringe values: Control the
amount of texture the brush picks up.

• Blackness value: Determines whether the
brush darkens as you go over it repeatedly,
like felt tip or calligraphy pens.

• Bleed value: Determines how much the
brush bleeds into the existing image; for
example, watercolor brushes have a very high
Bleed value.

• Tips and Tip Spacing values: Control the
number of bristles in the brush and the space
between these bristles; for example, one dis-
tinguishing feature of the Oil brush is that it
has multiple tips.

Painting, Erasing, and Cloning 57



Other brush properties include Spacing and
Smoothing. Spacing controls how densely dabs
of paint are packed together; denser paint strokes
have lower spacing values. Smoothing controls
how smooth the stroke is. 

By altering the brush properties associated with
artistic brushes, you can simulate almost any
real-life brush on the computer screen.

Shading

Shading brushes are used to apply a dodge or
burn effect to an image. A Strength value deter-
mines the strength of the effect.

Sponge

Sponge brushes are used to saturate or desaturate
an image. A Strength value determines the
amount of saturation or desaturation.

Noise

Noise brushes are used to add noise to an
image. A Strength value determines the amount
of noise.

Contrast

Contrast brushes are used to increase or decrease
the contrast in an area of an image.

Tint

Tint brushes are used to tint an area of the image
with the current foreground color. See Chapter
Ten: Color Correction for more information on
Tint brushes.

Brush Properties

Different brush properties are available in 
the Brush Tool Options, depending upon the
brush style chosen. 

Opacity

Opacity refers to the possible opacity
of an entire brush stroke. 

• A setting of 100 indicates a perfectly opaque
stroke.

• A setting of 50 indicates a translucent stroke.

• A setting of 10 indicates an almost transpar-
ent stroke.

Strength

Strength is used in the Tint brush
style to determine the amount of the brush
effect. Strength value is measured between 
1 and 100. 
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• A strength of 100 applies the full effect. 

• A strength of 50 applies a medium effect. 

• A strength of 10 applies a very subtle effect.

Concentration

While Opacity refers to the opacity of
the entire stroke, Concentration refers to the
opacity of each individual dab of paint. Opacity
and Concentration combine to yield the 
opacity of the stroke.

• At 100% concentration, the brush is totally
opaque, meaning that it entirely covers any
image or other paint strokes beneath it.

• At 50% concentration, each dab of paint is
semi-opaque. However, since many dabs are
packed closely together in an average stroke
(how closely depends on the Tip Spacing 
factor), a concentration of 50 percent tends
to be very opaque. 

• At 15% concentration, the brush will pro-
duce a nice, semi-translucent paint stroke.

• At 5% the brush yields a fine, misty 
airbrush-type of effect.

Concentration and Spacing (discussed below)
interact very closely. If you increase the Spacing,
you decrease the Opacity.

Flow

Flow refers to the amount of ink
build-up that occurs during one mouse click (or
pen click) on the document. The Flow amount
takes effect when you click the mouse on the
document and do not move the mouse. For
brushes with high Flow values, clicking on the
document without moving the mouse produces a
build-up of paint, much like what would be seen
immediately after placing a quill pen on paper.
The Flow value is controlled as follows:

• A high Flow value shoots paint out of the
brush (mouse) very rapidly until you release
the mouse button. Keeping the mouse but-
ton pressed down is the equivalent of shoot-
ing an airbrush in one place for a few
seconds. A high Flow value is useful for inks
and airbrushes.

• A Flow value of 0 places only one dab of
paint on the document regardless of how
long you hold the mouse in one place.

• In-between values produce a medium
amount of ink build-up.

Spacing

Spacing controls the concentration of paint dabs.
The closer the spacing, the more dabs per inch,
and the more dense the paint stroke will be. At
high Spacing, on the other hand, you can clearly
see the individual dabs.

Spacing in xRes S.E. is measured as a proportion
of brush size. For example, if the brush size is 10
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pixels, a Spacing setting of 50% implies that
there are 50% x 10 = 5 pixels between each dab.
The advantage of this scaling system is that if
you increase the size of the brush, you don’t have
to change the Spacing to get the same look.

Generally speaking, you don’t want to see the
impact of an individual dab on a brush stroke.
The brush type and its opacity influence how
small the Tip Spacing must be to disguise indi-
vidual dabs of paint. 

• For an airbrush, you can get away with
Spacing of up to 25%. Because these brushes
are so translucent, the dabs do not show up
as easily.

• For a typical retouch brush with a soft edge,
a Spacing of 15% is appropriate. The soft
edge helps disguise the impact of individual
dabs, but the high opacity of these brushes
does require tight Spacing.

• At the extreme, a Calligraphy brush requires
a Spacing of 1 or 2 percent to produce crisp
results.  

• A Spacing of 0 indicates no Spacing at all. In
other words, the dabs apply without regard
to how many dabs per inch. This absence of
Spacing produces very blotchy results.

Note: Higher Spacing can slow down the real-time per-
formance of the brush.

Smoothing

Ha ve you ever painted on the computer and felt
that your strokes looked like they we re done on
f i ve cups of coffee? You are not alone. Most com-
puter programs do not offer any form of mouse
smoothing, and the result is jagged strokes. Eve n
if you are using a pre s s u re - s e n s i t i ve tablet, it is
ve ry difficult to draw a smooth line with the pen
unless you have some additional help from the
c o m p u t e r. This is where the Smoothing slider on
the Brush Tool Options is useful. 

The Smoothing control applies a smoothing
algorithm to the brush path, allowing you to
paint with very smooth strokes, even with a
standard mouse. The algorithm works by exam-
ining the path of the stroke and smoothing out
that path as the cursor moves. The advantage of
this technique is that you can achieve extremely
smooth, ribbon-like effects even with the stan-
dard mouse. The disadvantage is that the paint
can lag slightly behind the brush. Smoothing
also makes the brush less responsive to minor
variations in the tablet or the mouse.

Smoothing is set to parameters between 0 and
100. Some examples are:

• Smoothing of 0: This indicates no smooth-
ing at all. Pencils and other tools which
require the ability to black and fill should
not have any smoothing. 

• Smoothing of 7: This number represents an
average value for many brushes. It introduces
a small lead between the paint and the
mouse, but it produces smoother strokes.
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• Smoothing of 15 or more: High values of
smoothing are used infrequently, mainly for
calligraphy and other ornamental effects. 

Texture

xRes S.E. supports paper textures. After specify-
ing the texture in the Textures Palette or creating
your own you can configure your brush to react
with that texture by altering the Texture and
Fringe values of the brush. 

The Texture value controls how textured the
overall stroke appears: the higher the value, the
more textured the brush.

Fringe

The Fringe value controls the texture at the edge
of the brush: the higher the fringe value, the
more fringed, or shredded, the strokes appear.
Brushes with high Fringe values include pencil
and charcoal. The fringe is affected by the paper
texture set in the Textures Palette. 

Bleed

The Bleed control affects how the colors of the
brush bleed into the colors already on the can-
vas. If you set Bleed at a high level, it will dilute
the brush strokes. A high bleed level is used in
the watercolor brushes to achieve the watery
effect.

With xRes S.E., you can tell the program exactly
how much bleeding you want to occur for each

brush. This is useful for simulating watercolor
effects.

Blackness

Blackness adds tremendous realism to most paint
strokes; this is important to brushes such as
charcoal or felt-tip pens. The general idea of
Blackness is that it affects how the colors burn
into the background. When blackness is set to
0%, the blending is a strict (additive opacity)
blend. This mimics the way oil paints tend to
blend. Setting Blackness close to 100% results in
a subtractive blending that is closer to the way 
liquid inks blend.

Ranges for Blackness are as follows:

• Blackness 0: In this case, each stroke covers
up the last with no color build-up. Even if
the stroke is semi-transparent, the effect can
seem artificial. 

• Blackness 100: The maximum Blackness set-
ting corresponds to a pure Subtractive Mode.
This setting mimics the way inks blend, with
each stroke darkening the previous stroke,
and the colors becoming more saturated. 

• Intermediate Values: Values between 0 and
100 are used for most brushes. You can
tweak the Blackness value of each brush.

Note: High Bleed and Blackness values used in combina-
tions produce dark, liquid ink effects.
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Tips

Vincent Van Gogh and other impressionists
tended to show the bristles in their brush
strokes. On the computer, we can’t simulate (yet)
an actual brush with 1000 individual hairs, but
we can approximate this result by using multiple
tips for each stroke. 

xRes S.E. has a maximum of 20 tips per brush.
These tips move in unison to produce an
approximation of the Van Gogh effect. The Tips
slider directly specifies the number of tips or
bristles. 

• Most brushes use a single tip. This includes
all of the retouch brushes.

• You can start getting the Van Gogh effect
with as few as 5 tips.

• 15 tips is probably the maximum you will
ever need.

Note: Multiple-tipped brushes can be slower than single-
tipped brushes. 

Tip Spacing

The Tip Spacing Slider controls the distance
between brush tips for a multi-tipped brush.
Small distances produce brush tips that overlap,
creating a creamy oil effect. Large Tip Spacing
produces bristles that are farther apart, creating
the effect of random bristles.

Tip Spacing is measured as a percentage of the
overall brush size. For example, a Tip Spacing
value of 40 creates a distance between strokes
that equals 40% of the brush size.

Brush Tool Options Submenu
The Brush Tool Options submenu allows you to
c reate many brush pro p e rty relationships. The sub-
menu accesses six different dialogs that allow yo u
to create pre s s u re or speed relationships, dire c t i o n
relationships, and randomness re l a t i o n s h i p s.

The dialogs function by listing the behavior at
the top of the dialog and properties at the bot-
tom of the dialog. The brush properties listed at
the bottom of the dialog vary depending on the
brush style. The brush properties listed in these
dialogs can include:

• Size: Changes the size of the brush based on
the specified brush behavior.

• Concentration: Changes the concentration of
the brush dabs based on a certain brush
behavior.

• Blackness: Changes the Blackness value of
the brush based on the specified brush
behavior.

• Angle: Changes the angle of the brush dabs
based on the specified brush behavior.

• Hue: Changes the hue of the paint dabs
based on the specified brush behavior.
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• Lightness: Changes the lightness of the paint
dabs based on the specified brush behavior.

• Saturation: Changes the saturation of the bru s h
dabs based on the specified brush behavior.

• Scatter: Affects the distance between paint
dabs. 

Pressure and S peed Relationships

Pressure-sensitivity refers to differing brush
behavior based on the pressure placed on a pres-
sure-sensitive tablet. Placing more pressure on
the tablet produces a larger brush, and placing
less pressure on the tablet produces a smaller
brush. Pressure-sensitivity behavior allows you to
simulate natural brush behavior by giving the
brush a gradual build-up in size, opacity, and
blackness.

Speed-sensitivity refers to different brush behav-
ior based on the speed of the mouse or stylus.
Moving the mouse faster produces a thinner
brush, and moving the mouse slower produces a
thicker brush.

By accessing Pressure Sensitivity or Speed
Sensitivity from the Brushes Palette, you can
activate pressure-sensitivity and speed-sensitivity.

When you use a mouse, the Pressure Sensitivity
and Speed Sensitivity dialogs have the same
effect; they control brush behavior based on the
speed of the mouse. If you use the Pressure
Sensitivity dialog, then:

• Dragging the mouse slowly is the equivalent
of placing more pressure on the tablet.

• Dragging the mouse rapidly is the equivalent
of placing less pressure on the tablet.

Macromedia recommends that, if using a mouse,
you use either the Speed Sensitivity dialog or the
Pressure Sensitivity dialog. If you use both
dialogs, then the values entered in the dialogs
will be combined to determine brush behavior
based on mouse speed.

If you use a tablet, the Pressure Sensitivity dialog
controls the behavior of the brush based on the
pressure placed on the tablet. The Speed
Sensitivity dialog controls the behavior of the
brush based on the speed of the pen or stylus.

To Make a B rush Pressure-Sensitiv e

or S peed-Sensitiv e

1 Access the Pressure Sensitivity or Speed
Sensitivity dialogs from the Brush Tool
Options submenu.

2 The bottom of the dialog lists the brush
properties that can be affected by the pres-
sure or speed of the brush. For example,
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artistic style brushes include the following:
Size, Concentration, Blackness, Angle, Hue,
Lightness, Saturation, and Scatter.

Click the checkbox next to the brush properties
that you wish to be affected by pressure or speed.

For example, clicking “Size” in the Pressure
Sensitivity dialog makes the size of the brush
vary depending on pressure.

3 A slider at the top of the dialog controls the
degree of the relationship. The slider can be
set between 1 and 100. A setting of 100 pro-
duces a stronger relationship than a setting of
1. Generally, it is recommended that you set
the slider in the Pressure Sensitivity and
Speed Sensitivity dialogs between 50 and
100.

4 Click OK to accept the settings.

5 If you have made the pressure or speed of the
mouse or tablet affect the size of the brush,
there is one more step to take. Access Size
Sensitivity from the Brushes submenu. A dia-
log appears that has two sliders: MinSize and
NumSizes.

The MinSize refers to the minimum size of the
brush as a percentage of the total size. When a
brush is pressure or speed sensitive, placing less
pressure on the tablet or moving the mouse
rapidly produces a brush that reflects the mini-
mum size. Placing more pressure on the tablet or
moving the mouse slowly reflects the maximum
size. The maximum size of the brush is set in the
Shape Inspector size-slider.

The NumSizes slider refers to the number of
sizes between the minimum size brush and maxi-
mum size brush. The greater the number of sizes
is, the smoother the transition between a smaller
brush size and a larger brush size. 

6 Adjust the MinSize and NumSizes sliders
and click OK. You have made your brush
pressure-sensitive or speed-sensitive.

Direction Relationships

Direction relationships change brush properties
based on the vertical or horizontal direction of
the brush. Vertical Sensitivity creates brush rela-
tionships based on the vertical direction of the
brush stroke. Horizontal Sensitivity creates brush
relationships based on the horizontal direction of
the brush stroke.

To Create Direction Relationships

1 Access “Vertical Sensitivity” or “Horizontal
Sensitivity” from the Brush Tool Options
submenu. 

2 Check the checkboxes of pro p e rties you want
to be affected by the direction of the brush. Fo r
example, to make the direction of the bru s h
affect the hue, check “Hu e.” This would pro-
duce a brush that paints in different hues based
on the direction you drag the mouse.

3 A slider at the top of the dialog controls the
degree of the relationship. A value of 100
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produces a stronger relationship than a value
of 10. Move the slider to the desired value.

4 Click OK to accept the settings.

Random Relationships

Random brush relationships introduce a degree
of randomness into brush properties. Random
relationships are used to create oil brushes with
multi-colored tips. They are also used to create
other special effects.

To Create Random Relationships

1 Access “Random Sensitivity” from the Brush
Tool Options submenu.

2 Check the checkboxes of properties you want
to be random. For example, to make the hue
value random, check “Hue.” 

If a brush has one tip, the hue, lightness, and
saturation properties affect each dab of paint. 
If a brush has many tips, these same properties
affect each brush tip instead of each dab 
of paint.

3 The top of the dialog displays a slider 
controlling the amount of the random 
relationship. Lower settings produce less 
random relationships. Move the slider to 
the desired value.

4 Click OK to accept the settings.

Textures Palett e
The Textures Palette stores all of the available
paper textures in effect. The brushes in xRes S.E.
respond to the active texture. One texture is
a c t i ve at all times. To make a texture active, click it.

For example, you can select rice paper for use
with the Japanese brush, heavy cotton paper 
for watercolor, or a glossy coated surface for a 
felt-tipped drawing. Textures add dimension,
liveliness, and realism to images.

The Textures Palette contains the following:

• Texture Icons: There is one icon for each
paper texture. Click any Texture icon to
automatically make that texture active. 
Only one texture can be active at a time.

• Scroll Bar: This allows you to scroll through
the available textures.

• Invert Checkbox: Inverts the current texture.

• Duplicate Icon: This icon duplicates existing
textures.

• Trash: This icon deletes existing textures.

To Rear range the Texture Icons 

within the Palett e

Click a Texture icon and drag it to its new
location on the Palette. The other Texture icons
shift accordingly.
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To Change the Name of a Texture

Double-click the desired Texture icon. A dialog
appears allowing you to enter a new name for
the texture.

To Duplic ate an Existing Texture

Click the Texture icon and drag it to the 
New Icon. A dialog allows you to enter a new
name for the texture. The default name is the
previous name with the word “Copy” after it, for
example, “Sand Copy.”

To Delete a Texture

Click the Texture icon and drag it to the trash 
on the Textures Palette. 

Note: You cannot undo the deletion of a texture with the
Edit >Undo command. To restore a deleted texture,
uncheck “Save Textures” on Exit from the General
Preferences and relaunch xRes S.E..

To Create a New Tex ture

You can create your own custom textures for the
Textures Palette. 

1 Create a new document that is 96 x 96 pix-
els. The size can also be multiples of 96, such
as 960 x 960 pixels or 192 x 192 pixels. The
size of the document will determine the size
of the texture.

2 Create a design you want to use for a
texture using any of the brushes or filters
of xRes S.E..

3 Access the Objects Wi n d ow (menu command
Wi n d ow > Objects). Check that the object
d i s p l a yed in the Objects Wi n d ow matches the
object on screen. If the Objects Wi n d ow has
not updated, compact and re-open the Ob j e c t
Wi n d ow, and the object will be updated.

4 Drag the object from the Objects Window
into the Textures Palette (menu command
Window > Palettes > Textures). A dialog
appears prompting you for a name for the
texture.

5 Enter a name in the dialog and click OK.
The texture is added as the last texture in the
Textures Palette. You can click and drag your
texture to a new location within the Palette.

Saving Textures

Any changes made to the Te x t u res Palette, includ-
ing adding textures, are saved automatically for
the current session. To save the changes perma-
nently to disk, use the menu command File >
Pre f e rences > General. Make sure that the “Sa ve
Te x t u res on Ex i t” pre f e rence is checked. When it
is checked, all changes made to the Te x t u re s
Palette are automatically saved to disk. If it is not
checked, the changes are saved for the current ses-
sion only.
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Erasing
To access the Eraser Tool, click the Eraser Icon
on the Tools Palette. 

To Use the E raser Tool

1 Click the Eraser Icon on the Tools Palette.

2 Access the Brushes Palette by double-clicking
the Eraser Icon.

3 Select a brush that you want to use for 
erasing. In most cases you will want either
the Hard brushes or Soft brushes.

4 Select a Brush variant from the Variant Menu
(in the Brushes Palette).

5 Click the document and drag to erase. You
are now erasing with the background color.

Erasing to the Last Undo Sta te

The eraser normally erases with the background
color. However, if you press Option (Alt in
Windows) while erasing, you erase to the last
undo state. This feature is very useful. Some
ideas for its use are:

• After applying a filter or color correction
effect, Option- (Alt- in Windows) erase to
undo only part of the effect.

• Option- (Alt- in Windows) erase with the
airbrush or a semi-opaque brush to achieve
a unique artistic effect. 

• Option- (Alt- in Windows) erase to erase a
paint stroke you just painted. You will also
erase to the previous background of the
image. This method is better than erasing
with the background color because the 
background color can alter the background
of the original image.

Note: You can also erase to the last undo by checking
“Erase to Undo” in the Eraser Options. To access the
Eraser Options, select the Eraser Tool and use the menu
command Window > Inspectors > Tool Options, or sim-
ply double-click the Eraser Tool.

Creating Straight Lines
You can create straight lines in xRes S.E. by
using the Shift key.

To Create Straight Lines with the Shift K ey

The first method used to create straight lines is
to press the Shift key while using the Eraser or
Brush Tools. You can use the Shift key to create
straight lines and to constrain lines to be either
horizontal or vertical.

1 Click the Paint Tool or the Eraser Tool on
the Toolbar.

2 Click the document. 

3 Hold down the Shift key and click another
point. The two points will connect to form a
straight line. If you hold the Shift key,
you can create a series of straight lines.



4 If you start using a different tool or apply a
filter, you can connect the line where it pre-
viously stopped. To do this, reselect the
Brush Tool if it is not already selected, press
the Shift key, and click the document. A
straight line is created, connected to the pre-
vious brush stroke.

To Create Horizontal or Vertical Lines

You can constrain a line to either the horizontal
or vertical axis.

1 Select the Paint Tool or Eraser Tool on the
Tools Palette.

2 Start to drag a paint stroke.

3 Hold down the Shift key. The stroke will be
constrained to either the horizontal or ve rt i c a l
axis, depending on which direction you drag.

Cloning
Cloning is the process of replicating one part
of an image and pasting it to another part of 
the image. Cloning has several uses in the image
creation process:

• Cloning is often the best way to touch up
photographs and images. It is often more
accurate and more controllable. For example,
imagine that a photograph has some scratch-
es on it. Using filters such as Noise and
Sharpen would not eliminate the scratches;

they can even enhance the scratches. A better
solution is to use the Clone Tool to clone a
nearby, similar part of the image (that had
no scratches on it) over the scratched part of
the image.

• Cloning can be used to replicate one part of
an image onto another. This method is sim-
pler than dragging an object from one docu-
ment to another. Cloning can also be used to
replicate part of one object to part of another
object.

• Artistic effects can be created using the
Clone Tool that cannot be created any other
way. For example, you can clone part of an
image using any artistic effect, such as an air-
brush. The result would be a soft, ghost-like
reproduction. You can easily produce artistic
effects by cloning with the Cubist or
Pointillist brushes.

To Clone an Image

1 Access the Brushes Palette (menu command
Window > Palettes > Brushes), and click the
brush you wish to use for cloning. For basic
cloning, select the Hard or Soft brushes. The
Hard brush clones with a hard-edged brush;
the Soft brush clones with softer edges. To
clone with an artistic effect, select another
brush, such as Airbrush or Oils.

2 In the Brushes Palette, select a variant in the
Variant Menu.
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3 Click the Stamp Tool on the Tools Palette.

4 The Stamp Tool works by defining an anchor
point around which to clone. To select an
anchor point, Option- (Alt- in Windows)
click an area of the image. Release the mouse
button to place the anchor point.

5 Click the target area that is to be the destina-
tion for the clone, and drag to clone the
image from the source area to the target area.
This target area can be in a different object
than the anchor point in the source area.

Note: When cloning, you can clone from one object to
another object as long as those two objects are in the same
document. You cannot clone from one document to
another document. 

In xRes Mode, you can only clone from one
object to the same object; you cannot clone 
from one object to a different object. See
Chapter Nine: Working in xRes Mode for more
information.

Aligned/Non-Aligned Cloning

Cloning is normally aligned. This means that
each time you move the mouse, the anchor 
point will move proportionately.

Non-aligned cloning will clone from the original
anchor point regardless of where you click the
cursor. To clone in the Non-Aligned Mode, hold
down the Shift key as you clone.

You can also clone in a Non-Aligned Mode by
accessing the Stamp Tool Options dialog, and
unchecking “Aligned.” To access the Stamp
Options, select the Stamp Tool on the Tools
Palette, and use the menu command 
Window > Inspectors > Tool Options, or 
simply double-click the Stamp Tool.
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5 Chapter Fiv e
Colors

Overvie w

This chapter discusses how colors are created, edited, and selected in an
xRes S.E. document. It also discusses Color modes and Color theory.
Topics include:

• Essential Terms

• Foreground and Background Colors

• Picking Colors

• Using the Swatches Palette

• Document Color Modes

• Using a Custom Indexed 256 Palette



Essential Terms

Active Objec t

An active object is the same thing as a selected
object, which is represented as gray in the
Objects Window. (Inactive objects are white in
the Objects Window.)

Selected Area

The selected area is the area inside the dotted 
black line or flashing marquee created with the
marquee tools, FastMask, or the Mask Window.

Foreground and Background
Colors
The current foreground and background colors
are displayed in the
Tools Palette.

The foreground and
background colors
have different uses.
The foreground color is used 
for painting operations and for the Bucket 
Tool. The background color is used for 
erasing operations. 

To switch the foreground and 
background colors, click the 
small double arrow in the 
Tools Palette.

Default Colors

The black and white microswatches
underneath the foreground and back-
ground colors are called the default col-
ors. The default colors are useful for
painting operations that involve strictly black
and white. Clicking on the default colors
changes the foreground
color to black and the
background color to
white. Clicking on the
default colors again
returns the foreground
color and background
color to their previous
states.

Picking Colors
There are three ways to pick colors in xRes S.E.:
the Color Picker, the Swatches Palette, and the
Eyedropper Tool. 

Using the Color Picker

Of the three color sampling methods, using 
the Color Picker allows you to choose from 
the widest range of colors including Pantone 
colors. 
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There are twm`ways to access the Color Picker:

• Use the menu command Window > Palettes
> Picker.

• Double-click the foreground swatch or the
background swatch in the Tools Palette.

Components of the Color Picker

Color Mode Menu

This menu allows you to choose a mode for
selecting colors while leaving the Color Mode 
of the document unaffected. Available Color
Modes include RGB, CMYK, HSB, HLS, YIQ,
Grayscale, and Custom Colors, which allows you
to pick a custom Pantone color.

Foreground S watch

The swatch on the left-hand side of the Color

Picker represents the current foreground 
color. As you change the sliders in the Color
Picker to change the color, this swatch will
update automatically.

Color Sliders

The color sliders are used to numerically enter 
a color in the Color Picker. As you move the
sliders or enter a new number for the sliders, 
the foreground swatch updates automatically.

Radio Buttons

The radio buttons are the three circles to the left
of each channel slider. At all times, one and only
one radio button is selected. The radio button is
used to determine the fixed channel, which
determines how the colors are organized within
the Preview window.

Preview Window

The Preview window represents the top of the
Color Picker; it previews the range of available
colors. Clicking on a color in the Preview
window makes that color the foreground color.

Hue Bar

The hue bar at the bottom of the Color Picker is
used as a shortcut for quickly accessing colors.
The hue bar displays color hues from 1 to 360°
left to right, and lightness values from 0 to 100
top to bottom. 
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To Pick a Color from the Color Picker

1 Select the Color Mode. Choices include
RGB, HSB, HLS, YIQ and Grayscale. The
Color Mode determines the range of colors
available through the Color Picker.

2 Select a fixed channel by clicking a radio 
button next to one of the channels. The fixed
channel determines the organization used in
displaying colors in the Color Picker.

3 Move the slider of the fixed channel until the
color you wish to use is displayed in the
Preview window.

4 Select a color using one of these methods:

• Click in the Preview window to select the 
color you want to use.

• Move the color sliders to select a color.
As you drag the sliders, the current color 
is reflected in the foreground swatch.

• Use the entry fields to the right of the 
color sliders to numerically enter the 
color you wish to use.

Note: You may also select a color by clicking anywhere on
the hue bar at the bottom of the Color Picker. See “Hue
Bar” in this chapter for more information.

Setting the Color M ode

The Color Mode menu determines the range of
colors available when using the Color Picker.

Macromedia recommends that you select the
Color Mode in the Color Picker that corre-
sponds to the Color Mode of the document. 

Note: Changing the Color Mode in the Color Picker does
not affect the Color Mode of the document; rather, it
affects the range of colors available in the Color Picker.

Color M ode Menu

RGB

RGB allows you to choose a color with red,
green, and blue values ranging from 0 to 255. 

CMYK

CMYK allows you to choose a color with cyan,
magenta, yellow, and black values ranging from
0 to 100%. 

Grayscale

Grayscale allows you to choose a color that is
pure black, pure white, or varying shades of gray
from 1 to 100 % black.

HSB

HSB allows you to choose a color with a hue
value from 0° to 360° and a saturation and
brightnesW value from 1% to 100%. The hue
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value is based on the color wheel, with 0 refer-
ring to the red value on the color wheel. For
example, if the hue is set to 250, a blue value is
displayed, because blue is 250 degrees clockwise
from red on the color wheel. 

HLS

HLS allows you to choose color with a hue value
from 0° to 360° on the color wheel and satura-
tion and lightness values from 1% to 100%. 

YIQ

YIQ allows you to choose colors based on the 
luminosity, chroma, and intensity of the pixels. 
The advantage of this method is that it may 
offer a smoother transition of colors than the 
other methods.

Selecting the Fixed Channel

The fixed channel determines the organization
used when displaying colors in the Preview win-
dow of the Color Picker. Only one channel is the
fixed channel at any given time. 

The Preview window of the Color Picker 
displays color only as they are defined by
the value of the fixed channel. 

For example, suppose that you are working in
the RGB color space, red is the fixed channel,
and the red value is 55. The Preview window
displays colors in which the red value is 55, and
the green and blue values are between 0 and 255.

Moving the slider of the fixed channel changes the
colors displayed in the Pre v i ew window; changing
the sliders of other channels does not change the
colors displayed in the Pre v i ew window.

Using the Hue Bar

The hue bar at the bottom of the Color Picker is
a quick way to select colors. Clicking anywhere
on the hue bar selects that color as the current
foreground color.

The hue bar displays colors of varying hues from
left to right, and of varying brightness values
from top to bottom.

Accessing the Apple Color Picker ®

Macintosh users may access the Apple Color
Picker by double-clicking on the current color
swatch in the left of the Color Picker. The Apple
Color Picker allows you to choose a color based
on the Apple Color Wheel. See The Macintosh
User’s Guide for more information on using the
Apple Color Picker.

Currently, there is no Windows equivalent to the
Apple Color Picker.

Using the S watches Palett e
In addition to the Color Picker, xRes S.E. allows
you to select colors with the Swatches Palette.
The Swatches Palette may be used to store fre-
quently accessed colors. Accessing specific colors
using the Swatches Palette is often quicker than
locating those colors in the Color Picker.

Colors 77



The Swatches Palette is accessed by the menu
command Window > Palettes > Swatches. 

The Swatches Palette contains swatches of specif-
ic colors. You can load and save different palettes
of swatches; you can also add, delete, and edit
the swatches in a palette.

To Select a Color from the 

Swatches Palett e

To pick a color from any one of these swatches,
simply click it. The foreground color is replaced
by the color of the swatch.

To Set a Color in the S watches Palett e

To set the color of any swatch, select a color by
using the Color Picker or sampling a color from
the image. Then Shift-click that swatch. The 
current foreground color replaces the color of 
the swatch. 

To Add a Color in the S watches Palett e

Click in the Swatches Palette in the empty white
space between the last color swatch and the end

of the palette to add a new swatch. This opera-
tion adds a swatch of the current foreground
color to the Swatches Palette.

To Delete a S watch

To delete a swatch, Command-click (Ctrl-click
in Windows) the swatch you wish to delete. 

Note: You cannot undo deleting a swatch with the Edit >
Undo command. To restore the deleted swatch, reload the
Swatches Palette. See “To Load a Swatches Palette”
below.

To Save a Swatches Palett e

You can save and load custom Swatches
Windows.

Changes made to a palette are not saved unless
you save them to disk. To save a palette, choose
“Save Palette” from the Swatches Palette sub-
menu. A dialog appears prompting you for a
name and location for the palette.

To Load a S watches Palett e

To load a palette, use the Load Palette command
from the Swatches Palette submenu. A dialog
box allows you to choose a name and location
for the palettes you load. Select the palette you
wish to open and click Open.

Note: xRes S.E. ships with several predefined swatches
palettes. These palettes are located in the Swatches fold-
er/directory in the xRes S.E. Resources folder/directory.
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Sampling Colors

The third method of picking colors in xRes S.E.
is with the Eyedropper Tool located on the
Tools Palette. This Tool selects a color from the
image and sets the foreground color based on
this color. The process of selecting colors from
the image using the Eyedropper Tool is called
sampling colors. 

Using the E yedropper Tool

To use the Eyedropper Tool, select
it from the Tools Palette, and then
click the document to sample the
color. The current foreground
color changes to reflect the sam-
pled color. Alternatively, pressing
Option (Alt in Windows) while
using the Brush Tool or Gradient
Tool turns the tool into an
Eyedropper Tool.

To Set Eyedropper Tool Options

Normally, the Eyedropper Tool
samples the color that is directly underneath the
cursor. However, it is possible to have xRes S.E.
average out all of the pixels over a certain radius,
in order to produce an average color. To set this
radius, double-click the Eyedropper Tool, access-
ing the Eyedropper Options. Enter a radius from
1 to 32.  A value of 1 samples only 1 pixel. A
value of 32 samples pixels within a 32-pixel
radius and averageÛ these colors. 

Using the Info Inspec tor

The Info Inspector is used to
numerically examine a sampled
area. A sampled area may be 1
pixel if the eyedropper radius is
set to 1, or many pixels if the
eyedropper radius is set greater
than 1.  

Use the menu command
Window > Inspectors > Info to
make phe Info Inspector visible. The Info
Inspector displays:

• The R, G, and B values for the sampled area.

• The C, M, Y, and K values for the sampled
area.

• The X and Y coordinates of the sampled 
area in pixels.

Dragging the Eyedropper Tool over the image
displays different values in the Info Inspector. As
you move the Eyedropper over the image, the
values in the Info Inspector update automatically.

Document Color M odes
Each image in xRes S.E. is in a certain Color
Mode. xRes S.E. supports three Color Mo d e s :
RGB, Grayscale, and In d e xed 256. 

When you create a new image in xRes S.E., you 
specify the Color Mode of the document.
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When you open an existing document, that doc-
ument opens in the Color Mode it was previous-
ly saved in. To change the Color Mode of a
document, use the menu command Modify >
Color Mode. 

Color Theor y

In 1931, a French academic institute called
Centre International de l’Eclairage (CIE) made a
comprehensive study of which light sources
could be perceived by humans, and how these
light sources could be derived from three spectral
distributions. They found that three specific
color distributions outside of the visible gamut,
combined with the light sources, produced every
possible visible color. Rather than using all three
colors, the institute normalized the results to two
colors: Red and Green. The third dimension of
measurement was the luminance, Y.

For a given luminance the CIE found that all
visible colors fell into a horse-shoe pattern. This
familiar horse-shoe diagram is now found in
most textbooks on color.

The CIE study broke down all visible colors into
a color space that defined the red and green illu-
minants that were used, with a white point as a
benchmark for the luminosity. This important
landmark in scientific color theory gave scientists
an objective or device-independent framework to
discuss color. Given the illuminants and a white
point, it is possible to collapse the entire spectral
profile into three numbers: the CIE coordinates.
Those three numbers explained exactly how a
human perceived that color.

The CIE experiments continued, even after the
original CIE organization was disbanded. There
was a CIExyz Model, a CIEXYZ color space,
and later the CIELUV and CIELAB Models. 
All these models were just different transforma-
tions of the original model, with different 
standard illuminants and white points and with
different coordinate transformations.

While the CIE Color Model works with 
scientifically defined red and green illuminants,
of greater concern to most graphic designers is
the RGB Model, which corresponds directly to
the way computer monitors display color.

Using the RGB M odel

Every color in RGB is defined by three values: 
a red value, a green value, and a blue value. 
The computer interprets these values, displays 
a dot of color on the screen. 

By convention, the values in RGB space are
scaled between 0 and 255. The RGB Color
Model is often visualized as a cube with black at
the origin (R=0, G=0, B=0) and white at the dia-
metrically opposed corner (R=255, G=255,
B=255). Every color that your monitor can dis-
play is within the RGB color gamut.

The advantage of the RGB Color Model is that
it directly corresponds to the way computer
monitors display color. The disadvantage is that
it is completely monitor-specific; e.g., the color
R=128, G=55, B=23 may appear differently on
different monitors. 
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When you are outputting film for a transparency
or transferring a file to a video application, you
should work in the RGB Color Mode.

Using G rayscale

Use the Grayscale Color Mode for a document
that will be printed in the newspaper or other
output device which is limited to grayscale. You
can also use the Grayscale Color Mode to man-
age the file size; Grayscale documents are four
times smaller than CMYK documents of the
same image size and resolution.

Grayscale documents display only shades of gray.
They cannot display any color information.

Using Inde xed 256 Color

Indexed 256 Color Mode provides you with a
quick and accurate way to view images in
Indexed 256 Color Mode for multimedia appli-
cations such as Macromedia Director. This mode
has limited editability compared to RGB and
CMYK.

In addition, you must convert an image to
Indexed 256 Color before saving the file in the
GIF format. See Chapter Two: Opening, Saving,
and Importing Images for more information
about the GIF format.

When you convert to Indexed 256 Color Mode
from another color mode, the Indexed Color
dialog appears, allowing you to select one of the
following:

• Adaptive:  Develops an Indexed Palette for
the image based on the colors in the image.

• Uniform 8-8-4:  Develops an Indexed Palette
for the image based on eight shades of red,
eight shades of green, and four shades of
blue.

• Uniform 6-6-6: Develops an Indexed Palette
for the image based on six shades of red, six
shades of green, and six shades of blue.

• Custom: Uses the current Swatches Palette to
generate an Indexed Palette

Because Indexed 256 Color uses only 256 colors,
the color commands, filters, and brushes work
differently than the other color modes:

• The Invert, Brightness/Contrast,
Hue/Saturation and Balance color commands
affect the indexed palette, not the actual pix-
els. The result of these filters will be different
than if you are working in the other color
modes. In addition, these commands work
on the entire document, even if only one
object is active.

• Filters located under the Effects menu are
not available in Indexed 256 Mode. The
Curves, Levels, Equalize, and Selective Color
commands are also not available in Indexed
256 Mode.

• The Blend Mode of an object can only be
Normal. The object opacity acts as a thresh-
old value for the object. Pixels above this
Brightness value are visible; other pixels are
invisible.
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• Limited brushes are available in Indexed 256
Mode. The brushes may be hard-edged
brushes of any shape. The brushes may have
a Texture value; this texture will reflect the
current texture chosen in the Textures
Palette.

Note: Macromedia recommends that you do not switch
color modes between RGB and Indexed 256 frequently
because the image will become dithered.

Using a Custom 
Indexed 256 Palett e
xRes S.E. allows you to define your own palette
to use in the Indexed 216 Mode, to load and
save these palettes for different jobs, and to
define a transparency color and a matte color.

To create a custom Indexed 256 Palette, access
Modify > Color > Color Index Table while in 
the Indexed 256 Color Mode. This dialog also
appears when you convert to Indexed 256 and
choose Custom.

The Color Index dialog displays the 256 swatch-
es used to define the palette. It also displays Red,
Green, and Blue sliders that allow you to change
the color of each swatch.

The Color Index dialog contains buttons that
allow you to set the void and matte colors. 

To Set a Color in the Inde xed 256 Color Table

To set a color, click on one of the swatches.
Then set the color in one of these two ways:

• Adjust the Red, Green, and Blue sliders in
the Indexed 256 Color Table.

• Drag the cursor over the image until the
color you want to use is below the cursor.
Click the mouse to drop the color into the
selected swatch in the Color Index Table.

To Load and S ave Differen t Tables

The Load and Save buttons on the right side of
the Color Index dialog are used to load and save
custom tables. To load or save a dialog, click the
Load or Save button. 

To Set the Void and M atte Colors

The Void Color refers to the compositing color
used while using the Indexed 256 Color Table.
To set the Void Color, select the desired color,
and click the Set Void Color button.

For example, if you are creating an image to place
on a web page, you set the Void color to a neutral
g r a y. This allows you to see what the image would
look like composited on a neutral gray color.

The Matte Color refers to a color that is trans-
parent when the image is composited. Common
matte colors are black and white. To set the
Matte Color, select the color you wish to be
transparent, and click on the Set Matte Color
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button. To clear the Matte color, click the Clear
Matte Color button.

For example, if you have a portrait image with 
a white background and choose white to be the
transparency color, then areas in the image that
were white will now be transparent. 

Loading Inde xed Tables as S watches

You may load the colors used in the Color Index
Table as swatches to be stored  in the Swatches
Palette. To do this, convert to Indexed Color,
and access the Swatches Palette (Window >
Palettes > Swatches). Choose Load Color Index
Table from the Swatches submenu.
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6 Chapter Six 

Fills

Overvie w

This chapter discusses the nature and uses of fills. Topics include:

• Essential Terms

• Solid Fills

• Gradient Fills



Essential Terms

Fill

To fill is to apply a color or colors to an entire
document or selection. There are three ways to
create a fill in xRes S.E.:

• The Fill command

• The Bucket Tool

• The Gradient Tool

Fills created with the Fill command or the
Bucket Tool use only the selected (foreground 
or background) color to complete the fill.

Gradients

Gradient fills differ from normal fills in that they
can contain multiple colors, multiple shades of
opacity, and textures. For example, a gradient fill
could be rainbow-colored, of varying opacity,
shaped like a cone, one of a metallic texture.

Solid Fills
There are two ways to create solid fills in
xRes S.E.: 

• The Fill command 

• The Bucket Tool

Fill Command

The Fill command is used to fill a selected area
or active object with one color (the foreground
or background color). The Fill command also
allows you to set the opacity for the fill.

To Use the Fill Command

1 Activate all objects you wish to fill. The 
Fill command affects all active objects. 
If a selection is present within an object, 
the command affects only the selection. 

2 Access the Fill command by one of two ways:

• Use the menu command Edit > Fill.

• Click the Fill Icon on the Toolbar.

3 Set the opacity from 1 to 100 in the Fill dialog.
A value of 100 makes the fill fully opaque.

4 Select the foreground or background from
the Colors menu.

5 Click OK. The area is filled with the 
specified color at the specified opacity.

Note: You can use keyboard shortcuts to fill an area with
the foreground or background color at full opacity. Press
Delete to fill an area with the background color. Press
Option-Delete (Alt-Delete in Windows) to fill an area
with the foreground color. These keyboard shortcuts only
work if no paths are present in the document.
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To Use the Bucket Tool

The Bucket Tool is used to fill
contiguous areas of color that are
similar in value. Instead 
of using the Bucket Tool you 
can use the Magic Wand Tool 
to select an area, then fill the
area with the Fill command. The
Bucket Tool is simply a conve-
nient shortcut for the Fill com-
mand. The Bucket Tool Options
(accessed by double-clicking the
Bucket Tool) allow you to specify
the tolerance and opacity for the
fill, and whether or not the fill is anti-aliased.

1 Select the Bucket Tool on the Tools Palette.

2 Click a pixel in the area you wish to fill. The
area filled depends on the tolerance of the
Bucket Tool and the color value of the pixels
adjacent to the pixel you clicked.

Options for the Bucket Tool

Bucket Tool Options include Tolerance, Op a c i t y,
and Anti-aliasing.

1 Access the Bucket Tool Options by double-
clicking the Bucket Tool on the Tools Palette.

2 Check the Anti-Aliasing preference if you 
want the fill to be anti-aliased. Anti-aliasing
produces smooth fills. Unchecking this pref-
erence produces fills with hard edges.  

3 Set the Tolerance for the Bucket Tool from 
1 to 100. Lower tolerances will have the
Bucket Tool fill areas very similar 
to the color value of the pixel you click;
higher tolerances will have the Bucket Tool
fill a broader color range based on the color
value of the pixel you clicked. 

4 Select an Opacity for the bucket from 
1 to 100: 100 is fully opaque, 1 is 
almost transparent.

Gradient Fills
The Gradient Tool is used to create fills with:

• Different colors.

• Different opacity values.

• Different blending modes.

• Different shapes, such as line or ellipse.

• Special effect gradients, such as a 
Satin pattern.

The Gradient Tool can also be used to save and
load customized fills.
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Advanced techniques can be applied with the
Gradient Tool. For example, you can make one
edge of an object opaque, the opposite edge
transparent, and the area in between varying
shades of opacity. The Gradient Tool Options
(accessed by double-clicking the Gradient Tool)
can also be used to add borders to documents or
to colorize an image.

Gradient Shapes

The shape menu (at the bottom left of the
Gradient Tool Options) contains practical shapes
such as Line and Rectangle, and special effect
shapes such as Satin and Folds. 

With all Gradient Fill shapes, the inside or left
side of the shape is filled with the left end of the
color ramp, the outside or right side of the shape
is filled with the right end of the color ramp, and
the opacity ramp (below the color ramp) con-
trols the opacity of the colors.

The gradient shapes are:

Line

After selecting Line
from the shape menu,
drag out a line with
the Gradient Tool to
define the gradient
placement. The
beginning of the line
displays the left side of the gradient color ramp;
the end of the line displays the right side of the
gradient color ramp.

If the dragged line does not cover the full image
area, the ends of the gradient will overlap to
cover the entire area.

Rectangle

After choosing
Rectangle from the
shape menu, you
can drag out a rec-
tangle to define the 
gradient area. The
gradient colors will
translate into the rectangle as follows: 

• The left side of the gradient color ramp will
be displayed at the center of the rectangle.

• The right side of the gradient color ramp will
be displayed at the edge of the rectangle.

Ellipse

The Ellipse works
in the same manner
as the Rectangle.
With the Gradient
Tool selected, drag
out an ellipse and
release. xRes S.E.
will fill the ellipse with the colors from the
gradient ramp.

The Ellipse can be constrained to a circle by
holding the Shift key as it is drawn, or the El l i p s e
can be drawn from its center by holding the
Option key as it is drawn. If you hold both the
Shift and Option keys, the Ellipse is constrained
to a circle drawn from the center of the image.
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Cone

A Cone gradient is a
gradient in which the
colors change
depending on the
angle from a specified
center. For a good
Cone gradient, it is
important that the starting (left) and ending
(right) colors on the gradient color ramp 
are identical so there is no obvious break in 
the gradient. 

To apply a Cone gradient with the Gradient
Tool, click a pixel to specify a center for the
Cone. The Cone will start to the immediate
right of the selected pixel. To be precise, if you
consider the top of your image to be 12 o’clock,
the Cone gradient will start building the Cone at
3 o’clock, and continue clockwise. The gradient
color ramp and gradient opacity ramp are always
applied left to right. 

Diamond

The Diamond 
shape produces a
Diamond-shaped 
gradient with a 
diameter equal in
length to the line
drawn with the
Gradient Tool. The inside of the Diamond 
contains the colors on the left side of the 
gradient color ramp, and the outside of the
Diamond contains the colors on the right side 

of the gradient color ramp. Likewise, the opacity
of these colors is determined left to right on the
gradient opacity ramp.

Hyperbola

The Hyperbola shape
produces an interest-
ing curve effect. The
size and direction of
a line drawn with the
Gradient Tool deter-
mines the shape of
the Hyperbola.

Pinch

To understand how
pinch works, think 
of a rectangle. Then,
pinch all four corners
into the center. The
inside of this pinched
shape is represented
by the left most color in the gradient color ramp;
the outside of the pinched shape contains the
colors on the right side of the gradient color
ramp. The line drawn with the Gradient Tool on
the document determines the size of the pinched
shape.
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Satin

Satin produces a soft,
b i l l owy effect, which is
used primarily for spe-
cial effects. Us i n g
Satin is a ve ry intere s t-
ing way to add texture
to an existing picture .
Apply the gradient at
50% opacity with the Blending Mode set to
“Ad d” or “Bl e n d” to add texture to an existing
d o c u m e n t.

Folds

This produces geo-
metric patterns. The
length of the line
drawn with the
Gradient Tool deter-
mines the shape of
the folds. Experiment with the tool to learn how
to use it.

Gradien t Techniques

The Gradient Tool Options can be used to create
custom gradient fills. It can also be used in com-
bination with other operations for more
advanced imaging techniques, such as:

• Colorizing images.

• Cross-fade effects.

• Gradient borders.

• Special effect backgrounds.

Creating C ross-fade Effects

By applying gradients to the mask channel of
objects, you can create cross-fade effects. 

To Create a Cross-fade Effec t

1 Double-click the Gradient Tool to access the
Gradient Tool Options.

2 Select White > Black from the preset menu,
located in the top left corner of the Gradient
Tool Options.

3 Activate the desired object. To make 
an object active, click on it in the 
Objects Window.

4 Access the Channels window for the active
object (Window > Channels). Click on the
New Icon at the top of the Channels window
to add a new channel; this channel will be
the mask channel of the object, and will be
used to create a transparency mask. Click the
mask checkbox for the new channel, and
click the view checkbox for the composite
channel.
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5 Select a shape for the cross-fade from the
Shape Menu. For example, a Line creates 
the effect of the object fading from opaque
to transparent, from one side to another; 
an Ellipse creates the effect of the object
being opaque in the middle and transparent
at the edges.

6 Apply the gradient by clicking, dragging, 
and releasing the gradient tool on the object
(as per the selected gradient shape). The 
gradient is applied to the mask channel of
the object, and it affects only the transparen-
cy, not the colors, of the object. 

If the result is the exact reverse of what was
desired–for example, the wrong edge of the
object is opaque–access the menu command
Modify > Color > Invert to reverse the effect.

Creating Borders 

with the G radient Tool Options

Using the gradient opacity ramp, it is easy to
affect only the border of an image with the 
gradient fill. To create a border, select the Preset,
Color Mode, and Blending Mode from the
Gradient Tool Options submenus. Set the shape
to “Rectangle” or “Ellipse.” Edit the gradient
opacity ramp so that only a small portion on the
right-hand side is white (opaque), and the rest is
black (transparent). 

To create a border with a gradual edge, create a
gradual transition from black to white in the gra-
dient opacity ramp. To create a border with a
sharp edge, create an abrupt transition from
black to white on the gradient opacity ramp.
Only the areas in the gradient color ramp direct-
ly above the white areas of the gradient opacity
ramp will be visible. These colors will form the
border of the selected shape (Rectangle or
Ellipse).  
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Creating S pecial Effec t
Backgrounds with G radients

To create special effect backgrounds, set
Blending Mode to “Blend.” Set the Shape to
“Satin” or “Folds.” Apply the gradient. An
abstract gradient will appear on the image. 

If you are not pleased with the results, use the
menu command Edit > Undo, then apply the
gradient again, dragging the line in a different
direction or to a different length. Experiment
until you are satisfied.

Preset G radients Menu

xRes S.E. comes with several preset gradients
that can be accessed by the Preset Menu. The
colors, transparency, Color Mode, Blending
Mode, and shape of the gradients is already
determined for preset gradients.

The preset gradients are located in the upper left
corner of the Gradients Options (accessed by
double-clicking on the Gradient Tool). The 
preset gradients are:

Black ➾ White

Use this gradient for converting color pictures to
gray values with the Colorize command while
still remaining in RGB Mode or CMYK Mode.
You can also use this gradient in the mask chan-
nel of an object to create cross-fade effects. 

Cafe au Lait

This gradient is similar to sepiatone seen on old
black and white photographs. Use it as a starting
point for colorizing black and white pictures.
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Sunrise

A strictly opaque gradient from ye l l ow to orange,
this choice is ve ry useful for creating sunrise effects.

Rainbow

This gradient contains the colors red, orange,
yellow, green, light blue, and dark blue. Each
color proceeds from totally opaque to totally
transparent. 

Red Ligh t

This cone-shaped gradient produces a nice light-
ing effect, which looks like a sun ray. Because
this gradient is mostly transparent, it will not
affect most of the underlying picture. 

Applying a P reset G radien t

To apply a preset gradient, follow these steps:

1 Double-click the Gradient Tool on the Tools
Palette to access the Gradient Tool Options.

2 Select a preset gradient from the preset menu
in the upper left corner of the Palette.

3 Select the Color Mode for the gradient from
the menu in the upper right corner of the
Palette. To apply the gradient in the RGB
color space, choose RGB. To apply the gradi-
ent in the CMYK color space, choose CMYK

4 Select a shape for the gradient from the menu
in the bottom left corner of the Gradient
Tool Options. 

5 Select a Blending Mode for the gradient 
from the menu in the bottom right corner 
of the Palette. The Blending Modes for 
gradients are the same as Blending Modes
used for objects. 

6 Click, drag and release to apply the gradient
(as per its shape).

Saving, Naming, and Deleting P reset
Gradients

You can save gradients for the current session
only, or you can save them permanently. You 
can also rename or delete existing gradients. 

Permanently S aving Changes to a P reset

Gradient

To permanently save changes to a preset 
gradient, use the “Save To File” command on 
the Gradient Tool Options submenu.

Saving a P reset G radien t

To save a preset gradient, access the Save
command in the Gradient Tool Options sub-
menu. Any changes you have made to the preset 
gradient are saved only for the current session.

Saving Edited P reset G radients

To save an edited preset gradient, access the
“Save to File” command in the Gradient Tool
Options submenu. A dialog confirms that you
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wish to save your changes permanently to disk.
Use this command to save new presets, name
changes, or deletions permanently to disk. 

Renaming a P reset G radien t

To rename a preset gradient, access the Name
command from the Gradient Tool Options 
submenu. A dialog allows you to enter a new
name for the gradient; this name change applies
only to the current session.

Adding a P reset G radien t

To add a preset gradient, access the “Add” com-
mand from the Gradient Tool Options submenu.
A dialog allows you to enter a name for the new
gradient.

Deleting a P reset G radien t

To delete a preset gradient, access the “Delete”
command from the Gradient Tool Options 
submenu to delete the current gradient.

Gradien t To ol Options

The Gradient Tool Options (accessed by double-
clicking the Gradient Tool) contains options for
the Gradient Tool. They include:

• Shape.

• Color Mode.

• Blending Mode.

• Preset Color.

• Color Ramp and Opacity Ramp 
(with range sliders). 

• Submenu commands.

Shape Menu

This menu is located in the bottom left corner 
of the Gradient Tool Options. The shape of the
gradient is selected with this menu.

Color M ode

This menu is located in the upper right corner 
of the Gradient Tool Options. The Color Mode
(RGB or CMYK) is selected with this menu.

Blending M ode

This menu is located in the bottom right corner
of the Gradient Tool Options. The Blending
Mode is selected with this menu. The Blending
Mode determines how the color values of the
gradient will react with the target object.
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Preset Gradients

This menu is located in the upper left corner of
the Gradient Tool Options. The preset gradient
(colors and opacities) is selected with this menu.

Color Ramp

This ramp allows you to enter the colors to use
in the gradient. The gradient color ramp can be
controlled with the range sliders, described
below under “Range Sliders.”

Opacity Ramp

This ramp, located directly below the color
ramp, allows you to enter the opacity level for
different sections of the gradient. How opacities
are dropped into the gradient opacity ramp is
controlled by the range sliders, as described
below under “Range Sliders.”

Range Sliders

The two triangles below the gradient color ramp
and above the gradient opacity ramp are called
range sliders. They are used to limit the area that
will be affected by colors dropped into the gradient
color ramp and by levels of opacity (white to black
in color) dropped into the gradient opacity ramp.

Submenu Commands

To access the Gradient Tool Options submenu,
click the arrow in the top right corner of the
Gradient Tool Options. With this menu you can
save your own gradients or change the name of
existing gradients.

Creating N ew Gradients

You are not limited to the preset gradient fills
that come with xRes S.E.; you can create new,
custom gradients to suit your needs.

To Create a New Gradient

1 Access the Gradient Tool Options by double-
clicking on the Gradient Tool.
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2 Select “Add” from the Gradient Tool Options
submenu. A dialog appears allowing you to
enter a new name for the gradient. After
entering the name, click OK.

3 Examine the gradient color ramp in the
Gradient Tool Options. The gradient color
ramp is used to enter colors for use in the
gradient fill. Move the range sliders under-
neath the gradient color ramp to determine
where you want to drop the color in the 
gradient fill. The range sliders limit the area
of the gradient color ramp (or the gradient
opacity ramp beneath it) affected when you
drop colors.

4 Select the color you wish to drop into the
gradient color ramp by one of these methods:

• Selecting a color from the Color Picker.

• Selecting a color from the Swatches Palette.

• Sampling a color with the Eyedropper Tool.

See Chapter Five: Colors for more informa-
tion on selecting colors.

5 Drop the selected color into the gradient
color ramp.

To drop a color, drag the mouse over the 
gradient color ramp. Click on the area where
you wish to drop the color. If you do not
release the mouse, you can experiment with
dropping the color in different locations.
Release the mouse button to confirm the
drop, which is limited by the range sliders.

6 Reposition the range sliders to a new loca-
tion, select a new color, and drop the new
color into the gradient color ramp. Continue

repositioning the range sliders and dropping
colors until you have completed the gradient.

7 Examine the small ramp below the gradient
color ramp; this is called the gradient opacity
ramp. The gradient opacity ramp controls
the opacity of the gradient. 

If desired, drop white, black, or gray colors
into the gradient opacity ramp. Dropping
white into the gradient opacity ramp 
produces a fully opaque gradient. Dropping
black in the gradient opacity ramp produces
a transparent gradient. Dropping shades of
gray in the gradient opacity ramp produces
translucent gradients. 

The range sliders limit the area of the 
gradient opacity ramp affected by the drop.

9 Select a Color Mode, Blending Mode, 
and shape for the gradient fill.

10 Select “Save to File” from the Gradient 
Tool Options submenu. A dialog appears,
confirming that you wish to save the new
gradient fill to disk. Click OK.
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Chapter S even
Masks and Channels

Overview

This chapter addresses how to use masks and channels to edit an image.
Topics include:

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

101

7

• Essential Terms

• Masks

• Channels



Essential Terms

Mask

The term “mask” is an old one. In the eighteenth
century, painters used masks to protect selections
of their paintings from unwanted paint. The
mask might have been a paper cutout, a layer of
wax, or other material which could protect a 
section of the painting from paint and could be
easily repositioned or removed.

In traditional photography a mask is used to
protect sections of the photographic paper from
burning, dodging, and other photographic
effects.

In xRes S.E., a mask is created with selection
tools and is displayed on the monitor with a
flashing dotted line called a marquee. The area
within the marquee can be affected by paint
brushes and special effects. The area outside the
marquee is protected from such effects.

An important difference between a mask in tra-
ditional painting or photography and a mask in
xRes S.E. is that the mask in xRes S.E. allows
you to mask and apply various effects to just one
object of a multi-object image.

Channel

Channels are used to store the color information
in a document. For example, the channels in an
RGB document are the Red, Green, and Blue
channels.

Channels that are not primary channels (Red,
Green, or Blue in RGB) are called alpha chan-
nels. Alpha channels are used to store selections
and to mask out parts of objects. In most cases,
alpha channels are not viewable. Alpha channels
can be specified as mask channels. Mask chan-
nels mask out areas of the object.

For example, you can select an airplane from an
image of an airplane in a cloudy sky and store
this airplane selection in an alpha channel. 
By specifying that channel as a mask channel,
only the plane, and not the sky behind it, would
be visible. You could then drag the airplane
object onto a clear sky (for example) and re p o s i-
tion it as desired in the compositing pro c e s s.

The ability to store selections in channels and
specify these channels as mask channels is one of
the unique features of xRes S.E..

Masks

Using Masks in xRes S.E .

In xRes S.E., masks are created using any of the 
selection tools or techniques, including the 
marquee tools (Rectangle and Ellipse), the Lasso
Tool, the Wand Tool, and the Mask Palette.

The boundary of a selection is called a marquee;
the marquee is shown on the screen as a flashing
dotted outline. 
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Only the area inside the marquee will be affected
by image-editing operations, such as applying 
filters, filling, or painting. The area outside of
the selection is protected, or masked, from 
these operations.

Using Selections in xRes S.E.

In xRes S.E., selections are applied to objects,
not to entire documents. Only one object can be
affected by a selection. If objects are overlapping,
only one of them is affected by a given selection.

When a filter, paint, clone, eraser, fill, or gradi-
ent operation is performed in xRes S.E., it is
performed to all active objects. If there is no
selection inside of the object, the operation
affects the entire object. If a selection is avail-
able, the operation affects only the area within
the selection.

When a filter, paint, clone, eraser, fill, or gradi-
ent operation is performed in xRes S.E., follow
the above flow chart to determine which areas of
the image will be affected. 

Marquee Tools
(Rectangle and Ellipse)

The two basic selection tools in xRes S.E. are the 
Rectangle Tool and the
Ellipse Tool. These tools
simply create rectangular or
elliptical selections, which
are designated by a flashing
marquee.
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To Use the Marquee Tools

To use either of the marquee tools:

1 Select the Rectangle Tool or Ellipse Tool
from the Toolbar.

2 Click on the document to anchor the
Rectangle or Ellipse marquee.

3 Drag the mouse diagonally to create the rec-
tangle or ellipse-shaped selection.

When you drag the mouse, you can view the
Delta X and Delta Y numbers in the Info
Inspector (accessed by the menu command
Window > Inspectors > Info). 

The Delta X value refers to the difference on the
X axis between where the cursor was first clicked
and where the cursor is now. The Delta Y va l u e
refers to the difference on the Y axis betwe e n
w h e re the cursor was first clicked and where the
cursor is now. When the Delta X and Delta Y va l-
ues are equal, you have drawn a square with the
Rectangle Tool, or a circle with the Ellipse To o l .
By reading the Info Inspector as you drag, yo u
can view the exact size, in pixels, of the marq u e e.

If you make a mistake with either of these tools,
simply redraw the selection; the new selection
will replace the old selection. When you redraw
the selection, start outside the previous selection;
otherwise, you will float the prior selection.

To Constrain the Marquee Tools

To constrain the Rectangle Tool to a square, or
the Ellipse Tool to a circle, hold down the Shift
key as you drag out the shape.

To Draw from the Cen ter

By default, the Rectangle and Ellipse Tools are
drawn out from a corner, or side, of the shape.
To draw the shapes out from the center, hold
down the Option (Alt in Windows) key as you
drag out the shape.

To Set Rectangle Tool Options and Ellipse

Tool Options

1 Double-click the Rectangle Tool or Ellipse
Tool to access the appropriate Tool Options.

2 Select a method for dragging out the mar-
quee from the method menu. Choices
include Freehand, Constrained Aspect Ratio,
and Fixed Size. Freehand allows you to drag
out a marquee of any size.  

The Constrained Aspect Ratio option constrains
the marquee to a certain width and height ratio.
For example, by setting width to 1 and height to
1, you constrain the marquee to a perfect circle
or square. By setting width to 3 and height to 1,
you drag out a rectangle or ellipse three times as
wide as it is high. 

The Fixed Size option allows you to specify a
size for the marquee, measured in pixels.

3 Enter the variables for your selection:

• If you choose the Freehand option, all 



other choices are disabled; there are no 
variables to set.

• If you choose the Constrained Aspect Ratio
option, enter positive integers for the 
height and width variables.

• If you choose Fi xed Si ze option, enter positive
integers for the height and width va r i a b l e s .
The Fi xed Si ze is always entered in pixe l s.

Any marquee that you drag out on the docu-
ment will be constrained to the proportion, or
fixed size, that you specify.

To Convert Fixed Size from Pixels 

to Inches or Centimeters

The marquee tool options (accessed by double-
clicking on the appropriate marquee tool) allow
you to enter a size for the marquee in pixels.
However, there may be times when you want to
measure a selection in inches or centimeters. 
To do so, follow these steps:

1 Determine the resolution of the image by
examining the Resize Document dialog
(accessed by the menu command Modify >
Resize > Document). Examine the 
resolution, and click Cancel.

2 Multiply the resolution (either pixels per 
inch or pixels per centimeter) by the number 
of inches or centimeters desired. For example,
imagine that you are trying to create a 
selection that is 1˝ high by 2˝ wide, and the
resolution of the document is 100 ppi. En t e r
100 pixels for the height, because 100 ppi x
1̋  = 100 pixels, and enter 200 pixels for the
width, because 200 ppi x 2˝ = 200 pixe l s.

Using the Lasso Tool
The Lasso Tool is used to create a freeform 
o u t l i n e.

To Use the Lasso Tool

1 Click on the Lasso Tool in the Tools Pa l e t t e.

2 Click and drag the cursor around the 
desired selection.

3 When you release the cursor, xRes S.E. closes 
the loop and creates a selection around the
traced area.

To Create a Polygonal 

Selection with the Lasso Tool

The Lasso Tool can also be used to draw straight
line segments. To create straight line segments,
hold down the Option (Alt in Windows) key
and click down on a point. Release the mouse
and click a new point. xRes S.E. will connect the
two points with a line segment. 

You can create a mixed straight line and freehand
selection by holding down8the Option (Alt in
Windows) key at any time to create straight
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lines. This method is appropriate for lassoing
selections without straight lines or easily defined
borders.

Using the Magic Wand Tool
The Magic Wand Tool is used to create selec-
tions based on pixels similar in color value such
as those for a blue sky.

To Use the Magic Wand Tool

1 Click the Magic Wand Tool 
on the Tools Palette.

2 Click a pixel on the document
where you want to create the
selection. A selection is created
based on the color values of the
neighboring pixels.

3 Enter an opacity for the Magic
Wand Tool from 1 to 100. The
opacity of the Magic Wand Tool
determines the strength of any
effects that are applied to the
selection. If the opacity is 100%,
the effects apply at full strength.
If the opacity is 50%, the effects apply at half
strength.

4 If the selection is too small, increase the Ma g i c
Wa n d’s tolerance and create a new selection.
The tolerance can be set in the Magic Wa n d
Tool Options, described below. If the selection
is too large, decrease the Magic Wand toler-
ance and create a new selection.

Note: The Magic Wand Tool does not work in xRes Mo de.

To Set Magic Wand Tool Options

Magic Wand Tool Options allow you to control
the tolerance of the Magic Wand Tool and con-
trol whether or not the selection is anti-aliased. 

1 Double-click the Magic Wand Tool on the
Tools Palette.

2 Enter a tolerance for the Magic Wand
between 0 and 255. Low tolerances create
selections based on a narrow range of colors.
High tolerances create selections based on a
broad range of colors.

3 Check the Anti-Aliasing pre f e rence if yo u
want the selection to be anti-aliased. Anti-
aliasing produces smooth selections, while
non anti-aliasing produces more jagged selec-
t i o n s.

Common Selection Commands
A few common selection commands can simplify
the selection process. These are discussed below.

To Select the E ntire Image

Use the menu command Select > All
to select the entire image, including

portions that extend beyond the visible window.
An alternative is to click the Select All Icon on
the Toolbar.
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To Discard a Selection

Use the menu command Select >
None to discard the current selection.
An alternative is to click the Select

None Icon on the Toolbar.

To Invert a Selection

Use the menu command Select >
In verse to inve rt the current selection.
A l t e r n a t i ve l y, click the Select In ve rt Ic o n

on the To o l b a r. In ve rting the selection switches
the mask and the previously selected are a.

To Add to a Selection

To add to a selection, hold down the Shift key
while using any of the marquee tools. 

To Subtract from a Selection

To subtract from the current selection, hold
down the Command (Ctrl in Windows) key
while using any of the marquee tools.

To Toggle the Visibilit y

of a Selection Outline

To toggle the visibility of a selection, use the
menu command View > Selection. If “Marquee”
is checked in the menu, the selection outline is
visible. If “Marquee” is unchecked in the menu,
the selection outline is invisible; however, it still
acts as a mask for the image. 

Storing and Loading Selections
Storing and Loading selections allows you to
keep multiple selections in the document while
displaying them one at a time on the screen.

To Store a Selection

Use the menu command Select > Store to save
a selection to a channel. A pull-down menu 
will allow you to select a channel or to create a
new channel. 

Storing a selection in a channel ensures that it
can be used after it is discarded on the screen. 

To Load a Channel as a Selection

Any channel can be loaded back into the selec-
tion mask using the menu command 
Select > Load. 

To load a selection, use the menu command
Select > Load and select the channel you wish to
load from the drop-down menu. The loaded
selection replaces the current selection. Use the
Shift key to add the loaded selection to the 
selection on screen. Use the Command (Ctrl in
Windows) key to subtract the loaded selection
from the selection on screen.

When you save a selection to a channel,
xRes S.E. does not discard the selection, so you
will still see that selection on the screen. If
you want to delete the selection, use the menu
command Select > None.
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Creating a Soft-Edged Selection

One of the most useful techniques in photo-
retouching is creating selections that have soft
edges. Soft edge selections can be used to apply 
a gradual effect to a document. For example,
applying a filter to a soft-edged selection applies
that filter 100% to some areas, 50% to others,
and 0% to other areas. If an affected area is near
the edge of the selection, the effect is applied
anywhere between 1% and 100%. 

Another use of soft-edged selections is to create an
object that is opaque in the center but then fades
to transparent at the edges. This effect is cre a t e d
by first making a soft-edged selection and then
floating this selection. See Chapter T h re e :
Objects, for more information on floating and
o b j e c t.

The process of creating a soft-edged selection is
called feathering. To feather a selection in
xRes S.E., use the menu command Select >
Feather. A feathering value can be entered from
1 to 128. A value of 128 provides the most soft-
edged selection; a value 1 provides the most 
hard-edged selection.

Floating a Selection

Selections can be floated with the menu 
command Select > Float. In addition, clicking 
inside a selection immediately after creating it
with the Rectangle, Ellipse, or Lasso Tools 
floats the selection.

When you float a selection, the selection is dis-
carded and a distinct floating object is created

above the document based on the area inside of
the selection. A feathered selection produces an
object with edges that fade from opaque to
transparent. A non-feathered selection produces
an object with crisp edges.

An object that is created with the menu com-
mand Select > Float can be manipulated like any
other object. 

When you create an object by floating a selec-
tion, the selection outline is stored in the first
available alpha channel of the object and acts as
a mask for the object. 

Dropping a Selection

It is often useful to copy a selection from one
object to another. You can copy selections to transfer
the same selection to several objects. To copy a selec-
tion from one object to another, you must drop that
selection from the source object to the target object.

To Drop a Selection

1 The selection that you wish to drop is said to
be on the source object. Move the selection
on top of the object you want to drop the
selection onto; this object is called the target
object. Note that if more than one object is
below the source object, the topmost of these
objects will be the target object.

2 Use the menu command Select > Drop
Selection. The selection from the source
object is copied onto the target object.
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In this example, the selection from the Friends
text object was dropped onto the underlying
object of the boys. The text object was then
deleted. A filter effect applied to the boys object
was constrained to the resulting selection.

Using FastMask M ode
One of the most useful features of high-end image 
editors is the ability to paint in a mask to create a
selection. In xRes S.E., this is accomplished by the
Fa s t Mask Mode. Painting in a mask with the paint
tools allows more flexibility than using the other
selection tools, such as the Magic Wand To o l.

To Enter FastMask M ode

You can toggle between Normal Mode (where
the selection appears as a flashing marquee) and
FastMask Mode by clicking the two icons at the
bottom of the Tools Palette:

While in Normal Mode, masks are represented
by selections. The area that is not in the selection
is the area of the mask. 

While in FastMask Mode, the mask is represent-
ed by a 50% red area. You can change the color
and opacity of this mask to suit your image and
personal preferences.

To Create a Mask in FastMask M ode

When painting in Fa s t Mask Mode, use the colors
black and white to paint in the mask. White paints
in the mask, black erases the mask, and shades of
gray paint in the mask with va rying opacities. 

Follow these steps to create a mask in 
FastMask Mode:

1 Click the FastMask Mode Icon at the bottom
of the Tools Palette.

2 Use the Brushes Palette with the menu 
command Window > Palettes > Brushes, and
select a “Hard” or “Soft” brush. Select 
a variant from the Variant menu. 

3 Click the microswatches on the Toolbar 
to reset the foreground and background 
colors to black and white. 

4 Use the Mask Palette with the menu command
Wi n d ow > Masks. Se ven swatches are lined in
a row across the palette. Be l ow these seve n
swatches are seven smaller checkboxes. Ma k e
s u re all checkboxes are unchecked (blank).

5 Paint with black to paint in the mask, dis-
played as a red overlay. Paint with white to
paint out the mask, which removes the red 
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overlay. You can also paint with shades of
gray; the darker the gray, the closer it is to
painting in the mask. 

6 To return to Normal Mode, click the
Normal Mode Icon at the bottom of the
Tools Palette. The selection is now defined 
as the area outside the mask.

To Change the Mask Color

By default, FastMask Mode displays the mask as
a 50% opaque red mask. The mask color can be
changed by dropping a new color into the Mask
Palette.

1 Choose a color from the Color Picker by
using the menu command Window >
Palettes > Picker. An alternative is to choose
a color from the Swatches Palette, which is
used by the menu command Window >
Palettes > Swatches. 

For information on picking colors from 
the Color Picker or Swatches Palette, see
Chapter Five: Colors.

2 Use the Mask Window with the menu 
command Window > Mask.

3 Drop this color into the color swatch in the
bottom left corner of the Mask Palette.

To Change the Mask Opacit y

The opacity of the mask can be set between 
0 and 100. An opacity of 0 is transparent. An
opacity of 100 is opaque. An opacity between 

1 and 100 is translucent. To change the opacity
of the mask, change the opacity slider in the
Mask Palette. 

Mask Windo w

The Mask Window is used for advanced mask-
ing options. It is used to mask out areas based
on the color values of the pixels. For example,
you could choose to mask out both the blue 
and yellow in a sky. The advantage of the Mask
Window over a tool like the Magic Wand is 
that up to seven colors can be used in the 
Mask Window to determine the area mask. 
In addition, you can specify that the mask 
affects the entire document and not just an 
area of similarly-colored pixels.
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Using the Mask Windo w

The Mask Window is accessed by the menu
command Window > Mask. It contains the 
following elements:

• Seven Swatches: These determine the colors
that will be used to create the mask.

• Seven Microswatches: These microswatches
are located below the main swatches and are
used to toggle the swatches on and off.

• Tolerance Slider: This is used to control the
tolerance range for the mask colors.

• Feather Slider: This is used to control the
feather range for the mask. 

• Color Swatch: This is located in the bottom
left corner of the Mask Window and is used
to set the color of the mask.

• Opacity Slider: This determines the opacity
of the mask.

To Use the Mask Palett e

1 Use the Mask Window with the menu com-
mand Window > Mask.

2 Enter FastMask Mode by clicking on the
FastMask Icon on the Tools Palette.

3 Drop the colors you wish to use for the mask
in the swatches. To drop a color, click the
swatch. As you enter a color, an “X” appears
in the microswatch below the swatch. The
“X” turns the swatch on and indicates that it
will be used in the masking process.

Before entering a color in the Mask Window,
you might want to sample that color from
the document in the area that you wish to
mask. To sample a color, press Option (Alt in
Windows) which turns the cursor into an
Eyedropper Tool and click the document.
The current foreground color now indicates
the sampled color.

Sample as many colors as needed to drop
colors in the Mask Window. You can enter
up to seven colors in the Mask Window.

4 Adjust the tolerance and feather values in the
Mask Window.

The tolerance value controls how close the
masked colors are to the colors in the Mask
Window. A smaller tolerance indicates a nar-
rower range of colors; a larger tolerance indi-
cates a broader range of colors.
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The feather determines how anti-aliased the
mask is. A more feathered mask has less
abrupt edges. See “Creating a Soft-Edged
Selection” in this chapter to learn more
about feathering.

5 Now there are two options: masking the
image globally or masking the image locally.
A global mask masks out all active objects
based on the colors in the Mask Window.
A local mask masks out selected parts of an
image by brushing over them.

To create a global mask, use the menu command
Select > Auto. A mask is created based on the
colors, tolerance, and feather value set in the
Mask Window.

To create a local mask, select a brush from the
Brushes Palette (double-click on the Brush Tool
to open the Brushes Palette). Masking works
best with either the Hard brush or the Soft
brush. To change the variant, use the drop-down
menu at the top of the palette. Paint over the
image in the areas you wish to mask. A mask is
created in these areas only based on the colors,
tolerance, and feather value in the Mask
Window.

The advantage of creating a local mask is that
you can change the values of the Mask Window
as you create different local masks. Masking in
different areas using variable colors, sensitivity,
and feathering allows tremendous freedom for
mask creation.

To Turn Swatches On and Off

Under each swatch in the Mask Window is a
small square, called a microswatch. If this small
square has an X in it, the swatch above it is on.
If this small square does not have an X in it,
then the swatch above it is off. Swatches that are
on affect the mask; swatches that are off do not
affect the mask.

For fastest mask performance, turn on only as
many swatches as needed. Using one or two
swatches to create a mask yields the fastest re s u l t s ;
using six or seven yields the slowest re s u l t s .

To Change Mask Values

Mask values can be changed at any time. For
example, you can locally mask one area and then
locally mask another area with different mask
values. You may also want to change mask val-
ues, for example, if you have created a global
mask that encompasses too much of the image.

To change the mask values, adjust the sliders,
drop new colors in the swatches, and/or turn the
swatches on or off.

Channels
Channels are used to store the color information
in a document. For example, channels in an
RGB document store the Red, Green, and Blue
information for the document. 

Channels that are not primary channels are
called alpha channels. Alpha channels are used to
store selections and mask out parts of objects. 
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xRes S.E. offers channels on a per object basis,
up to 32 channels per object. These channels can
be viewed by the Channels Window (menu
command Window > Channels). Channels are
used for the following purposes:

• Channels allow you to correct scanning
errors. 

All desktop scanners scan the image in three
passes, one for each of the red, green and
blue planes of the image. Often the blue
channel emphasizes scratches on the picture.
By blending the blue channel with another
channel using the Calculation commands,
you can improve the quality of the image.

• Channels allow you to work with spot colors. 

While it is true that most images are printed
in CMYK, there are times when you want 
to use a fifth or a sixth (spot) color to bring
out some text effect or to use as a solid 
background. By creating the effect in a new
channel and saving the file in the DCS 
format, you can create a spot color.

• Channels are useful for storing selections. 

Often when you are working with selections
you need to turn off the selection but still
save your work. To accomplish this, you can
save the selection to a channel which can be
loaded at a later time.

• Channels allow you to create 
interesting effects. 

You can easily create dropshadows, beveled
glass effects, satin embossing, or 3-D effects
with channel operations. There are several
books on the market that discuss using 
channel operations to create interesting
effects. If you move the object after having
created the special effect, the special effect
will move with the object.

Channels Window

Channels are controlled by the Channels
Window, which is accessed by the menu com-
mand Window > Channels, or by clicking on
the Channels Icon on the Toolbar.

The Channels Wi n d ow lists all of the channels on
the left-hand side. Beside each channel is a col-
o red swatch indicating the color of that channel. 

There are two categories organized vertically
with the titles “view” and “mask.” There are
also three icons at the top of the Channels
Window, and these icons Load Selection, 
New Channel, and Delete Channel are used to
add, duplicate, or delete channels.
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To Change the Visibility of a Channel

By toggling the view box in the Channels
Window you can make any channel visible or
invisible. Only those channels with the view box
checked affect the appearance of the document.
Generally speaking, you will want to view all 
primary channels.

If you are using a channel to store a mask or
selection, you generally do not want the view
box of that channel checked. 

At the top of the channels box is the composite
channel, which is RGB, Grayscale, or Indexed
Color. Clicking on the view box of the compos-
ite channel has the same effect as clicking on the
view boxes of each of the primary channels. 

By default, xRes S.E. displays individual chan-
nels in Grayscale, but a combination of two or
more channels in color. For example, if you just
make the red channel visible, the red channel
will appear in Grayscale, but if you make both
the red channel and the green channel visible,
the result will appear yellowish (red + green =
yellow in the RGB color space). 

To make individual color channels appear in
color instead of Grayscale, toggle the “Single
Channels in Gray” preference in the General
Preferences (File > Preferences > General). If this
box is checked, individual channels appear in
Grayscale. If this preference is not selected, then
individual channels appear in color (for example,
a red channel appears red).

Individual channels are shown in Grayscale by
default because it is much easier to inspect and
modify a Grayscale image than it is to modify an
image that is entirely tinted red (or cyan). The
human eye can identify many more shades of
gray than it can shades of red. For this reason,
Macromedia recommends that you 
display channels in Grayscale.

To Change the Editability of a Channel

To change the editability of a channel, click the
channel’s name with the Arrow Tool. Editable
channels are indicated in Grayscale. Non-
editable channels are indicated in white. For
example, if you apply a filter on an image and
the red channel is not editable, then the filter
will only apply to the green and blue channels.

Clicking on the composite channel’s name has
the same effect as making every channel editable.

Mask Channels

Mask channels are used in xRes S.E. to mask out
areas of an object. Mask channels are used for
the following: 

• In text objects, mask channels are used to
make only the text visible.

• Mask channels are used to create cross-fade
effects, that is, to create the effect of an
object fading from opaque to transparent.

• Mask channels are used whenever you 
float a selection. 
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The opacity of the resulting object is con-
strained to the selection area with a mask
channel. The resulting object is actually 
rectangular, but because the opacity is 
limited to the prior selection, the object 
can appear as a different shape on screen.

• By transferring the selections in mask 
channels from one object to another, you 
can create two objects of the exact same
shape. For example, you could have two
objects containing different patterns that 
are both egg shaped.

To Create a Mask Channel

A mask channel works by taking gray informa-
tion of the channel and using it to determine the
opacity of the object. Areas of white in the mask
channel result in opaque areas of the object.
Areas of black in the mask channel result in
transparent areas of the object. Areas of gray in
the object result in translucent areas of the
object. The shade of gray determines the exact
opacity of the object; darker shades of gray in a
mask channel produce a more transparent object
than lighter shades of gray.

If more than one channel is specified to be the
mask channel, xRes S.E. applies the intersection
of these channels. In other words, only areas of
the image that are opaque in both mask channels
remain opaque if both mask channels are selected.

To Create a N ew Channel

To create a new channel, check the New Channel
Icon in the Channels Palette. A new channel will
be created below the current channels.

To Duplic ate a Channel

To duplicate an existing channel, click the 
channel and drag it to the New Channel Icon. 
A duplicate of the channel will be made below
the current channels.

To Delete a Channel

To delete a channel, drag that channel to the
trash can in the Channels Palette. Primary
channels cannot be deleted. If you accidentally
delete a channel, use Command-Z (Ctrl-Z in
Windows) to undo the deletion.

Channel Options

The Channel Options dialog is accessed by
double-clicking on an individual channel’s name.
This dialog allows you to change the color of a
channel, to alter the opacity, and to choose
whether the color indicates the mask.

To Change the Opacity of a Channel

Every channel has its own opacity. This opacity
number determines how the channel will be
composited onto the overall image. For example,
if the color of a channel is pure red, then at an
opacity of 100% (or 255), a value of pure white
in the channel will translate into pure red on the
image. However, if the channel only has an
opacity of 50% (128), then the color pure white
will translate into pink (red, 128). 

To change the opacity of a channel, double-click
the name of the channel to open the Channels
Options dialog. Enter the opacity of the channel
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from 1% to 100%. 100% represents a totally
opaque channel.

To Change the Color of the Channel

To change the color of a channel, double-click
the channel to use Channel Options. Select a
new color using the Color Picker (menu com-
mand Window > Palettes > Picker), and click
the appropriate color swatch. The color of the
channel will change to the selected color.

You can only change the colors of non-primary
colors. If you are working in RGB, you cannot
change the colors of red, green, and blue.
Likewise, if you are working in CMYK, you can-
not change the colors of cyan, magenta, yellow,
and black.

To Use the Color Indic ates Mask

The “Color Indicates Mask” preference is used if
alpha channels are a color other than white and
the alpha channels are viewed in combination
with other channels. 

If the Color Indicates Mask preference is
checked, the color indicates the mask of the
channel. If Color Indicates Mask is unchecked,
the color indicates the selection in the channel.

Alpha Channels
Channels that are not primary channels are
called alpha channels. Alpha channels are used:

• To store selections.

• To create dropshadow and 3-D effects.

• To create textured effects.

• For intermediate channel operations.

• For mask channels.

Alpha channels are displayed in Grayscale. Alpha
channels are initially displayed in white in RGB
Mode and black in CMYK Mode. Storing a
selection in a channel changes the Grayscale
information for that channel. 

Painting and Filling Alpha Channels

You can apply several operations directly to
alpha channels. One frequently used operation 
is painting directly in the alpha channel. For
example, by airbrushing around sharp edges in
an alpha channel you could produce a softer
selection. Alternately, you could apply
Calligraphy directly to an alpha channel, and
load it as a selection at a later time.

Storing and Loading Selections

One use for channels is to store different 
selections. By storing and loading selections, 
one file can contain several different selections
that are stored in different channels. Here are
some situations that would involve storing and 
loading selections:
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• You mask out different parts of an image 
and save these masks as Grayscale channels
so that you can go back and use the masks
later.

• You outline an object with the Pen Tool, 
and then save that outline as a selection.

• You achieve complex calculation command
effects (see below) that require you to load
selections in and out of channels.

Storing selections in channels gives you a way to
view those selections. For example, after storing
a selection to a channel and viewing it, you
might decide that the edges of the selection are
too crisp, and so you use a Gaussian Blur filter
on the alpha channel to soften it. When you
view a channel, the areas inside the selection are
indicated in white. Areas outside of the selection
are indicated in black. Areas that are partway in
or out of the selection are indicated in shades of
gray.

To Store Selections

To save a selection to a channel, use the menu
command Select > Store. This command leads to
a submenu which allows you to save the current
selection as a new channel or to one of the exist-
ing channels. 

To Load Selections

Any channel can be loaded as a selection with
the menu command Select > Load. You can 
also load the selection within the channel by

dragging that channel to the Load Selection 
Icon located at the top of the Channels 
Window and releasing it.

When you load a selection, the current selection
is replaced. If you hold down the Shift key while
doing the load, the new channel will be added 
to the current selection. If you hold down the
Command (Ctrl in Windows) key while doing
the load, the new channel will be subtracted
from the current selection.
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8 Chapter Eigh t
Filters

Overvie w

This chapter describes practical filters used in traditional image-editing

and filters used to achieve special effects such as Blur, Sharpen, Noise,
Distort, and Stylize. All these filters are found under the Effects menu. 

Filters that are used specifically for color correction are described in

Chapter Ten: Color Correction.

This chapter also describes how to use third-party plug-in filters in

xRes S.E.. Topics include:

• Essential terms

• Blurring an Image

• Sharpening an Image

• Adding Noise to an Image

• Distortion Effects

• Stylize Filters

• Plug-in Filters



Essential Terms

Filter

A filter is an effect applied to the image by a
menu command that effects the pixel data in the
image. After an image has been scanned in and
color-corrected, the real fun beings—applying 
filters. Gaussian Blur, Add Noise, and Unsharp
Masking are essential to photo-retouching.
Other filters are useful for special effects, such as
Ripple and Solarize.

xRes S.E. contains practical filters as well as fil-
ters that are simply fun to use. Third-party plug-
in filters, such as Kai’s Power tools, can be used
in xRes S.E.. With all these filter possibilities,
xRes S.E. can alter the image in almost any way
imaginable.

All of the filters in xRes S.E. can be applied to 
documents in RGB or Grayscale Mode. Filters
only apply to active objects in the document. If
there are selections inside of the objects, the filter
applies only to areas inside of the selection. Note
that filters only apply to editable channels.

Filter P reviews

All filters with dialogs are previewed in one of
two ways:

• The entire image is previewed as you drag
the slider in the filter dialog. 

The advantage of this method is that you can

preview the entire image at one time. The disad-
vantage of this method is that it can be slower
than the second method, using a preview box.

• A box in the center of the image provides a
preview of the filter.

By dragging the preview box around the image,
you can see how the filter will affect that area of
the image. This method of previewing is faster
than previewing the entire screen.

Set the pre f e r red pre v i ew method in the Ge n e r a l
Pre f e rences (accessed by the menu command File >
Pre f e rences > General) by checking or unchecking
“ Use Pre v i ew.” If this pre f e rence is checked, then
x Res S.E. pre v i ews filter effects with a mova b l e
p re v i ew box. If this pre f e rence is unchecked, then
x Res S.E. pre v i ews the entire image at once.
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Blurring an Image
One of the things that photo-retouching 
programs do best is to soften an image. xRes S.E.
provides four filters for softening images:

• Gaussian Blur: This is a smooth blur within
a defined radius of 1 to 128 pixels.

• Basic Blur: This is a straight-forward 3 x 3
pixel averaging of pixels.

• Motion Blur: This is a kind of blur that you
get when photographing moving objects.

Gaussian Blur Command

Of these four blurs, the Gaussian Blur is the most
i m p o rtant. The Basic Blur is provided for ve ry
slight blurs, and generally produces insufficient blur
for a large image. The other blurs are used as special
effects and so are used less fre q u e n t l y.

When you use Effects > Blur > Gaussian Blur,
you are prompted to enter a radius in pixels. You
can enter any integer from 0 to 31. 

If the blurring effect is still not sufficient, you
can run the filter several times to achieve the
desired effect.

Some areas where Gaussian Blur might be useful:

• Softening Selection Outlines: Apply Gaussian
Blur to a channel that holds a selection to
soften that selection outline. This is equiva-

lent to loading that selection and using the
menu command Select > Feather.

• Softening Photographs: Use Gaussian Blur 
at a low setting on photographs to soften 
the image.

Motion Blur Command

The Effects > Blur > Motion Blur command 
creates a type of blur that would occur if you
were taking a picture of a moving object with a
slow shutter speed. 

There are three parameters to the Motion 
Blur command: 

• Angle: The angle can be set from 
-180 to 180.

• Number of Copies: This is the number of
copies that xRes S.E. makes of the image to
create the blur effect.

• Distance: This is the distance, in pixels,
between the separate copies of the image.

xRes S.E. will overlay the number of copies using
the specified distance to create the impression of
a moving object.

Simple Blur Filter

With the Simple Blur Filter, the computer
replaces every pixel with the average of the
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neighboring pixel values. This averaging of pixels
is a special type of convolution filter.

To achieve this averaging effect, apply the menu
command Effects > Blur > Simple. A slider with
a value from 1 to 10 allows you to set the 
intensity of the blur.

Examples:

• 10 corresponds to a straight 3 x 3 
pixel average.

• 1 gives an almost imperceptible blur with
more weight given to the center pixel.

The main use of the Blur Filter is to achieve
extremely slight blurs. There are times when the
minimum radius of 1 on the Gaussian Blur 
produces too strong an effect. In such cases, 
the Basic Blur filter (with a strength of around 5)
is the right tool for the job.

Sharpening an Image
Sharpening often refers to improving image 
contrast. While this is partially true, one should
distinguish between increasing the contrast in the
colors of an image (as done with the Br i g h t n e s s /
Contrast command) and increasing the spatial
contrast between neighboring pixels (which is
what the Sharpen commands actually do).

Generally speaking, it is easier to blur an image
than to sharpen it. If an image is completely out
of focus no amount of computer-generated sharp-
ening will make that image come into focus.

xRes S.E. offers two types of sharpening com-
mands: Sharpen and Unsharp Masking. In most
cases, the Unsharp Masking effect is the most
useful.  

Sharpen Command

The Effects > Sharpen > Basic command applies
a straight 3 x 3 sharpening convolution to each
editable object in the image. The effect of this
filter is to accentuate lines and edges in the
image, but because it operates on a very small (3
pixel wide) radius, it can also highlight unwant-
ed noise. 

You can tone down the effect of the Sharpen 
filter by moving the amount slider from its
default value of 10 to a lower value.

Unsharp Masking Command

The term “Unsharp Masking” refers to a photo-
graphic process of blurring a negative, collating it
with the original positive and then exposing the
combined pieces of film. This technique allows
photographers to increase the overall sharpness
of an image in post-processing. 

With the Effects > Sharpen > Unsharp mask
command, xRes S.E. performs the same process 
digitally. After a copy of the original image is
made, that image is inverted, blurred, and then
added back to another copy of the original
image. Since you are subtracting a blurred image
from the original, the result retains only the
accentuating features of the original image. This
result is thresholded and added back to the origi-
nal image to increase the overall sharpness.
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Like the Sharpen > Luminosity command, the
Unsharp Mask command works on the luminos-
ity channel. The difference is that with Unsharp
Mask, you can specify a blur radius and use the
Gaussian Blur filter to do the blur, as opposed to
the Luminosity command’s simple 3 x 3 pixel
convolution. 

You also can specify a threshold level under
which no enhancement is made. This is useful
for screening out noise artifacts. Macromedia
recommends that you primarily use the Unsharp
Mask filter instead of the Sharpen filter.

Experiment with the different settings, and try
using the filter more than once. It’s often better to
apply a filter with moderate settings three or four
times than applying a filter with a high radius and
a high amount. Both the Sharpen filter and
Unsharp Mask filter can cause stray bits of noise
to creep into your picture. To minimize the noise,
it is best to run these filters last.

Adding Noise to an Image
There are commands used to add noise to an
image: Add Noise and HLS Noise. Add Noise
adds noise to all channels, while HLS Noise adds
noise only to user-specified channels in the HLS
color space.

Note: You can also add noise to an image using
the Noise brush. See Chapter Four: Painting,
Erasing, and Cloning and Chapter Ten: Color
Correction for more information on using noise.

The Effects > Noise > Add command adds a 
specific amount of random noise to each editable

channel. You can specify the amount of noise to
a number from 0 to 100. 

Use the Noise Filter:

• To distress type, creating a worn, 
weathered look.

• To add realism to gradients that are too
smooth and to images that were originally 
created as line art.

• As a first step in creating a texture or 
a background.

HLS Noise Command

The menu command Effects > Noise > Add HLS
is a variant of the simple Add Noise Filter com-
mand in which the image is temporarily convert-
ed to HLS Color Mode. Noise is added in each
of the Hue, Lightness and Saturation channels,
and the image is re-converted back to its original
mode. If you are working on a CMYK image,
the black plate is not affected.

The advantage of using HLS Noise is that you
can control the amount of color added to the
image. For example, if you set the hue slider to
zero and raise only the lightness slider, there will
be no unwanted color added into the image. 

Some other programs on the market have a
“Protected Noise” filter. When xRes S.E. acts
only in the luminosity channel (as described in
the above example), it is effectively reproducing
this filter.
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Distortion Effects
Five filters (described below) are used to distort
the image and are useful for creating special
effects. Distortion filters can introduce a black
value to the edge of the image; this effect is
intentional.

Ripple

The Effects > Distort > Ripple filter is a variant
of the Wave filter. It produces a ripple in both
the horizontal and vertical dimensions simulta-
neously, creating a warped effect. 

The ripple is controlled by amplitude and wave-
length parameters in the Ripple dialog which are
best learned by experimentation.

Cylinder

The Effects > Distort > Cylinder filter creates 
a warped cylindrical effect. Enter the level of 
distortion as a number from 1 to 100.

Whirlp ool

The Effects > Distort > Whirlpool filter creates a
whirlpool effect by displacing the colors of the
image. The angle is entered as a number from 
-1000 to 1000.

For a neat effect, create a new document. Use
the Whirlpool filter to create a black whirlpool
around the edges. The degree of the angle 
determines the strength of the effect.

FishEye

The Effects > Distort > FishEye filter creates a
bulge in the center of the image. The level of dis-
tortion is entered as a number from -100 to 100.

Stylize Filters
The Stylize filters are great for creating 
special effects.

Emboss

The Effects > Stylize > Emboss command can be
used to create a raised, embossed look. The filter
has three parameters, the Angle of the embossing
(from -180 to +180), the Emboss Depth (from 1
to 5 pixels), and the Contrast Factor. Best results
are generally obtained with an Angle of 45 and
an Emboss Depth of 1. The Contrast slider can
be used to adjust the depth of embossing.

The Emboss filter will emboss the image onto a
gray background. If you wish to choose a differ-
ent color, you should apply the Effects > Stylize
> Colorize command afterwards to re-map the
image to a Indexed 256 Palette (stored as a gradi-
ent in the Gradient Tool Options). 

Find Edge 

The Find Edges filter is a 3 x 3 pixel convolu-
tion, which corresponds to the Find Edge and
Invert commands used in other programs. The
Find Edges filter has no dialog. 
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Diffuse

The Effects > St y l i ze > Diffuse filter diffuses the
location of each pixel randomly, without affecting
the pixe l’s color. The result is similar to looking
t h rough a thick glass plate.

By adjusting the slider, you can affect the level of
diffusion that occurs. 

Maximum and Minimum Filters

The Effects > Stylize > Maximum filter takes the
maximum value for each channel in a specified
pixel radius. This creates a somewhat posterized
effect, as neighboring pixels are reduced to a 
single value. It also has the effect of lightening
RGB images and darkening CMYK images.
Conversely, Effects > Stylize > Minimum darkens
RGB images and lightens CMYK images.

To Produce Borders

Minimum and Maximum filters also have uses
when working with channel operations on
Grayscale images. For example, if you have a
solid white shape on a black background, and
you wish to increase its size by two pixels, you
can apply the Effects > Maximum command
with a radius of 2. By subtracting that image
from the original shape, you are left with a 
2-pixel wide border.

Increasing or Decreasing 

a Selection by 1 Pixel

Often after making a selection with the marquee
tools, one pixel needs to be added or subtracted

to fine tune the selection. This can be accom-
plished by saving the selection to a channel and
then either applying the Minimum filter to
decrease the selection or applying the Maximum
filter to increase the selection. 

Median Filter

The Effects > Stylize > Median filter takes the
median of all pixels in a specific area. Two uses
of this filter are:

• Softening Images: By taking the median of
all pixels in a specific area, the filter acts as an
averaging or blurring filter, so it can be used
to soften images. 

• Removing Unwanted Noise: By specifying a
threshold value, you can use the filter to
remove unwanted noise from an image.
xRes S.E. will compare each pixel with the
median value and only replace the pixel if the
difference is greater than the threshold. The
lower the threshold, the more powerful the
filter as a noise detector, but the more likely
the image will appear blurred as a result.

Mosaic

On tabloid news shows, some interviewees
have “pixilated” faces to protect their identity.
This same pixilated effect can be achieved with
xRes S.E. using the Mosaic filter.

The filter is under Effects > Stylize > Mosaic. It
creates a pixilated “police suspect” look by aver-
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aging all pixel values within small rectangles. The
height and width of these rectangles can be set in
the Mosaic dialog.

Threshold

The Threshold filter “squashes” the picture into
black and white values. The way this filter works
is by computing a brightness value for every
pixel in the image from 0 to 255 and then com-
paring these numbers to a specified pixel value.
If a pixel’s brightness value is lower than the
specified pixel value, it turns black; if it is higher,
it turns white. The specified pixel value is
entered by a slider bar in the Threshold dialog.

Threshold works best when you turn the same
number of pixels black as pixels you turn white.
In order to enter an appropriate threshold value,
we suggest examining a histogram of the image
by the Levels dialog before applying the filter.

Tint

The Effects > Stylize > Tint Filter creates a
monochromatic tinted image from the original
image by separating the image into chroma
(color) and luminance channels, replacing the
chroma channels only. The chroma is computed
from the R, G, B sliders in RGB Mode (or C,
M, Y sliders in CMYK Mode).

Solarize Filter

The Effects > Stylize > Solarize filter applies 
a solarization effect to the image, which is 
equivalent to a V-shaped curve. You can achieve

the exact same effect with the Curves dialog; 
the filter is a shortcut. 

Macromedia strongly recommends playing with
this filter if you have not tried it before. You can
achieve some very interesting results!

Plug-In Filters
xRes S.E. supports third-party Adobe
Photoshop-compatible plug-in filters such as
Kai’s Power Tools and Gallery Effects. You
should store all plug-ins that you wish to use 
in xRes S.E. in the same folder or directory
as xRes S.E.

To use Plug-In Filters

1 Install the third-party plug-in filters, follow-
ing the directions that shipped with the
third-party application. 

2 Use the menu command File > Preferences >
Set PlugIn Folder. A dialog appears, allowing
you to specify the location of the folder that
contains the plug-in filters. Click Select at
the bottom of the dialog.

3 Access General Preferences with the menu
command File > Preferences > General.
Check the “Support PlugIns” preference and
click OK.

This preference sets aside one third of the avail-
able memory for using plug-ins. If this prefer-
ence is not checked, then memory is not set
aside for using plug-ins. 

4 Quit and relaunch xRes S.E.. The plug-ins
will appear on the main menu.

Chapter Eight128



If you change the location of your plug-in folder,
you should reset the location of the plug-in 
folder as per step 2, and then relaunch xRes S.E..

If you are not using plug-ins, uncheck the
“Supports Plug-Ins” preference in General
Preferences.
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9 Chapter Nine
Working in xRes M ode

Overvie w

This chapter defines xRes Mode and offers strategies for
maximizing performance in xRes Mode. Topics include:

• Essential Terms

• Is xRes Mode a Proxy System?

• Working in xRes Mode

• Using the LRG File Format

• Importing an Image to an xRes Mode Document

• Maximizing Performance in xRes Mode



Essential Terms

Direct M ode

Direct Mode is the default work mode for
xRes S.E.. All features are available in Direct
Mode, however, Direct More lacks the speed of
xRes Mode.

xRes M ode

xRes Mode is designed exclusively for the quick
manipulation of high-resolution files greater than
10 to 20 MB in size, or files with 10 or more
objects. 

In general, operations that would take minutes to
apply in Di rect Mode take only a few seconds to
apply in xRes Mode. For example, applying a fil-
ter to a 500 MB file in xRes Mode takes a few
seconds; applying the same filter to a 500 MB file
in Di rect Mode could take several minutes.

In xRes Mode, the speed of the operation is not
dependent on the size of the file. You may work
with large files with as little as 16 MB of RAM.
For example, xRes Mode operations performed
on a 500 MB file occur at the same speed as
operations on a 20 MB file.

In xRes Mode, selective processing is used to
achieve the rapid speed of operations. xRes S.E.
does only the work necessary (1) at the current
zoom level and (2) to the area of the image visi-
ble on screen.

Delayed processing delays image editing 
until the image is rendered.

For example, suppose you are working on an
image that is 5000 x 5000 pixels and you apply a
Gaussian Blur filter. In Direct Mode, the filter is
applied immediately to all pixels in the 25 
million pixel image. In order for the processor to
manipulate 25 million pixels, it needs about 200
MB of RAM. Even with sufficient RAM, the
operation could take minutes to apply.

In xRes Mode, the filter is only applied to the
pixels currently visible on screen at the current
zoom level. 

Suppose you are viewing the image at the 1:8
zoom level and you can see an area that is 500 x
500 pixels. The Gaussian Blur filter would be
applied only to 500 x 500 pixels, or 250,000 pix-
els total. Although this may still seem like a lot of
p i xels, it is 1/100th of the full 25 million pixe l s
in the image. Even with a small amount of RAM
this filter can be applied in just a few seconds.

Panning or zooming the image in xRes Mode
applies the blur to parts of the image which have
not yet been displayed.

When you export the image to a file format such
as TIFF, xRes S.E. performs the processing it has
delayed, thereby building the final file; this
process is called rendering the file.
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LRG

The LRG document format was designed by
Fauve Software (now part of Macromedia) to
specifically address the issue of saving a large
document (10 to 20 MB or larger). An LRG
document is stored in a series of tiles, making it
easy to rapidly access the image data. LRG
documents are automatically opened in xRes
Mode by xRes S.E.. For more information on
the LRG file forms, see “Using the LRG File
Format” in this chapter.

LRG documents can be saved as RGB 
(with 29 channels), CMYK (with 28 channels),
or Grayscale (with 32 channels). 

You might want to export a document to the
LRG format if you plan on opening it later in
xRes mode. When you export the document to
an LRG format all objects will be merged.

MMI

This MMI file format is used to save documents
while keeping multiple objects independent. An
MMI file describes a document by keeping a
command set for all objects in the document.
Generally, you will not want to export the MMI
file to another file format until you have finished
editing the image. 

If you save to any format other than MMI, all
objects will be merged into the background. 

To change a document from MMI format 
to another format, you must export it to the
appropriate format; you cannot use the Save As
command. See “Exporting Images” in this 
chapter for more information.

In xRes Mode, the MMI file serves as a 
pointer to all objects in the document. See
“MMI File Format” in this chapter for 
more information.

Is xRes M ode a P rox y System?
Proxy systems are commonly used in image-edit-
ing to deal with large files. In a proxy system, a
72 dpi file is used to represent the larger, high-
resolution file. 

The disadvantage of a proxy system is that you
may not zoom in and examine effects at the pixel
level. For example, you may not examine the
effect of a Sharpen filter at the pixel level, so you
must guess the result of the effect. 

In addition, it is very difficult to do masking
work because the 72 dpi file used to represent
the file lacks the detail of the actual file. Most
proxy systems only allow you to composite and
apply a few filters, and they lack the advanced
painting and masking abilities of xRes S.E..

xRes Mode is not a proxy system; in fact, it
resolves the difficulties typically associated with
proxy systems.

In xRes S.E., you can zoom in to the actual pixel
data and see the result of any effect. You may
also edit, paint, and mask at the pixel level. 
xRes Mode is a comprehensive work mode
which includes the following functions: 

• Batch Conversion

• Cloning 
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• Cropping 

• Erasing 

• Fill Effects (including Gradients)

• Filters

• Grouping 

• Masking 

• Moving 

• Multiple Undo Levels 

• Painting

• Resizing and Rotating Objects 

• Text Editing

• Working with Channels and Alpha Channels 

• Working with Paths 

• Panning and Zooming

• Untransform Command

In addition, when you perform operations in
xRes S.E., those operations are performed to
the actual pixel data, unlike a proxy system,
in which the operations are performed only
to a 72 dpi model of the image.

Working in xRes M ode
As previously discussed, xRes S.E. supports 
two work modes: Direct Mode and xRes Mode.
The work mode is document-specific; that is,
each document is either in Direct Mode or 
xRes Mode.

The top of the image window indicates the
active mode. If you are in xRes Mode, the word
“xRes” appears in the title bar of the image win-
dow. If you are in Direct Mode, the word “xRes”
does not appear.

To Create a New Image in xRes M ode

To create a new image in xRes Mode, use the
menu command File > New and choose xRes in
the Work Mode menu.

To Open an Existing D ocument

in xRes M ode

To open an existing document in xRes Mode,
use the menu command File > Open As LRG.

To Use the U ntransform Command 

in xRes M ode

The menu command Modify > Untransform is
an additional feature of xRes Mode. The
Untransform command restores the topmost
active object to its original size and shape while
maintaining the other operations performed on
the object.
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Features Not A vailable in xRes M ode

About 5% of the features available in Di rect Mo d e
a re not available in xRes Mode. These include:

• Magic Wand Tool

• Bucket Tool

• Drop Object and Drop Selection commands

• Indexed 256 Color Mode

Features That Work Differentl y
in xRes M ode

Certain features work differently in xRes Mode:

• Stamp Tool

• Shape Inspector

• Undo levels

• MMI and LRG files

• Render Command

In xRes Mode, the Stamp Tool clones from one
p a rt of an object to another part of the same
object, but cannot clone from one object to
another object, because post-processing is used.
See Chapter Four: Painting, Erasing, and Cloning
for more information on the Stamp To o l .

The Shape Inspector allows larger brush sizes in
x Res Mode. See “Brush Si ze s” later in this chapter.

More undo levels are available in xRes Mode.
Object transformation commands do not 
terminate the undo list. See “Local vs. Global
Operations” in Chapter One: xRes S.E. Basics
for more information.

MMI files serve as pointers to associated LRG
files, which are objects in the image. MMI files
save command sets, while LRG files save image
data. See Chapter Two: Opening, Saving, and
Importing Images for more information.

The LRG file format is available in xRes Mode
to handle larger, high-resolution files.

A Render command is available to render files on
screen. Additionally, files render automatically
when they are exported to any file format except
MMI. See “To Use the Untransform Command
in xRes Mode” in this chapter.

Brush Sizes

When brushing, painting, and cloning in 
xRes Mode, the maximum size of the brush
depends on the zoom level of the document.

The maximum size of the brush represents the
second number in the zoom level times 100. 
For example, working at the 1:16 zoom level in
xRes Mode, the maximum brush size equals
1600 pixels. 

This allows you to use extremely large brushes
when working with large images. The size incre-
ments in the Shape Inspector represent the 
integers 1 through 100 times the second number
in the zoom level. 
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For example, working at the 1:16 zoom level in
xRes Mode, the first brush size available is 16
pixels, the next is 32 pixels, the next is 48, and
so on, up to 1600 pixels.

In addition, preset brush sizes are saved in screen
pixels. The total amount of screen pixels is
equivalent to the actual pixels divided by the sec-
ond number of the zoom level. 

For example, a brush that is 160 actual pixels
wide working at the 1:16 zoom level is 10 screen
pixels. Clicking on this brush at a different zoom
level produces a brush size that equals the second
number of the zoom level times the screen pixels
of the brush.

For example, suppose that the first preset brush
equals 1 screen pixel (the default setting).
Clicking on this preset brush while working at
the 1:1 level produces a brush that is 1 x 1 pix-
els. Clicking on this preset brush while working
at the 1:16 zoom level produces a brush that is
16 x 16 pixels.

Cloning

In xRes Mode, you can only clone from one part
of an object to another part of the same object.
You cannot clone to different objects or to differ-
ent documents.

Rendering

Rendering, also called post-processing, is the
process of performing all operations at the 1:1
zoom level. 

Rendering is usually performed at the end of the
work routine, but it can be performed at any
time. The rendering time varies based on the
type of machine, the size of file, the number of
objects in the file, and the number of operations
performed on the document. Typical rendering
times for a PowerMac or Pentium range from
five to twenty minutes.

Saving or exporting a file in any file format
except MMI automatically renders that file. 

Using the S ave As Command in xRes M ode

You may use the Save As command to save to
the MMI file format if the document has many
objects or to any available file format if there is
only object. 

If you are in xRes Mode and save an image in a
format other than MMI, you will actually be
rendering the file when you save it. Rendering
builds the file for final output by merging 
all objects into the background object.

Using the Export Command in xRes M ode

The Export command is the only way to save
multiple-object documents as file formats 
other than MMI.

Exporting produces a separate document in 
the file format. See Chapter Two: Opening,
Saving, and Importing Images for the available
file formats.

Exporting an image in xRes Mode automatically
renders that file. You will be prompted with a
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dialog that allows you to save the file at a lower
zoom level if desired. You may want to save a file
at a lower zoom level to fit it on a floppy disk or
simply to print out a quick proof. Export at 1:1
to render the complete image.

The zoom level choices for exporting images are:

• 1:1

• 1:2

• 1:4

• 1:8

• 1:16

• 1:32

• 1:64

Exporting a file at a lower zoom level does not
affect the resolution of the file. However, it will
change the dimensions of the file in pixels. 

Exporting a file at a zoom level of 1:2 saves a file
that is half the width and half the height of the
original file, or 1/4th the original size. For exam-
ple, exporting a file that is 8000 x 8000 pixels at
the 1:2 zoom level produces a document that is
4000 x 4000 pixels; this exported document is
16,000,000 pixels total, which is 1/4th the size
of the original 64,000,000-pixel document.

Using the Render Commands

To render all of the objects in a document, use
the menu command File > Render. You may
want to use this command to render a document
without saving it as a specific file format.

Oper ation Set

Operations performed to an object are called the
operation set of an object. An operation set can
include applying filters, gradients and fills; paint-
ing; and selecting. 

Rendering deletes the stored operation set of the
object. This allows faster execution of command-
based operations. Some common command-based
operations include cloning, zooming, and panning. 

For instance, if you have performed several oper-
ations and find that zooming in the image is
slower than you would like, you could apply the
File > Render command to make the zooming
substantially faster.

Note: The menu command File > Render cannot be used
as a substitute for the final render of the document, which
i n vo l ves exporting the file format to a different zoom level. 

Using the menu command File > Render 
prevents the initial undo ability of the object.
After applying several operations to objects and
applying the menu command File > Render, the
menu command Edit > Undo has no effect until 
further operations are applied to the objects
within the document.
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Using the Render Objects Command

The Render Objects command is in the Objects
Window submenu. Accessing it will render all
active objects within the document. 

1 Activate all objects you wish to render by
clicking on them in the Objects Window
(Window > Objects).

2 Choose Render Objects from the Objects
Window palette submenu. All active objects
within the document will be rendered. The
objects remain separate image elements that
may be freely moved, resized, rotated, edited,
and saved.

How Do I Switch bet ween 
Direct and xRes M odes?

Use the Modify > Work Mode command to
switch work modes. When switching from
Direct to xRes Mode, a dialog prompts you to
save your objects as LRG files. 

Opening Files in xRes M ode

To open files in xRes Mode, use the menu com-
mand File > Open.

• Images that were saved in the LRG file 
format will open in xRes Mode.

• Images that were saved in any file format
other than LRG or XRS will open in Direct
Mode, with the exception of MMI (below).

• Images that were saved as MMI files open in
the mode in which they were saved.

Using the LRG File Forma t
The LRG file format is used to organize large
tiles of data in a manner that allows them to be
rapidly opened, imported, and edited by your
computer. When working in xRes Mode, all
open or imported images are converted into the
LRG file format.

When a file is converted into the LRG file for-
mat, up to seven different zoom levels of the
document are made at varying resolutions. 
Each level is composed of several tiles of data.
The following diagram illustrates this concept:

For example, imagine a (4000 x 4000 pixel) 
document converted to the LRG file format. The
bottommost level of the LRG file is 4000 
x 4000 pixels, the same size as the original 
document, representing the 1:1 zoom level.
However, it is not an exact copy of the image
because it is arranged in rectangular tiles, as
opposed to line after line of pixel data. 

The second level in the LRG file is 2000 x 2000
pixels, representing the 1:2 zoom level. This level
is 1/4th the size of the original document. 

The third level is 1000 x 1000 pixels, or 1:4; it is
1/16th the size of the original document. There
can be up to seven zoom levels ranging from 1:1
to 1:64. 
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Organizing data in this manner allows selective
processing on the image data. When an opera-
tion is performed, it is performed on only one of
the seven zoom levels. Zooming in or out to a
different zoom level performs the operation on
that zoom level.

To Use the Open As LRG Command

1 Use the menu command File > Open 
As LRG.

2 Choose the file you wish to open as an 
LRG from the menu. Click Open.

3 A new dialog prompts you with the line
“Save LRG As...” Type in a new name for 
the file, and specify a location for the file 
on disk.

4 Click Save. The file is saved in the LRG
format. The file opens as an LRG file in 
xRes Mode. The first time you use the Open
As LRG command, the file may take a few
minutes to convert to the LRG file format,
particularly if the file is over 30 MB. This is
because the original file is being opened and
converted into the LRG file format simulta-
neously. However, opening the 
same LRG file at a later time will take only 
a few seconds.

Note: After converting the file to the LRG file format you
can delete the original file. 

Converting Images
This section explains how to convert
images from one work mode to another.

To Convert an Image 

from Direct M ode to xRes M ode:

1 Open the file you wish to convert with 
the File > Open command.

2 Use the menu command Modify > Work
Mode and choose xRes.

3 A dialog prompts you to resave each object as
an LRG file. Resaving the objects as LRG
files guarantees rapid performance in xRes
Mode.

To Convert an xRes Image to Direct M ode

1 Open the file you wish to convert with the
menu command File > Open.

2 Use the menu command Modify > Work
Mode and choose Direct.

You may also convert a file to the LRG format as
you open it, which will make the file open in
xRes Mode. See “To Use the Open As LRG
Command” in this chapter to learn about open-
ing files directly into the LRG format.

Importing an Image to a Direc t
Mode or xRes M ode D ocumen t
When you are importing an object into a docu-
ment, the mode of the object changes to reflect
the mode of the document. 

If you are working in xRes Mode and import an
image that is not already in the LRG file format,
a dialog prompts you to resave the image as an
LRG file. After resaving the file, you can import
it into a document in xRes Mode; furthermore,
you can delete the original file.
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MMI File Forma t
The MMI (Macromedia Image) file format is
used in xRes S.E. to save all works in progress
that consist of multiple objects, whether in
Direct Mode or xRes Mode. 

In xRes Mode, if an MMI file consists of multi-
ple objects, the MMI file will point to these
objects, which are represented as LRG files.
When you open an MMI file, the file points to
all associated LRG objects in the document and
plays back the command set for these objects. 

For example, a simple MMI file in xRes Mode
reads like this: 

Open house.lrg. Filter: Invert.Import tree.lrg. Filter:
Brightness,Contrast

By storing only the commands, MMI files in
xRes Mode typically remain very small.

Note: An MMI file in xRes Mode may point to associat-
ed LRG files, used to build the image when it is opened.
It is important not to delete these LRG files, or else you
will not be able to build the document.

If you have moved or renamed LRG files associ-
ated with an MMI file, xRes S.E. prompts you
to indicate the new location of these files when
opening the MMI file.

Maximizing Per formanc e
in xRes M ode
Understanding the difference between pixel-
based and command-based operations can 
help you work with large files more efficiently 
in xRes Mode. 

Some operations in xRes Mode are pixel-based
and occur at a constant speed, regardless of the
size of the file. The speed of such operations is
dependent upon:

• Your system.  

• The number of screen pixels 
currently displayed.

Pixel-based operations include painting, applying
filters, applying fills, and masking. Pixel-based
operations execute at the same speed whether
they are applied at the beginning or at the end of
the work routine.

Other operations in xRes Mode are command-
based. The speed of such operations is based
upon:

• Your system.  

• The number of screen pixels 
currently displayed.

• The number of operations previously applied
to the displayed pixels.

Command-based operations include transform-
ing objects, zooming, panning, cloning, and 
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rendering. Command-based operations execute
more quickly if they are performed at the begin-
ning of the work routine.

In addition:

• If you resize a new object, it takes only a few
seconds. But if you apply a few filters and
paint strokes and then resize the object, the
resizing takes longer. The exact speed differ-
ence depends on the speed of your system
and the (currently viewable) size of the
object. 

• If you zoom to the 1:1 level of a newly
opened 100 MB file, you will only have to
wait a few seconds for the screen to update.
If you zoom back out, perform masking
work and paint strokes, the zooming and
panning will take longer. For optimal speed
performance, perform operations that involve
accessing the pixel level early in your work
routine. Again, the quality of the image will
not be affected, just the speed at which the
operations are performed.

• If you render a document that has only a few
commands applied to it, it will be rendered
faster than a document that has several com-
mands applied to it. 

• If command-based operations are taking
longer to apply to an object than you would
like, use the Render Object command to
delete the command set of the object.

• If command-based operations are taking
longer than you would like on all objects,
then use the Render command to delete the
command set of all objects within a docu-
ment.
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Chapter Ten 
Color Cor rection

Overvie w

This chapter discusses how to perform color correction in xRes S.E..
Topics include:
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Essential Terms

Color Cor rection

Color correction involves changing the color 
values of pixels. Color correction has several uses
in photo-retouching:

• If an image has too much or too little bright-
ness or contrast, color correction can restore
the correct brightness and contrast values.

• Color correction adds or subtracts saturation.
Saturation refers to the strength of the 
color values. Saturated images appear very
bright; desaturated images appear muted. In
xRes S.E., saturation may be added or 
subtracted to the entire image, or to a 
selected area.

• The color correction command Se l e c t i ve Color
only modifies pixels that fall within a cert a i n
color range. For example, you could make all
of the blue pixels in an image purple. You can
use this command to turn an entire sky, and
only the sky, to a slightly different tint.

History of Color Cor rection

Before computers were used in digital imaging,
photographers placed a filter over the lens of 
the camera to adjust the color of a photograph.
Photographs used a myriad of these filters, rang-
ing from green to blue to red. These filters easily
tinted an image or pulled out unwanted areas of
the color spectrum. Still, the amount and variety

of effects achieved by these manual techniques is
limited compared to modern-day computer-
based image editing.

Thanks to the magic of  computerized image
processing the colors of an image can be manip-
ulated in seconds. A scan of a photograph pro-
vides the raw material for a digital artist. Once
an image is inside the computer its colors are as
malleable as clay.

One of the main uses of color manipulation is to
create unusual, artistic color effects. Take an
image of a landscape for example, and turn the
sky into a burning red. Create a blue rhinoceros,
a dalmatian with pink spots, or a zebra with
orange stripes. It’s all possible in xRes S.E..

Color correction is the mainstay of the photo-
graph retouching industry. Many service bureaus 
spend most of their time performing these 
color corrections, which allows precise control 
of the brightness, contrast, and dynamic range 
of photographs.

Local Color Cor rection
Local color correction refers to correcting color
in one particular area of an image under the
brush. For local color correction, you may use
the Tint brush.

To Use the Tint Brush

1 Select the Brush Tool on the Tools Palette.
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2 Double-click the Brush Tool to access the
Brushes Palette.

3 Select the Tint brush in the Brushes Palette.

4 Select a variant from the variant menu, locat-
ed at the top of the Brushes palette. Variants
for the Tint brush include Basic, Stong, and
Weak.

5 Click the document in the area that you wish
to color correct. A Brush Icon appears. Clicking
and moving the brush applies the effect.

6 To change the strength of the effect, access
Tool Options with the menu command
Window > Inspectors > Tool Options, and
adjust the setting of the strength slider.

7 Continue applying the correction to the doc-
ument and changing the Strength value until
the desired result is achieved.

The Tint Brush

The Tint brush is used to tint an image with the
current foreground color. The advantage of using
the Tint brush over the Tint Filter (menu com-
mand Modify > Color > Tint) is that it allows
you to better control the color used to tint the
image. It also allows you to limit the tint affect
to a particular area of the image. 

The Tint brush is often used to apply subtle
shadow effects by tinting with gray on a low set-
ting. It is also used to draw attention to or away
from elements of an image by tinting those ele-
ments to a certain color.

To use the Tint brush, select the Brush Tool
from the Tools Palette, select the Tint brush in
the Brushes Palette, and then select a variant in
the Variant menu. 

Global Color Cor rection
Global Color Correction commands are filters
that affect the entire document. When you apply
a color correction filter, that filter is applied to
all active objects within the document. If there
are any selections in the objects, the filter applies
only to the areas inside these selections. 

xRes S.E. has several color correction filters used
for color correction. These filters are located
under the Modify > Color submenu, and
include:

• Invert: Creates a negative of the image.

• Levels: Controls the dynamic range of the
image and allows control over brightness and
contrast.

• Brightness/Contrast: Adds brightness con-
trast to an image.

Previewing Color Cor rection

There are two options for previewing color 
correction effects:

• You can preview the entire document at one
time. When you achieve the desired effect,
click OK. This method can take longer than
using the preview box.
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• You can use a preview box to preview just
one section of the image. You can move the
preview box around the image to preview
different areas. The advantage of using a 
preview box is it is generally faster than pre-
viewing the entire image.

To set the preview preference, access General
Preferences, (File> Preferences> General) and
check/uncheck “Use Preview Box.”

Inverting an Image
The menu command Modify > Color > In ve rt
i n ve rts the image by inve rting each color channel.
As a result, if you are inve rting a CMYK image,
you should turn off the editability of the black
channel to avoid getting a result that is too dark.

Levels Command
One of the more common problems with
scanned images is that they lack tonal range. 
The image may be over-exposed, under-exposed,
or simply lack highlights and shadows. In all
three cases, the limited number of grays or colors
produces a flat appearance and makes it difficult
to distinguish details. 

Access the menu command Modify > Color >
Levels to easily correct this problem. This opera-
tion can also boost or lighten the brightness or
contrast in the highlights, mid-tones, or shadows
of the image.

When you access the Levels command via the
menu command Modify > Color > Levels, 

xRes S.E. displays a dialog with a histogram of
the image, as well as two sets of sliders: one for
the input range and one for the output range.
There are other controls on the side of the dia-
log, including black and white eyedroppers, and
an auto button. These features are discussed
below:

Channel Selec tor

The Levels box contains a Channel Se l e c t o r
which allows you to choose which channels of the
image will be affected by an operation. T h e
Channel Selector located at the top of the dialog
lists all the editable channels of the image, includ-
ing alpha channels.

If all primary channels are editable the channel
selector also contains a composite channel.
Changes to the composite channel will affect all
the primary channels in a composite. You can
also alter individual channels instead of the com-
posite channel.

Histogram

A histogram is a chart which graphically depicts
the distribution of gray values in an image. A
high concentration of gray is indicated by a high
bar on the histogram. For example, an RGB his-
togram which is skewed to the left indicates a
dark, under-exposed image. The histogram in
the Levels dialog will automatically update itself
to reflect the currently selected channel.

The advantage of having the histogram for refer-
ence is you can align the input and output slid-
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ers to it. For example, you align the left input
slider with the beginning of the histogram. 

Input Levels

The Input Level sliders consist of two triangles,
which together define an Input Range. By
default, this range is set to the entire range of 0
to 255 for each channel. By restricting this range
to a sub-interval, you are telling xRes S.E. to
ignore anything outside of the range and to
expand the inside of the range accordingly.

Output L evel

Below the Input Level sliders, two other triangles
Cameo Output Lever sliders can be moved to
define an Output Range. This range re-maps the
Input Level sliders to how the channels will
appear in the final image.

Gamma

The Gamma slider controls the mid-tones of the
image. A value greater than 1 will increase the
mid-tone levels. A value of less than 1 will
decrease the mid-tone levels. 

Gamma is typically set between 0.5 and 3.0.
Since it only affects the mid-tones of an image,
you can think of it as a brightness control. In
fact, the Brightness/Contrast command uses the
same type of transformation internally.

Using Eyedroppers to Set Black Point and

White Point

Instead of using the histogram to determine the
black and white points, you can pick two points
from the image with one of the two eyedropper
tools located in the dialog. Click first on the
black eyedropper tool and then click on the
darkest point in the image to set the black point.
Do the same with the white eyedropper to set
the white point. xRes S.E. will use the channel
values for each of these points to determine the
channel input amounts. 

Setting black and white points is not identical to
working channel by channel with the histogram
as a guide. If you are using the black point eye-
dropper and click a dark area, then the R, G, B
(or C, M, Y) values of that point will be applied
to each color channel, regardless of the his-
togram values for each color channel. 

Auto

Clicking on the Auto button selects the black
and white points automatically based on the his-
togram. By default, the black point will be set at
3% of the frequency scale, the white point at
97%. You can change these values by clicking on
the Options buttons. The dialog allows you to
define different clipping points.

Load/Save

The Load and Save buttons can be used to load
and save preset level adjustments to disk.
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To set the black and white points of an image:

An old saying in the photo-retouching world is
that nine tenths of the work is getting the right
black point and white point. This may be an
exaggeration, but it is not completely off the
mark. Making sure that the darkest point on the
image is re-mapped to pure black and that the
lightest point is pure white and not some off-
white can dramatically increase the perceived
quality of an image. Use the eyedroppers on the
levels command for this purpose.

Using Levels In P ractic e

Because the Levels command offers so much
power over controlling the brightness and con-
trast over the highlights, mid-tones, and shadows
of an image, it is one of the most powerful tools
for correcting images that were under- or over-
exposed.

To Lighten or Dar ken an Image While

Reducing Contrast

1 Move the left output slider to the right to
lighten the image while reducing contrast.
Since you will be re-mapping the input range
to a smaller output range, the overall bright-
ness of the image will increase, and the con-
trast will decrease. This is very handy for
washing out a background in order to draw
attention to another element (for example, a
piece of text) in the foreground.

2 Move the right output slider to the left to
darken the image while reducing contrast.

To Lighten or Dar ken an Image While

Increasing Contrast

1 Move the left input slider to the right to
darken an image while increasing contrast.
Since you are re-mapping a new limited
input range to the previous output range, the
contrast of the image increases and the over-
all brightness decreases. Moving the input
slider too far to the left may compromise the
detail in the image because pixels of different
brightness values are compacted into the
same brightness level.

2 Move the right input slider to the left to
lighten an image while increasing contrast.
Since you are re-mapping a new limited
input range to the previous output range, the
contrast of the image and the brightness of
the image increase.

To Decrease or Increase the O verall Contrast

To increase the overall contrast of the entire
image, move the input sliders left and right the
same amount. For example, move the left input
slider right by 5 and the right input slider left by
5 to increase the overall contrast of the image.

To decrease the overall contrast of an image,
move the output sliders left and right the same
amount. For example, move the left input slider
right by 10 and the right input slider left by 10
to decrease the overall contrast of the image.
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To Darken/Lighten the Mid-tones 

of an Image

To make the mid-tones of an image darker, move
the gamma slider to the right. To make the mid-
tones of an image lighter, move the gamma slider
to the left.

To Change the Contribution of any Channel

Because the Levels command can work on any
individual channel, you can significantly change
the image by applying changes to the input or
output slider (or both) for any specific channel.
For example, you could decrease the amount of
red in an RGB image by dragging the rightmost
output slider to the left, for the red channel only

Brightness/Contrast Command

The menu command Modify > Color >
Brightness/Contrast allows you to quickly
change the brightness or contrast of an image. 

The Brightness control affects the overall bright-
ness of the image, that is, the overall lightness or
darkness of the image. The Contrast control
affects the contrast of the image, or the degree of
similarity the brightness values are to each other.
The Brightness/Contrast control affects only the
mid-tones of an image.

Hue/Saturation Command

The Modify > Color > Hue/Saturation com-
mand modifies the image in Hue, Lightness and
Saturation (HLS) space, even if you are working
in RGB Mode or CMYK Mode.

If you keep the saturation and luminosity sliders
fixed at zero (no change) and only move the hue
slider, the entire image will shift by a fixed hue. 

For example, if you decide to shift the hue by a
positive 60°, the red areas of the image will shift
into yellow, the yellow areas into green, the green
areas into cyan, with the magenta areas shifting
back into red. (The hue spectrum is measured on
a circle, proceeding from 1° to 360°.)

Large color shifts do not serve any practical pur-
pose in complex images, other than creating psy-
chedelic effects or out-of-ordinary photographs. 

However, small shifts in hue in either direction
can warm or cool a photograph. In addition, if
you mask out a single element, such as an item
of clothing, then the hue slider can be used to
alter the color of that selection without affecting
the general luminosity levels. 

Also note that all shades of gray, including black
and white, are unaffected by hue shifts.
Therefore, changing the hue of an image will
have little if any effect on the highlights or the
shadows.

If you increase the saturation of an image, the
colors become deeper. If you examine magazine
advertisements today, you will see that intensely
saturated colors are frequently used, even more
so than they were just ten years ago.

There are some cases where muting an image
creates a more pastel look. Lowering the satura-
tion provides exactly that effect.
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Chapter Ele ven
Pre-Production

Overvie w

This chapter discusses key concepts and offers tips regarding 
pre-production and printing. Topics include:
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Essential Terms

Continuous Tone

If you look closely at an original black-and-white
or color photograph, you will see that the image
consists of solid shades of gray or color that
blend smoothly. An original photograph is called
continuous-tone art.

Halftone Screens

To reproduce continuous-tone art and process
colors on a commercial printing press, the image
or color must be broken into a series of dots of
various sizes and colors, called a halftone screen.
In electronic publishing, scanning is the first step
in converting continuous-tone art to halftone
screens. Black dots are used to recreate black-
and-white images and cyan, magenta, 
yellow, and black dots to recreate color images
on the press. When printed, small dots create
light areas and large dots create dark areas.

Properties of Color
Objects appear to be certain colors because of
their ability to reflect, absorb, or transmit light,
which we perceive as color. Our eyes are sensitive
enough to perceive thousands of different colors
in the spectrum of visible light—including many
colors that cannot be displayed on a color moni-
tor or printed on a commercial printing press.

Many environmental factors, such as changes in
lighting or the proximity of colors to each other,

influence our perception of these colors. In gen-
eral, differences in how we perceive colors do not
seriously affect our lives. In commercial printing,
however, differences in color perception often
affect the success of a print job. Understanding
how different factors influence color perception
will help you meet your desired printing results.

Every device used to create a color illustration—
be it a scanner, color monitor, color desktop
printer, or commercial printing press—repro-
duces a different range of color in the visible
spectrum. For example, you can view many more
colors on your monitor than you can print on a
desktop printer or a commercial printing press.

In addition, scanners and color monitors use a
different color model than desktop printers and
commercial presses. As colors move from the
computer screen to the printing press, they are
converted from one color model to another—
that is, you do not print exactly the same colors
that you see on-screen. However, the calibration 
system of xRes S.E. ensures that the color seen
on screen and in print are as close as possible.

Two Color M odels
Different media manipulate light in different
ways. Video technology, such as monitors and
film recorders, use the additive RGB Mode; it
transmits light which we perceive as different
colors. See “Additive Color Model”.

In commercial printing however, translucent
cyan, magenta, and yellow inks are printed on a
page. Printers also use a fourth ink, black, to
deepen shadows, to add depth, and to print true
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black type and black lines. CMYK inks absorb
and reflect light and we perceive the reflected
light as different colors. See “Subtractive Color
Model” below.

Additive Color M odel

You can combine varying intensities of three
wavelengths of light—red, green, and blue
(RGB)—to simulate the range of colors found in
nature. 

Red, green, and blue are called the additive pri-
maries. If you combine 100% of red, green, and
blue, you perceive the color as white. If none of
the additive primaries are present, you perceive
black.

Subtractive Color M odel

If you subtract red, green, or blue from white
light (100% each of red, green, and blue), you
create cyan, magenta, or yellow (CMY). For
example, you perceive an object as cyan if it
absorbs (subtracts) 100% red light and reflects
green and blue. Cyan, magenta, and yellow are
called the subtractive primaries and form the
basis for printed process colors.

Printing
You can print to an RGB-based device or to a
CMYK-based device. The device that you 
choose affects the available printing options. 
The following sections discuss printing to a

CMYK-based output device. See “To Print to 
a Film Recorder” at the end of this chapter for
information on printing to an RGB device.

Before printing your image, you must first 
determine the output type:

• Use a 300 to 800 dpi desktop printer to
print initial black-and-white proofs, color
proofs, illustrations, or to print final copies
which don’t require high-quality results.

• Use an imagesetter to print high-resolution
images (1200 to 3600 dpi) and camera-ready
color separations on either camera-ready
paper or plate-ready film.

• Use a high-resolution dye sublimation 
printer, such as 3M’s Matchprint, to print
high-resolution color proofs. 

• Print to a film recorder to create 35 mm
slides of your illustrations.

Separations

To print continuous-tone color on a commercial
printing press, first separate the page containing
the composite art into its component colors by
printing a film separation for each ink—(cyan,
magenta, yellow, black), and any spot colors
needed to print the colors in your image. Your
printer uses these film separations to create the
printing plates used on the press.

The success of your print job depends in large
p a rt on the quality of your film separations. W h e n
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you select a commercial printer, discuss who is
responsible for checking the separations. You or
the pre p ress service provider must check that:

• The dimensions of the image are correct.

• All fonts print correctly.

• All visible objects in the document 
are printed.

• All the separations printed as specified 
and with the correct marks.

• Halftones (including scanned images)
look consistent and smooth.

• Overlapping process-color separations create
rosette patterns and do not show unaccept-
able moiré patterns. 

Print Options

Before printing in xRes S.E., check that the
Monitor Calibration and Printing Inks
Calibration is correct to ensure that what you 
see on the monitor will be reflected on the 
printed page. 

To Print Directly from xRes M ode

1 Set up your Printer Options with the menu
command File > Page Setup. The options
available depend on the output device speci-
fied for the computer. Read the instruction
manual that ships with the output device for

the exact options for printing. Page Setup
options may include paper size, the number
of images printed per page, image enlarge-
ment or reduction, and page orientation.

2 Use the menu command File > Print or click
the Print Icon on the Toolbar. Choices in the
Advanced Print Options dialog include:

• Centered to Page: Check this preference to
center the image to the page. Otherwise
the image is printed at the top of the page.

• Print Separations: Check this preference to 
print one particular channel. If you click
this checkbox, a drop-down menu allows
you to choose a primary channel to print
(C, M, Y or K). 

• Channel in Color: Check this preference to
print the individual channels in color, oth-
erwise the channels print in Grayscale. In
most cases you will want to print in
Grayscale to better distinguish subtle
brightness changes within a channel.

• Fit to Page: Check this preference to fit the 
image to the printed page. If this checkbox
is unchecked, a drop-down menu allows
you choose the zoom level for printing
your image.

3 Click Print. 

Note: You do not have to render the file before you print
while in xRes Mode; rendering takes place during the
printing process.
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To Print Selec ted Objects

You may not want to print all of the objects in
the document at one time. If you are interested
in printing only one object, or only a few objects
out of several, you can specify which objects to
print.

Access the Objects Window and uncheck the
View box for objects you do not want to print.
Only visible objects print.

To Print at Different Z oom Levels

You can create a proof of a large document for a
printer by printing at a lower zoom level. You
may also want to print a lower zoom level to
speed up the printing process; smaller files print
faster than larger files.

You can print at any of the following zoom 
levels: 1:1, 1:2, 1:4, 1:8, 1:16, 1:32, and 1:64. 
A zoom level of 1:2 prints a document that is
half the height and half the width of the original
file; a zoom level of 1:4 prints a file that is one
fourth the height and one fourth the width of
the original file. 

To print at a lower zoom level uncheck “Fit to
Page” in the Print Options. A Print Level drop-
down menu appears. Choose a zoom level in the
drop-down menu, and click Print.

Note: As an alternative, you can export the file at a
lower zoom level and print this exported file at 1:1.

To Print on Different S tocks

If you are printing on a variety of paper stocks,
you should calibrate your Printing Inks for each
of these stocks and save the ink settings. The
same colors can print differently depending on
the texture and thickness of the paper. Use the
menu command File > Preferences > Printing
Inks to access the Printing Inks dialog. See
Getting Started for more information on Printing
Inks.

When you start a project, you should load the
ink settings which correspond to the output
device you will use for that project.

To Print to Different Output D evices

If you are printing to different output devices,
you should calibrate printing inks for each 
output device. See the documentation included
with the output device for more information.

To Print to a Film Recorder

If you are outputting the image to a film
recorder, you should work in RGB Color Mode.

To guarantee that the color in the film recorder
matches the color in xRes S.E., make sure that
the Monitor Gamma is correctly calibrated. See
Getting Started for information on setting
Monitor Gamma.
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Exporting to EPS
You or your service bureau may decide to print
with another application. You can use xRes S.E.
images that have been exported as EPS files in a
variety of applications. In addition to using EPS
files as design elements in page layout docu-
ments, you can work with EPS files in post-pro-
cessing applications to complete prepress tasks. 

To export an xRes S.E. document to the EPS
format, use the menu command File > Export >
EPS. This EPS file may then be opened in a page 
layout program such as Quark XPress. 
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Appendix 1: Frequently Asked Questions
This appendix answers frequently asked questions regarding the installation and operation of xRes S.E..  

Before Calling Technical Suppor t

Before calling Technical Support, scan this chapter to see if your question has been addressed. Below
are suggestions to try before calling Technical Support: 

• Read the ReadMe file that ships with xRes S.E. for information not included in the documen-
tation set. 

• Quit xRes S.E. and relaunch it.

• Delete the xRes S.E. Preferences file by opening the Resources folder (located in the xRes S.E. 
folder) and dragging “xRes S.E. Preferences” to the trash can. Relaunch xRes S.E..

• Reinstall xRes S.E..

• Macintosh users: Restart the computer with extensions off by holding down the Shift key as 
the system restarts until you see the message “Extensions Off.” Relaunch xRes S.E..

Frequently Asked Questions

Memory

Q: I have two hard drives with several megabytes available on both, but the Info Inspector says only a
few megabytes are available on the swap disk. Why? 

A: You must specify which swap disks you wish xRes S.E. to use. The default setting makes the hard
disk that xRes S.E. is on the only swap disk. Use the menu command File > Preferences > Memory,
and specify a Primary Swap Disk and a Secondary Swap Disk. Relaunch xRes S.E. for the change to
take effect.

Q: I’m getting an error message that says “Insufficient swap disk space to complete operation. An addi-
tional 71 MB is needed.” Why?



A: You do not have enough swap disk space to complete the required operation. You must free up some
swap disk space before continuing. Use one or more of these methods to free up swap disk space:

• Save the file, close the file, and reopen it again.

• Use the menu command File > Preferences > Memory and reduce the number of undo levels. 
Having only one undo level allows the greatest amount of swap disk space to be available. You 
must always have one undo level.

• Macintosh Users: Drag unneeded files and folders to the trash and empty the trash.

Painting and Erasing

Q: I’m painting and nothing is showing up on the image. Why?

A: Examine the Objects Window to make sure that the object you are trying to paint on is active (gray).
If it is not, click on it to make it active.

When you use the Brush, Eraser, or Clone Tool, you affect only editable channels within active objects.
Make sure the primary channels are editable. Use the Window > Channel command and click the com-
posite channel to make it editable.

If selections are present within the active objects, the painting is limited to those selections. Selections
may be invisible. To view an invisible selection, access View > Selection. To delete any selections, access
the menu command Select > None.

Also, brushes are only visible if the opacity is set greater than 0. Artistic brushes, which have no opacity
value, are only visible if the concentration value is above 0. Make sure the opacity of the brush is greater
than 0 in the Brush Options Inspector. For artistic brushes, make sure the concentration is greater than
0 in the Brush Options Inspector.

Note that the Shading, Sponge, and Contrast brushes are not designed to affect solid white or solid
black colors.

Q: I have been changing the values in my brush set and now Charcoal and Felt Tip both look like the
Airbrush. Why?

A: If you have been experimenting with values in the Brush Options Inspector, you may have inadver-
tently changed the behavior of the default brushes so that they do not behave as their name indicates.
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Choose “Default Brush Set” from the Brushes submenu.  The original (default) brush set will be
reloaded. 

If “Save Brushes on Exit” is checked in General Preferences, the brush changes will be permanent.
Uncheck this option to keep your brush changes from being saved when you exit xRes S.E.. 

Q: The Brush Tools provide unexpected results. Why?

A:  Painting occurs only in editable channels. You may receive an unexpected result if you are painting
in a mask or painting in an alpha channel.

If the blending mode of an object is not Normal, or the opacity is not set at 100%, painting can pro-
duce unusual results. For example, if the opacity of an object is set to 50%, the paint stroke appears
translucent. Make sure that only primary channels are editable (checked) in the Channels Palette,
accessed by the menu command Window > Palettes > Channels. 

Check the opacity and blending mode of the object by viewing the Objects Window, and change the
opacity and blending mode if necessary.

Q: I’m trying to erase but getting I’m getting a cube-shaped/calligraphy-shaped/multi-tipped eraser.
Why?

A: Erasing is performed with the brush currently selected in the Brushes Palette. If you have selected a
cube-shaped/calligraphy-shaped/multi-tipped brush, the eraser acts like this brush. Choose the Hard or
Soft brush in the Brushes Palette to simulate typical eraser behavior.

Fills and Gradients

Q: I’m using the Bucket Tool and its filling at half opacity. Why?

A: The Bucket Tool fills at the opacity set in the Bucket Tool Options. If the opacity is set to 50% in
the Bucket Tool Options, the fill is only 50% opaque. Access Bucket Tool Options by double-clicking
on the Bucket Tool and reset the opacity to the desired level.

Q: I want to make a line-shaped fill with the Gradient Tool and I’m getting a different shape.

A: The shape of the gradient is set with the Shape Menu in the Gradient Tool Options. Choose “Line”
to produce a line-shaped fill. 
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Q: What is that bar below the Color Ramp in the Gradient Options?

A: This is the Opacity Ramp. It determines the opacity level for the color directly above it on the 
Color Ramp. Opacity levels are set by dropping Grayscale colors into the Opacity Ramp. Entering
white into the transparency ramp is equivalent to an opaque gradient; entering black is equivalent to a
transparent gradient, and shades of gray correspond to shades of opacity. The range of color affected by
each drop into the Opacity Ramp is controlled by the Range Sliders, which appear as two triangles
between the Color Ramp and Opacity Ramp. See “Opacity Ramp” in the xRes S.E. User Guide for
more information.

Selections and Masking

Q: I’m using the Magic Wand and then applying an effect, but it only applies halfway. Why?

A: The Magic Wand Tool Options allow you to set a selection's opacity from 1% to 100%. If the opaci-
ty is set to less than 100%, filters and painting tools will not be applied at their full effect.  To create
selections that produce 100% opaque effects, access the Magic Wand Tool Options by double-clicking
on the Magic Wand Tool and set the opacity to 100%.

Q: I’m trying to mask but I keep getting a cube-shaped/calligraphy-shaped/multi-tipped masking brush.

A: Masking is performed with the brush currently selected in the Brushes Palette. If you have selected a
cube-shaped/calligraphy-shaped/multi-tipped brush, the mask acts like this brush. Choose the Hard or
Soft brush in the Brushes Palette to simulate typical mask behavior.

Performance

Q: I can only apply the Edit > Undo level once, and then the command is grayed out. Why?

A: Set the number of undos in the Memory Preferences (File > Preferences > Memory) greater than 1.
The Undo level can be set up to 20.

Q: I’m applying an operation and nothing is happening. Why isn't the program responding?

A: In xRes S.E., operations occur only on active objects. If an object is inactive the operation does not
affect it. Access the Objects Window (Window > Objects), activate the object you wish to affect, and
increase its opacity if necessary.
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Also, if an object has a low opacity, the effect of the operation may not be visible. Increase the opacity
of the object via the Objects Window if necessary.

If selections exist within an object, the operation occurs only to the area inside of the selection. To
delete a selection, access Select > None.

Most operations only affect editable channels. You can produce unusual results by applying an opera-
tion to an object in which only the alpha channels are editable. Access the Channels Window (Window
> Channels) and click the composite channel to make it editable.

Objects

Q: I’m trying to create a dropshadow by applying a blur filter to a text object, but nothing is happen-
ing. Why?

A: A mask channel is used in text objects to limit the visible area of the object. To blur the edges of the
text, you must blur the mask channel of the text object.

Access the Channels Window (Window > Channels) and click the mask channel to make it editable.
Next, click the view box for the composite channel to make all channels visible (to see the result of the
blur filter). Apply the Blur filter.

Q: I’m applying the Edit > Cut command and the document turns black. Why?

A: The Edit > Cut command applies to whole objects. By applying the Edit > Cut command, you are
cutting the object from the screen onto the clipboard. If you are using the Cut command in the RGB
color space and only one object is present, the Cut command leaves an uneditable (black) area on
screen. 

If you want to cut only part of an object to the clipboard, create a selection encompassing that area,
float the selection, and apply the Edit > Cut command to the floating selection.

If you want to delete an area inside a selection, use the Edit > Clear command instead of the Edit > Cut
command. The Edit > Clear command will fill the selected area with the background color.
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Printing

Q: Why is my document taking so long to print?

A: The higher the dpi setting, the longer it takes to print. Check the dpi of your printer, consider the
dpi needed for the particular project, and make sure that the dpi is not set unnecessarily high.

If you are printing from xRes Mode and have not yet rendered the file, the file is rendered as it is print-
ed. Printing an unrendered file can take longer than printing a rendered file, particularly on desktop
printers where the image size is 1 MB or greater.

Plug-Ins

Q: Why don’t my Plug-In filters show up in the xRes S.E. menus?

A: To use Plug-Ins, you must tell xRes S.E. where to locate the Plug-Ins. Access the menu command
File > Preferences > Set Plug-In Folder, and select a Plug-In folder.

Q: I’m applying the Plug-In filter and nothing is happening (or) I’m getting an error message. Why?

A: To use Plug-In filters in xRes S.E., you must allocate some of the available memory to Plug-In usage.

To allocate memory to Plug-In usage, access the menu command File > Preferences > General, and
check the “Use Plug-Ins” checkbox. Relaunch xRes S.E. for this preference to take effect.

Additionally, some Plug-Ins written by third-party developers were not written to take advantage of the
xRes S.E. technology. These Plug-Ins require a great deal of memory when applied to large images and
may require more RAM than is available on the machine.

If you receive an error message stating there is not enough memory to run the Plug-In, make sure that
you are not running any applications except xRes S.E.; this should free up RAM. Also, increase the
amount of RAM available to xRes S.E. by allocating more RAM to the application or purchasing more
RAM. 
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Filters

Q: I’m trying to preview the entire image before applying a filter, but the preview window shows only a
small portion of the image.

A: Access the menu command File > Preferences > General, and uncheck “Use Preview Box.”

Q: Filters in xRes Mode appear slightly different on screen than when printed.

A: The image appearance can vary with zoom level. For example, if you are viewing your image at the
1:8 zoom level, one on-screen pixel represents 64 actual pixels. Because the screen pixel represents the
average value of these 64 pixels, the on-screen image may be slightly different than the printed image,
which (if printing is set to the 1:1 zoom level) displays the true pixel values of the image.

To see an accurate version of your image before printing it, zoom in to 1:1 (View > Zoom In> 1:1). 
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Appendix 2: Advanced Tips and Tricks
These tips and tricks assume you know how to access all the xRes S.E. windows, and you are familiar
with xRes S.E. fundamentals. 

Tip 1: Creating B rushes

Creating Oil B rushes

The Tips and TipSpacing controls the number of “bristles” in the brush, and the space between these
bristles. Move the Tips Slider to the right to thicken the brush. The TipSpacing should depend on the
number of Tips; in general, TipSpacing should increase with the number of Tips.

Use the Random Sensitivity dialog (accessed by the Brush Options Inspector) to give each bristle a
slightly different hue, lightness, or saturation value. Move the slider to the right (higher settings produce
more random bristle colors), and click the Hue, Saturation, or Lightness checkboxes to increase the ran-
domness of these values. 

Creating Textured B rushes

Use the Texture Slider to control the amount of paper texture the brush picks up. The Fringe Slider
produces an inverse texture at the edge of the brush. To inverse the texture, check the Inverse checkbox
in the Texture Palette.

Creating Ink Pens

The Bleed and Blackness values are important when creating ink pens. High Bleed and Blackness values
simulate dark liquid ink. If the Blackness value is too high, the ink will always appear dark regardless of
the color. The Bleed value gives the paint its liquid appearance; use a very high Bleed value to simulate
watercolor effects.
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Creating Spr ay Effects

Spray-paint thickens if you spray in one place. This quality can be simulated by adjusting the Flow
Slider. Holding your mouse button down or holding your pen in one place with a high Flow setting is
the equivalent of holding a spray can in the same place—the paint thickens. A Flow value of 50 usually
does the job; a Flow value of 100 usually sprays too much paint in one spot to produce a realistic effect.

Another characteristic of spray-paint is its high scatter value. This quality is simulated by adjusting the
Scatter checkbox in the Random Sensitivity dialog (accessed by the Brush Tool Options submenu). For
spraying paint, set the slider value to about 15; for creating a spray effect with brushes like the
Pointillist or Cubist brush, set the slider value to about 30.

Tip 2: Creating G radients

The Gradient Palette allows you to save custom gradient fills. Once the Gradient Palette is mastered,
the Gradient Tool is incredibly powerful. The trick is in knowing how to manipulate the Gradient
Palette to create the desired effect.

Start by envisioning the fill you want: Will it be in a circular, elliptical, rectangular, or a conical design?
(Other shapes can be used for special effects.) Next, what colors will be in the gradient?

When you create elliptical or rectangular fills, the colors that you enter in the left of the Color Bar rep-
resent colors at the inside of the ellipse or rectangle, and the colors at the right of the Color Bar repre-
sent colors at the outside of the ellipse or rectangle.

When you create cone-shaped fills, ensure that the rightmost and leftmost colors in the Color Bar
match. Click the Eyedropper on the leftmost color, move the range sliders to the rightmost millimeter
of the Color Bar, and drag the sampled color on the Color Bar between the range sliders. When apply-
ing the cone-shaped gradient to the canvas, the colors will blend smoothly into one another for all 360°
of the cone.

Tip 3: Compositing with Multiple Objects

Using multiple floating objects is essential for successful compositing. Use these tips to better organize
the project:

Appendices 173



1 Name all of the objects.

By naming all of the objects, you can easily distinguish them using the Objects Window. To rename an
object, click on the object's name in the Objects Window or double-click on the object in the docu-
ment.

2 Uncheck “Activates Objects” in the Arrow Tool Options.

Normally, clicking on an object activates that object and allows you to move it. But if “Activates
Objects” is unchecked, then clicking in the document only allows you to move objects which are
already active. If the image has many objects (for example, more than 10 objects), it is often easier to
activate objects with the Objects Window than the Arrow Tool. 

3 Make use of the Align command.

The Align command is used to align objects to each other by aligning their top, bottom, left, or right
sides, or centers. Aligning objects can organize the document and increase visual appeal. To align several
objects, activate all the objects you wish to align, use the menu command Modify > Align, and choose
top, bottom, left, right, or center.

4 Make use of the “Lock” checkbox.

If you have decided you do not want to move an object for a while, lock it in place using the Lock
checkbox on the Objects Window. The object cannot be moved even if you click on it with the mouse
and drag.

5 Precisely position the objects.

Make use of the rulers to track the exact location of the objects. Access them using the keyboard short-
cut Command-R (Ctrl-R in Windows) and set the ruler measurement in the General Preferences. To
precisely position an object, double-click the object’s name in the Objects Window, or double-click on
the object in the document. Enter the position of the object in pixels, inches, centimeters, picas, or
points, and click OK.
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Appendix 3: Creating Web Pages

Why Would You Want to be on the World Wide Web?

The World Wide Web (WWW, or simply “Web”) is the leading edge of academic, business, and per-
sonal electronic communication. It is changing the way we work, interact with each other, and entertain
ourselves. At press time for this manual, about 20% of all Americans had access to the Web, 15% or so
used it weekly, and more than 30% of those users have made some purchasing decision based on infor-
mation found on the Web. These numbers are expected to double every 6 months.

If you have products to advertise, hobbies to pursue, or information that you want to retrieve, then
Web access is a great investment to make. Whether it involves putting your resume or portfolio on-line,
selling car parts to the far corners of the earth, or downloading the latest tax forms, there is a place for
you on the Web.

What is the World Wide Web?

The Web is a means of displaying information across the Internet with graphics.  It is a network made
of networks, which are owned and run by governments, educational institutions, private corporations,
and individuals. These diverse networks communicate with each other using Telecommunication
Communication Protocol / Internet Protocol (TCP/IP). A computer attached to these combined net-
works is, in theory, accessible by all other computers on the Internet. 

The bulk of information on the Internet is stored in files that are designed to be downloaded to your
computer for local use. However, documents can be formatted for the Web to be displayed on your
computer directly. These Web documents can also act as interfaces for on-line databases, e-mailing lists,
and newsgroups; Web documents can also be interfaces for downloading software from Web sites.

How to Create Graphics for the Web

Since the information on the Web is designed to be seen as quickly as possible, there are a number of
considerations you need to keep in mind when designing graphics for the Web.

Size
The size of the graphic is important, since the size determines how fast the document will be transmit-
ted to your machine. The size refers to the height, width and resolution of the file, attributes which are
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measured in pixels. The resolution should be 72 ppi. Normally you want the graphic to be as small as it
can be and still be of value to the page you are designing. Examine your Web page to determine the size
of the graphic needed in inches. In xRes S.E. you can keep the image small by working in Indexed 256
Color Mode.

Color Depth
Color depth refers to how many colors are in the image. An image displayed on the Web should have as
few colors as possible, so that the user does not have to wait a long time for the image to appear on the
screen. Rather than 24-bit images, many images for the Web are 8-bits (which allows 256 colors) and
are dithered to give the illusion of more colors. Unlike many image-editing programs, xRes S.E. can use
Indexed 256 Color Mode to create an 8-bit image. 

File Format
Current Web browsers read graphics in the CompuServe GIF and JPEG formats. In the near future,
Web browsers will accept Portable Network Graphics (PNG) files, which allow much more flexibility
than GIF and JPEG. xRes S.E. supports the JPEG, Progressive JPEG, GIF, GIF 89, and PNG formats,
so it is ideal for Web document design.

How to Get Information for Designing Your Own Page on the Web

Once you have a sketch of what you want to do with your page and you have produced the graphics,
you need to build your Web page. For more information access home.netscape.com and use the index
for HTML commands.  In addition, you can browse the computer section of your local bookstore for
more information on designing Web pages.
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xRes S.E . Glossar y

Acquiring Images

The Acquire command is used to open documents scanned with the TWAIN interface. The Acquire
command can use third-party acquire modules (also called import modules).

Alpha Channels

Alpha channels are non-primary channels used to store intermediate channel operations and special
effects. Certain file formats retain alpha channels; others delete the alpha channels.

Blending M ode

The blending mode of an object determines how it will be affected by the objects beneath it. 

BMP

BMP has an advantage over all other file formats: it is the official file format for Microsoft Windows®
images. BMP is an RGB-only format. It supports Indexed 256 color documents, as well as Grayscale
and 24-bit RGB documents, but does not support CMYK documents.

CCW

Abbreviation for Counter Clockwise.

Channel

A channel stores the color information for an image; for instance, the R, G, and B channels store the
red, green, and blue information for an image.

Cloning

Cloning is the process of replicating one part of an image and pasting it to another part of the image. 

Color Cor rection

Color correction involves changing the color values of pixels. 



Color Mode, Gray scale

Grayscale allows you to choose a color that is pure black, pure white, or varying shades of gray from 1%
to 100% black.

Color Mode, HSB

HSB allows you to choose a color with a hue value from 0° to 360° and a saturation and brightness
value from 1% to 100%. The hue value is based on the color wheel, with 0 referring to the red value on
the color wheel. For example, if the hue is set to 250, a blue value is displayed, because blue is 250
degrees clockwise from red on the color wheel. 

Color M ode, HLS

The HLS Color Mode allows you to choose color with a hue value from 0° to 360° on the color wheel
and a saturation and lightness value from 1% to 100%. 

Color M ode, RGB

The RGB Color Mode allows you to choose a color with red, green, and blue values ranging from 
0 to 255. 

Color Mode, YIQ

The YIQ Color Mode allows you to choose colors based on the luminosity, chroma, and intensity of
the pixels. The advantage of this method is that it may offer a smoother transition of colors than the
other methods.

Color Mode

This is the means by which color is represented in the document: RGB, CMYK, Grayscale, 
or Indexed 256.
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Color Model, Additiv e

You can combine varying intensities of three wavelengths of light—red, green, and blue (RGB)—to
simulate the range of colors found in nature. Red, green, and blue are called the additive primaries. If
you combine 100% of red, green, and blue, you perceive the color as white. If none of the additive pri-
maries are present, you perceive black.

Color Model, Subtractiv e

If you subtract red, green, or blue from white light (100% each of red, green, and blue), you create
cyan, magenta, or yellow (CMY), respectively. For example, you perceive an object as cyan if it absorbs
(subtracts) 100% red light and reflects green and blue. Cyan, magenta, and yellow are called the sub-
tractive primaries and form the basis for printed process colors.

Color, Matte

The Matte Color refers to a color that is transparent when the image is composited. Common matte
colors are black and white. 

Color, Void

The Void Color refers to the compositing color used while using the Indexed 256 Color Table. To set
the Void Color, select the desired color, and click the Set Void Color button.

Continuous Tone

If you look closely at an original black-and-white or color photograph, you will see that the image con-
sists of solid shades of gray or color that blend smoothly. An original photograph is called continuous-
tone art.

CW

Abbreviation for Clockwise.
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Direct M ode

Direct Mode is the default work mode for xRes S.E.. All features are available in Direct Mode, however,
Direct Mode lacks the speed of xRes Mode.

Document

A document is simply an open file. The relation between the terms “document” and “file” in xRes S.E.
is similar to that found in word processing; you can open, create, or close a document which in turn is
saved to a file. 

EPS

EPS stands for Encapsulated PostScript. PostScript is a page layout language which Adobe Systems
developed about fifteen years ago. All PostScript output devices, including most Hewlett Packard and
other desktop laser printers (as well as document setters) read PostScript files.

Exporting

The menu command File > Export saves a copy of a file to a different file format including file formats
of third-party vendors. An exported document will have all objects merged and all alpha channels 
deleted.

Filter, Plug-in

A plug-in filter is a filter from another program which you wish to use in xRes S.E.. xRes S.E. supports
third-party Adobe Photoshop compatible plug-in filters such as Kai’s Power Tools and Gallery Effects.
You should store all plug-ins that you wish to use in xRes S.E. in the same folder or directory.

Filter

A filter is an effect applied to an image by a menu command that effects the pixel data in the image.
Filters such as Gaussian Blur, Add Noise, and Unsharp Masking are essential to photo-retouching.
Other filters are useful for special effects, such as Wave, Ripple, and Solarize. All of the filters in 
xRes S.E. can be applied to documents in RGB, Grayscale, or CMYK modes. Filters only apply to
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active objects in the document. If there are selections inside of the objects, the filter applies only to
areas inside of the selection. Note that filters only apply to editable channels.

Floating

You can create an object by “floating” a selection within the document. A selection may be created with
any of the masking tools (such as the Ellipse Tool or the Rectangle Tool) or the Mask Window. Once
your selection is made, use the menu command Select > Float. The pixel data within the selection is
now a freely floating object. This new object may be resized, rotated, positioned, and edited as any
other object. 

Gamma

Gamma refers to calibrating your RGB monitor for accurate colors on-screen. See Getting Started for
more information on setting gamma levels.

GIF

The GIF format is an 8-bit color format frequently used in on-line services. GIF files are typically very
small, which make them convenient for uploading and downloading data using a modem.

Global O perations

Global operations are operations performed at the document level that change the position, size, or
shape of an object. Global operations support only one level of undo.

Half tone Screens

To reproduce continuous-tone art and process colors on a commercial printing press, the image or color
must be broken into a series of dots of various sizes and colors, called a halftone screen. In electronic
publishing, scanning is the first step in converting continuous-tone art to halftone screens. Black dots
are used to recreate black-and-white images, and cyan, magenta, yellow, and black dots are used to
recreate color images on the press. When printed, small dots create light areas and large dots create
darker areas.
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Histogram

A histogram is a chart which graphically depicts the distribution of gray values in an image.

HLS

HLS is a Color Mode which xRes S.E. uses to generate Noise. It cannot be accessed by the Modify >
Color Mode command; it is a Color Mode only used while applying the Add HLS Noise command.

Image

An image is a graphic or illustration that you view using xRes S.E.. An image is viewed within a docu-
ment, which can consist of single or multiple objects.

Importing

The menu command File > Import imports an image into the active document as an object. xRes S.E.
can import an image of any file format that it can open except MMI.

Interpolation M ode

The Interpolation Mode refers to the method xRes S.E. uses to ensure that object transformation com-
mands do not cause image degradation. The Interpolation Mode is set on the General Preferences dia-
log accessed by the menu command File > Preferences > General, and it is represented by a checkbox
called “Bilinear Interpolation.” If Bilinear Interpolation is unchecked, xRes S.E. will use “Nearest
Neighbor” Interpolation.

JPEG

JPEG stands for Joint Photographic Experts Group; it is one of the most efficient compression file for-
mats. JPEG compression can vary from high quality (saving a document at low compression, such as
2:1) to low quality (saving a document at high compression, such as 100:1). 
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Local Color Cor rection

Local color correction refers to correcting color in one particular area of an image under the brush. For
local color correction, you may use the Dodge, Burn, Sponge, Smear, Noise, Tint, or Contrast brushes.
These brushes allow you to control the exact strength and location of these local color effects.

Local Operations

Local operations are performed at the object level and do not change the position, size, or shape of the
object. Local operations support multiple levels of undo.

LRG

The LRG document format was designed by Fauve Software (now part of Macromedia) to specifically
address the issue of saving a large document (10 to 20 MB or larger). An LRG document is stored in a
series of tiles, making it easy to rapidly access the image data. LRG documents are automatically opened
in xRes Mode by xRes S.E.. 

Marquee Tool Options

Marquee Tool Options are settings that affect the Rectangle Tool and the Ellipse Tool. There is no sin-
gle tool called the “Marquee Tool;” the Rectangle Tool and the Ellipse Tool are the two marquee tools.

Mask Channel

The Mask column in the Channels Window is used to mask out certain areas of the object. Clicking
the Mask checkbox for a channel masks that channel in the object. The white areas of the channel rep-
resent opaque sections of the object, black areas of the channel represent transparent areas of the object,
and gray areas of the channel represent translucent sections of the object.

Masking, Unsharp

The term “Unsharp Masking” refers to a photographic process of blurring a negative, collating it with
the original positive and then exposing the combined pieces of film. This technique allows photogra-
phers to increase the overall sharpness of an image in post-processing. With the Effects > Sharpen >
Unsharp mask command, xRes S.E. performs the same process digitally.
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MMI

The MMI (MacroMedia Image) file format is used in xRes S.E. to save all works in progress that consist
of multiple objects, whether in Direct Mode or xRes Mode. The MMI file format is used to save docu-
ments with multiple objects which you want to keep independent. An MMI file describes a document
by keeping a command set for all objects in the document. Generally, you will not want to export the
MMI file to another file format until you have finished editing the image. If you save to any format
other than MMI, all objects will be merged into the background. To change a document from MMI
format to another format, you must export it to the appropriate format; you cannot use the Save As
command. 

Noise

Noise sets a random level of hue, saturation, and brightness to each pixel affected by a Noise filter.

Object Channels

Each object can contain up to 32 channels. To view the channels of an object, use the menu command
Window > Channels. The channels for one object will be different from the channels of another object
unless the objects are duplicates.

Object, Active

An active object is the same thing as a selected object, which is represented as gray in the Objects
Window. (Inactive objects are white in the Objects Window.)

Object

An object is an individual item in a document which can be moved, altered, and even saved separately
from the document. Editing an object might consist of applying a filter to it, painting over it, or any
other operation that changes the object’s pixel data. In xRes S.E., objects in the document are displayed
in the Objects Window. When an object is selected, it is called an active object. More than one object
can be active at a time. A document can contain multiple objects. Documents with multiple objects are
often reduced to having only one (background) object when they are exported to other file formats. 
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Objects Window

The Objects Window, accessed by the menu command Window > Objects, serves as a shortcut for
many common object operations. It is used to change the opacity and Blending Mode of an object, to
change the visibility of an object, to lock objects in place, and to delete objects.

Opacity

A 100% opaque object does not reveal objects beneath it; an object with 0% opacity is clear and reveals
all of the object beneath it. The opacity of an object can be set with the opacity slider in the Objects
Window.

Operation Set

Operations performed to an object are called the operation set of an object. An operation set can
include applying filters, gradients and fills, painting, and selections. 

PhotoCD

Kodak’s PhotoCD® file format is designed for reading files from specially encoded CD’s. PhotoCD
uses a multiple resolution document representation. This is similar in concept to the LRG file format
used in xRes S.E.. 

Photoshop 3.0

The Photoshop 3.0 format was designed by Adobe Systems to store and edit multiple-object docu-
ments. 

PICT

PICT is the standard image format for Macintosh. It was designed as both a vector and raster image
format. PICT raster format is not efficient for storing large documents (10 to 20 MB and larger) and
cannot store documents with alpha channels or store documents in CMYK Color Mode. 
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PNG

Despite being less than a year old, the PNG (pronounced “ping”) file format is gaining popularity due
to its lossless compression ability, true color support, free reference implementation, and full alpha
blending. Unlike the GIF format, PNG is royalty-free.

Pressure-sensitivit y

Pressure-sensitivity refers to differing brush behavior based on the pressure placed on a pressure-sensitive
tablet. Placing more pressure on the tablet produces a larger brush, and placing less pressure on the
tablet produces a smaller brush. Pressure-sensitivity behavior allows you to simulate natural brush
behavior by giving the brush a gradual build-up in size, opacity, and blackness.

Primary Channels

The primary channels of a color mode are red, green, and blue in the RGB Color Mode; cyan, magen-
ta, yellow, and black in the CMYK Color Mode; shades of gray in the Grayscale Color Mode; and
indexed color in the Indexed 256 Color Mode.

Process Colors

Process colors are created by overlapping dots (halftone screens) of cyan, magenta, and yellow (CMY)
inks to simulate a large number of different colors. Since CMYK inks are translucent, they absorb some
colors and reflect others. To create blue, for example, you combine cyan dots (which absorb red and
reflect blue and green) and magenta dots (which absorb green and reflect blue and red). Your eyes
merge the cyan and magenta dots to perceive the color blue. You can use process colors to simulate spot
colors and to reproduce color images.

Prox y System

xRes S.E. is not a proxy system. Proxy systems are commonly used in image-editing to deal with large
files. In a proxy system, a 72 dpi file is used to represent the larger, high resolution file. The disadvan-
tage of a proxy system is that you may not zoom in and examine effects at the pixel level.
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Raster Image

See Bitmap Image. 

Resolution

When an image is scanned, the image is broken into thousands of pixels. Each pixel is typically encoded
as three numbers, corresponding to the red, green, and blue components of its color in the RGB color
space. Resolution is typically described as the pixels per square inch (ppi) of the image, as it is displayed
on the monitor.

Selected Area

The selected area is the area inside the dotted black line or flashing marquee created with the marquee
tools, FastMask, or the Mask Window.

Selections

Selections mask out an area of an object and are displayed on screen as a flashing black and white line
or “marquee.”

Speed-sensitivit y

Speed-sensitivity refers to different brush behavior based on the speed of the mouse or stylus. Moving
the mouse faster produces a thinner brush, and moving the mouse slower produces a thicker brush.

Spot Colors

Spot colors are printed on a printing press with premixed inks. (You can choose from among hundreds
of different spot-color inks.) Use spot colors to achieve an exact color match—for a corporate logo, for
example—or to add visual impact to a one, two, or three-color illustration at a nominal cost.
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Swap Disk

A swap disk is simply the amount of hard disk space xRes S.E. can use to edit your document. The
amount of swap disk space needed depends on the size of your image, the number of objects in your
image, and the number of undo levels you plan to use. 

Swatches

The term swatch refers to a small square of color on a color palette, or one of the microswatches at the
bottom of the Tools Palette which control the foreground and background colors.

TGA

Targa (TGA) is the file format of True Vision Corporation, which is best known for its video boards for
IBM PCs. TGA is an RGB-only format, and can contain only one alpha channel. This format is
referred to as 32-bit color; 3 x 8 bits for the document, plus 8 bits for the alpha channel. 

TIFF

The TIFF format was developed over ten years ago by Aldus Corporation (now part of Adobe) as a gen-
eral purpose format for raster documents. TIFF stands for Tagged Image File Format; the format con-
sists of tagged fields which are general enough to handle any type of document. 

Vector Image

A vector image is different from a bitmap image. A vector image is an image composed of shapes saved
as mathematical relations to each other. An example of a vector-based image editing program is
Macromedia FreeHand.

Work M odes

xRes S.E. supports two document-specific work modes: Direct Mode and xRes Mode. Direct Mode is
designed for images that are less than 10 to 20 MB in size and contain less than ten objects. xRes Mode
is designed for images that are greater than 10 to 20 MB in size or contain 10 or more objects.
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xRes M ode

xRes Mode is designed exclusively for the quick manipulation of high-resolution files greater than 10 to
20 MB in size, or files with 10 or more objects. 
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